[KDE] drawInTitlebar causes window to be un-resizable

RESOLVED DUPLICATE of bug 1453386

Status

()

defect
RESOLVED DUPLICATE of bug 1453386
10 months ago
8 months ago

People

(Reporter: fcheslack, Unassigned, NeedInfo)

Tracking

(Blocks 1 bug)

61 Branch
x86_64
Linux
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(2 attachments)

(Reporter)

Description

10 months ago
User Agent: Mozilla/5.0 (X11; Linux x86_64; rv:61.0) Gecko/20100101 Firefox/61.0
Build ID: 20180614135649

Steps to reproduce:

Switch browser.tabs.drawInTitlebar to true.
Try to resize the window by dragging the window border.


Actual results:

There is no window border to drag for resizing.
(Kubuntu 18.04)


Expected results:

Window should be resizable.

Updated

10 months ago
Blocks: gtktitlebar
Component: Untriaged → Widget: Gtk
OS: Unspecified → Linux
Product: Firefox → Core
Hardware: Unspecified → x86_64

Comment 1

10 months ago
Can confirm. Happening in KDE Neon as well.
Summary: drawInTitlebar causes window to be un-resizable → [KDE] drawInTitlebar causes window to be un-resizable
Can you please check if running Firefox with such env variable works for you?

MOZ_GTK_TITLEBAR_DECORATION=client
MOZ_GTK_TITLEBAR_DECORATION=system

Also can you please attach a screenshot how Firefox looks in the two modes on your system? Thanks.
Flags: needinfo?(fcheslack)

Comment 3

8 months ago
Posted image Firefox - System.png

Comment 4

8 months ago
Posted image Firefox - Client.png

Comment 5

8 months ago
Hey Martin,

It works with system/server decorations, not client decorations. Attached the two requested screenshots above.
(In reply to Wyatt Childers from comment #4)
> Created attachment 9004011 [details]
> Firefox - Client.png

This looks like a duplicate of bug 1453386.

Comment 7

8 months ago
Can confirm, it's a duplicate, good catch Jan.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 8 months ago
Resolution: --- → DUPLICATE
Duplicate of bug: 1453386
You need to log in before you can comment on or make changes to this bug.