Closed Bug 1469823 Opened 2 years ago Closed 2 years ago

A new Top Sites tile does not appear after deleting a tile

Categories

(Firefox :: New Tab Page, defect, P1)

defect

Tracking

()

VERIFIED FIXED
Firefox 63
Iteration:
62.4 - Jul 2
Tracking Status
firefox-esr52 --- unaffected
firefox-esr60 --- unaffected
firefox60 --- unaffected
firefox61 --- unaffected
firefox62 + verified
firefox63 --- verified

People

(Reporter: ppop, Assigned: andreio)

References

Details

(Keywords: regression)

User Story

https://github.com/mozilla/activity-stream/compare/c3df1302cd5033911afd2c14739978c06f502041...firefox-62b6

Attachments

(3 files)

Attached image empty_tile.gif
[Affected versions]:
- Nightly v62.0a1, Build ID 20180619220118

[Affected Platforms]:
- Windows 10 x64

[Prerequisites]:
Have enough browsing history so that the Top Sites section is populated.

[Steps to reproduce]:
1. Open the browser with the profile from prerequisites and open a new tab.
2. Hover one of the Top Sites tiles and click the "(...)" button.
3. Click the "Delete from History" option.
4. Click on "Delete From History" button.
5. Observe the Top Sites tiles.

[Expected results]:
- The next tile in queue appears in the last position.

[Actual results]:
- The tile is not replaced, instead it remains empty.

[Regression Range]:
73:29.10 INFO: Last good revision: 486bd3917deebcf6e1120859b111d200142d444d
73:29.10 INFO: First bad revision: c9ae7e47a6eff9aef6a691c638754d2f176ee0ad
73:29.10 INFO: Pushlog:
https://hg.mozilla.org/integration/autoland/pushloghtml?fromchange=486bd3917deebcf6e1120859b111d200142d444d&tochange=c9ae7e47a6eff9aef6a691c638754d2f176ee0ad

It seems that bug 1466971 has caused this behavior.

[Notes]:
- The tiles update and change correctly when dismissing the tile.
- Attached a screen recording of the issue.
Assignee: nobody → andrei.br92
I don't think the last good revision is correct. I tried it and the bug still reproduces. Can you please confirm?
Flags: needinfo?(patriciu.pop)
The first good revision for me is before https://bugzilla.mozilla.org/show_bug.cgi?id=1462427 landed.
I managed to track it down to https://github.com/mozilla/activity-stream/pull/4184
Flags: needinfo?(patriciu.pop)
Commit pushed to master at https://github.com/mozilla/activity-stream

https://github.com/mozilla/activity-stream/commit/3e29130aadfc92d10488fba3bf831367c80bac24
fix(topsites): Listen for PLACES_LINK_DELETED actions to refresh (#4201)

Fix Bug 1469823 - A new Top Sites tile does not appear after deleting a tile
Status: NEW → RESOLVED
Closed: 2 years ago
Resolution: --- → FIXED
Iteration: --- → 62.4 - Jul 2
Priority: -- → P1
Blocks: 1470588
Target Milestone: --- → Firefox 63
I have verified that the issue is no longer reproducible on the latest Nightly build (63.0a1, Build ID 20180627100027) on Windows 10 x64, Mac 10.13.5 and Ubuntu 16.04 x64.

@Ed this issue is still present in the Beta channel, should we consider uplifting this fix given that it is a regression?
Status: RESOLVED → VERIFIED
Flags: needinfo?(edilee)
OS: Windows → All
[Tracking Requested - why for this release]: Functionality regressed in Nightly 62 although interaction rate with "delete from history" for a top site probably isn't that high and the problem fixes itself
Flags: needinfo?(edilee)
Can you request uplift? I think it'd be good to fix in beta. (Somehow, I can easily imagine top sites people might want to delete. )
Flags: needinfo?(andrei.br92)
Comment on attachment 8989162 [details]
Bug 1469823 - Update Activity Stream TopSites after deleting a tile.

Approval Request Comment
[Feature/Bug causing the regression]: Regression tracked to https://github.com/mozilla/activity-stream/pull/4184
[User impact if declined]: UI behavior inconsistency
[Is this code covered by automated tests?]: Yes
[Has the fix been verified in Nightly?]: Yes https://bugzilla.mozilla.org/show_bug.cgi?id=1469823#c6
[Needs manual test from QE? If yes, steps to reproduce]: Already checked 
[List of other uplifts needed for the feature/fix]: n/a
[Is the change risky?]: No
[Why is the change risky/not risky?]: Small patch already tested in Nightly
[String changes made/needed]: n/a
Flags: needinfo?(andrei.br92)
Attachment #8989162 - Flags: approval-mozilla-beta?
Comment on attachment 8989162 [details]
Bug 1469823 - Update Activity Stream TopSites after deleting a tile.

Verified fix for a recent regression, let's uplift for beta 5. 
Ed, I assume this was reviewed in github already since it landed in nightly already.
Flags: needinfo?(edilee)
Attachment #8989162 - Flags: approval-mozilla-beta? → approval-mozilla-beta+
This has a merge conflict:

<<<<<<< local
    <em:version>2018.06.29.1011-6fefff6e</em:version>
=======
    <em:version>2018.06.22.1337-8d599e17</em:version>
>>>>>>> graft
Yes, it was reviewed and landed for nightly/master.

andreio, the commit needs to be uplifted first to our git branch for the version commit ids to make sense.
Flags: needinfo?(edilee)
OK, it can wait for beta 6, no rush to get this into beta 5 today.
User Story: (updated)
Comment on attachment 8989276 [details]
Bug 1469823 - A new Top Sites tile does not appear after deleting a tile.

This was previously reviewed by me in comment 4 and approved in comment 11.
Attachment #8989276 - Flags: review?(edilee) → review+
Blocks: 1472297
Depends on: 1470336
Comment on attachment 8989162 [details]
Bug 1469823 - Update Activity Stream TopSites after deleting a tile.

https://reviewboard.mozilla.org/r/254230/#review262044

Mostly just clearing the request as this was already reviewed and already landed. ;)
Attachment #8989162 - Flags: review?(edilee) → review+
I managed to reproduce the initial issue on 62.0a1 (2018-06-21). I also can confirm that 62.0b6 build1 (20180705151535) is verified fixed across platforms (Windows 10 x64, Ubuntu 18.04 x64, macOS 10.12.6).
Flags: qe-verify+
User Story: (updated)
Component: Activity Streams: Newtab → New Tab Page
You need to log in before you can comment on or make changes to this bug.