Hide the existing onboarding button for users in the new simplified onboarding experience cohort

VERIFIED FIXED in Firefox 62

Status

()

defect
P1
normal
VERIFIED FIXED
11 months ago
11 months ago

People

(Reporter: ursula, Assigned: ursula)

Tracking

(Blocks 1 bug)

57 Branch
Firefox 63
Points:
---
Dependency tree / graph

Firefox Tracking Flags

(firefox62+ verified, firefox63+ verified)

Details

User Story

https://github.com/mozilla/activity-stream/compare/firefox-62b6...7ff2cf8e9be924ddcad5b837b9a45542b2a9889c

Attachments

(2 attachments)

Assignee

Description

11 months ago
No description provided.
Assignee

Comment 1

11 months ago
This will need to be uplifted to Beta 62
Assignee

Updated

11 months ago
Priority: -- → P1
Assignee

Comment 3

11 months ago
[Tracking Requested - why for this release]: We do not want to show the old onboarding experience for users who are in the experiment cohort that is seeing the new simplified onboarding experience, or else it may skew the experiment data. The experiment will run in 62.

Comment 4

11 months ago
Commits pushed to master at https://github.com/mozilla/activity-stream

https://github.com/mozilla/activity-stream/commit/e91d80c762c53c078df1b29b7fdf3eb094c48876
Fix Bug 1472297 - Hide the existing onboarding button for users in the new simplified onboarding experience cohort

https://github.com/mozilla/activity-stream/commit/e10832e38d2c4f8590a3ce93d4f9438d309c0928
Merge pull request #4223 from sarracini/bug_1472297

Fix Bug 1472297 - Hide the existing onboarding button for users in the new simplified onboarding experience cohort

Updated

11 months ago
Status: NEW → RESOLVED
Last Resolved: 11 months ago
Resolution: --- → FIXED

Updated

11 months ago
Blocks: 1472302
Iteration: --- → 63.1 - July 9
Let's verify the fix too.
Flags: qe-verify+
I have verified that the issue is no longer reproducible on the latest Nightly (63.0a1, 20180701220749) on Windows 10 x64, Mac 10.13.5 and Arch Linux x64. 
The existing onboarding experience is no longer shown if "browser.newtabpage.activity-stream.asrouterOnboardingCohort" is set to a value above "0".
Status: RESOLVED → VERIFIED
Flags: qe-verify+

Updated

11 months ago
User Story: (updated)

Comment 9

11 months ago
Comment on attachment 8989277 [details]
Bug 1472297 - Hide the existing onboarding button for users in the new simplified onboarding experience cohort.

This was previously reviewed by k88hudson in comment 4.

ursula, please request beta approval.
Flags: needinfo?(usarracini)
Attachment #8989277 - Flags: review?(khudson) → review+

Updated

11 months ago
Depends on: 1469823
Assignee

Comment 10

11 months ago
Comment on attachment 8989277 [details]
Bug 1472297 - Hide the existing onboarding button for users in the new simplified onboarding experience cohort.

Approval Request Comment
[Feature/Bug causing the regression]: Existing onboarding button is seen on newtab even when new onboarding experience is on
[User impact if declined]: The user will be able to access the old onboarding tour which may skew the data for the simplified onboarding experiment
[Is this code covered by automated tests?]: No
[Has the fix been verified in Nightly?]: Yes (63.0a1, 20180701220749)
[Needs manual test from QE? If yes, steps to reproduce]:  No
[List of other uplifts needed for the feature/fix]: None
[Is the change risky?]: No
[Why is the change risky/not risky?]: Just some css to hide an element on newtab
[String changes made/needed]: None
Flags: needinfo?(usarracini)
Attachment #8989277 - Flags: approval-mozilla-beta?

Updated

11 months ago
Blocks: 1470170
Comment on attachment 8989277 [details]
Bug 1472297 - Hide the existing onboarding button for users in the new simplified onboarding experience cohort.

CSS only fix for UI issue, let's uplift for beta 7.
Attachment #8989277 - Flags: approval-mozilla-beta? → approval-mozilla-beta+

Updated

11 months ago
User Story: (updated)
I have verified that the issue is no longer reproducible on the latest Beta built (62.0b7, Build ID 20180709172241) on Windows 10 x64, Mac 10.13.6 and Arch Linux x64.
You need to log in before you can comment on or make changes to this bug.