Closed Bug 1470772 Opened Last year Closed 10 months ago

mingw-w64 builds crash on start-up after bug 1467041 landed on ESR60

Categories

(Firefox Build System :: General, enhancement, major)

60 Branch
All
Windows
enhancement
Not set
major

Tracking

(Not tracked)

RESOLVED WONTFIX

People

(Reporter: gk, Unassigned)

References

(Blocks 1 open bug)

Details

While testing our RC for our first ESR60-based alpha Tor Browser it turned out that the bundles on Windows are suddenly crashing during start-up (even before a normal Firefox would show the profile selection dialog) which was not the case when using ESR 60.0.1.

After some bisecting it turned out that the fix for bug 1467041 is causing this. For now I reverted that one for our Windows builds (+ the fix for bug 1464084 to be on the safe side).

We build with GCC 6.4.0 and binutils being essentially 2.26.1.
Triaging an ni'ing :glandium since bug 1467041 was his fix.
Flags: needinfo?(mh+mozilla)
Are --gc-sections or --icf=safe known to have problems on mingw64 or binutils 2.26.1 specifically?
Flags: needinfo?(mh+mozilla) → needinfo?(gk)
We narrowed this down to --gc-sections; but that doesn't cause a crash for me in TreeHerder, so it's either a patch Tor has that Mozilla doesn't or a slight toolchian difference between Tor and Mozilla.
Flags: needinfo?(gk)
Is the startup crash in nsComponentManagerImpl::InitializeStaticModules ?
(In reply to Nathan Froyd [:froydnj] (away until 16 July 2018) from comment #2)
> Are --gc-sections or --icf=safe known to have problems on mingw64 or
> binutils 2.26.1 specifically?

I think it's considered not well tested.
Flags: needinfo?(jacek)
The problem is https://sourceware.org/bugzilla/show_bug.cgi?id=19803. Some fixes for it made it into 2.27 which Mozilla is using but we use 2.26.1. In particular, https://sourceware.org/git/gitweb.cgi?p=binutils-gdb.git;a=commitdiff;h=4153b6dbb0f38a16fd5b583761aa811212fbb9a5 solves the crash we are seeing.

Marking this as WONTFIX on Mozilla's side and we'll look into either backporting the necessary patch or hopefully bumping our binutils version (which is unfortunately blocked on https://sourceware.org/bugzilla/show_bug.cgi?id=23466).
Status: NEW → RESOLVED
Closed: 10 months ago
Resolution: --- → WONTFIX
You need to log in before you can comment on or make changes to this bug.