Default to --enable-release when milestone is not nightly

RESOLVED FIXED in Firefox -esr60

Status

defect
RESOLVED FIXED
Last year
Last year

People

(Reporter: glandium, Assigned: glandium)

Tracking

unspecified
mozilla62
Dependency tree / graph

Firefox Tracking Flags

(firefox-esr60 fixed, firefox61 fixed, firefox62 fixed)

Details

Attachments

(1 attachment)

No description provided.
Attachment #8983669 - Flags: review?(core-build-config-reviews) → review?(nfroyd)
Comment on attachment 8983669 [details]
Bug 1467041 - Default to --enable-release when milestone is beta/release.

https://reviewboard.mozilla.org/r/249502/#review255812

I think this makes sense...but people do build beta locally from time to time (and probably release, too?), and blanket-enabling `--enable-release` doesn't seem like the right thing to do there.  E.g. do we think that `--enable-debug` (or `--disable-optimize`) are going to work OK with `--enable-release`?

It sounds like this is just for JS builds, and wouldn't affect actual Firefox builds?  Do we have any evidence that binary JS builds actually get used?  My impression is that people who want JS releases just build from source anyway.
Attachment #8983669 - Flags: review?(nfroyd)
(In reply to Nathan Froyd [:froydnj] from comment #2)
> Comment on attachment 8983669 [details]
> Bug 1467041 - Default to --enable-release when milestone is beta/release.
> 
> https://reviewboard.mozilla.org/r/249502/#review255812
> 
> I think this makes sense...but people do build beta locally from time to
> time (and probably release, too?), and blanket-enabling `--enable-release`
> doesn't seem like the right thing to do there.  E.g. do we think that
> `--enable-debug` (or `--disable-optimize`) are going to work OK with
> `--enable-release`?

All automation builds use --enable-release, so --enable-debug and --disable-optimize, which are options we use on automation, work with it. It only makes builds a little slower.

> It sounds like this is just for JS builds, and wouldn't affect actual
> Firefox builds?

Actually, I was considering doing it for Firefox too for a long time, but the problem existing for js was the straw that broke the camel's back.

>  Do we have any evidence that binary JS builds actually get
> used?  My impression is that people who want JS releases just build from
> source anyway.

Standalone js is actually used by gnome shell, so it's even packaged in linux distros.
Attachment #8983669 - Flags: review?(nfroyd)
Comment on attachment 8983669 [details]
Bug 1467041 - Default to --enable-release when milestone is beta/release.

https://reviewboard.mozilla.org/r/249502/#review256054
Attachment #8983669 - Flags: review?(nfroyd) → review+
Blocks: 1467039
Pushed by mh@glandium.org:
https://hg.mozilla.org/integration/autoland/rev/9f71934b9849
Default to --enable-release when milestone is beta/release. r=froydnj
No longer blocks: 1467039
Comment on attachment 8983669 [details]
Bug 1467041 - Default to --enable-release when milestone is beta/release.

Approval Request Comment
[User impact if declined]: Longstanding issue that builds not using --enable-release may not be built in the prefered way. For downstream Firefox builds, that's mostly alleviated by the fact that MOZILLA_OFFICIAL (which enables other Firefox official stuff so is more or less expected to be used downstream) implies --enable-release already. For non-Firefox code (e.g. standalone spidermonkey), this tends to be more of a problem. Requesting for ESR for standalone spidermonkey.
[Is this code covered by automated tests?]: N/A
[Has the fix been verified in Nightly?]: N/A
[Needs manual test from QE? If yes, steps to reproduce]: N/A
[Is the change risky?]: No
[Why is the change risky/not risky?]: For mozilla.org produced builds, it's a noop because we get --enable-release set from it being implied by MOZ_AUTOMATION, which is set on all build jobs that create something we ship (and, if it's not on some job for some reason, it should anyways, and this change would fix this). For local developers building from the beta or esr trees, that just means slightly slower builds. For downstreams, that means they can't mess up by forgetting --enable-release.
[String changes made/needed]: N/A
Attachment #8983669 - Flags: approval-mozilla-esr60?
Attachment #8983669 - Flags: approval-mozilla-beta?
https://hg.mozilla.org/mozilla-central/rev/9f71934b9849
Status: NEW → RESOLVED
Closed: Last year
Resolution: --- → FIXED
Target Milestone: --- → mozilla62
Comment on attachment 8983669 [details]
Bug 1467041 - Default to --enable-release when milestone is beta/release.

Bug fix for downstream builders of Mozilla code. No-op change for official Firefox builds. Approved for 61.0b13 and ESR 60.1.
Attachment #8983669 - Flags: approval-mozilla-esr60?
Attachment #8983669 - Flags: approval-mozilla-esr60+
Attachment #8983669 - Flags: approval-mozilla-beta?
Attachment #8983669 - Flags: approval-mozilla-beta+
Depends on: 1470772
You need to log in before you can comment on or make changes to this bug.