Closed Bug 1471137 Opened 6 years ago Closed 6 years ago

Cookies not sent with SameSite=Strict for links from an atom feed to the same site

Categories

(Firefox Graveyard :: RSS Discovery and Preview, defect, P5)

60 Branch
defect

Tracking

(Not tracked)

RESOLVED WORKSFORME

People

(Reporter: brmichel, Unassigned)

References

Details

User Agent: Mozilla/5.0 (X11; Ubuntu; Linux x86_64; rv:60.0) Gecko/20100101 Firefox/60.0
Build ID: 20180607193903

Steps to reproduce:

1. Navigate to https://linuxfr.org/
2. Login on this site
3. Click on "Flux atom des dépêches" (it's a link to an atom feed on the same domain linuxfr.org)
4. Click on the title of an atom entry (it's a link to a page on linuxfr.org)


Actual results:

On the page loaded after 4, I'm not logged in because the cookies have not been sent.


Expected results:

I'm expect the cookies to be sent. The cookies are set with SameSite=Strict, but it shouldn't block sending the cookies as we have only navigated from the same site (https://linuxfr.org).
Component: Untriaged → RSS Discovery and Preview
Same cause as bug 1172234.
See Also: → 1172234
Status: UNCONFIRMED → NEW
Ever confirmed: true
Priority: -- → P5
We no longer open this in the browser, which fixes this issue, in a sense...
Status: NEW → RESOLVED
Closed: 6 years ago
Resolution: --- → WORKSFORME
Product: Firefox → Firefox Graveyard
You need to log in before you can comment on or make changes to this bug.