Switch relengapi URLs to new mozilla-releng/services URLs and also deprecate clobberer and archiver services

RESOLVED FIXED

Status

task
RESOLVED FIXED
10 months ago
9 days ago

People

(Reporter: garbas, Assigned: garbas)

Tracking

Details

Attachments

(15 attachments, 3 obsolete attachments)

46 bytes, text/x-phabricator-request
jlund
: review+
Details | Review
58 bytes, text/x-github-pull-request
markco
: review+
Details | Review
47 bytes, text/x-github-pull-request
emorley
: review+
Details | Review
48 bytes, text/x-github-pull-request
emceeaich
: review+
emceeaich
: checked-in+
Details | Review
61 bytes, patch
April
: review+
April
: feedback-
April
: checked-in+
Details | Diff | Splinter Review
46 bytes, text/x-phabricator-request
rail
: review+
Details | Review
54 bytes, text/x-github-pull-request
markco
: review+
Details | Review
54 bytes, text/x-github-pull-request
wcosta
: review+
Details | Review
65 bytes, text/x-github-pull-request
wcosta
: review+
Details | Review
39 bytes, text/x-github-pull-request
Ms2ger
: review+
Details | Review
49 bytes, patch
tsmith
: review+
tsmith
: checked-in+
Details | Diff | Splinter Review
51 bytes, patch
tsmith
: review+
tsmith
: checked-in+
Details | Diff | Splinter Review
56 bytes, text/plain
truber
: review+
truber
: checked-in+
Details
46 bytes, text/x-phabricator-request
jlund
: review+
Details | Review
5.87 KB, patch
rail
: review+
Details | Diff | Splinter Review
Comment hidden (empty)
(Assignee)

Comment 1

10 months ago
old relengapi URLs

    https://api.pub.build.mozilla.org/<service>

where <service> is one of:
 - mapper
 - tooltool
 - treestatus

should be replaced with

    https://<service>.mozilla-releng.net

deprecated services are:
 - archiver
 - clobberer
(Assignee)

Comment 3

10 months ago
:jlund I added you as a reviewer for the patch (submitted via phabricator) I will land it once you approve.
Flags: needinfo?(jlund)
Comment on attachment 8988118 [details]
switch relengapi URLs to new mozilla-releng/services URLs

Jordan Lund (:jlund) has approved the revision.

https://phabricator.services.mozilla.com/D1842
Attachment #8988118 - Flags: review+
Flags: needinfo?(jlund)
Attachment #8988229 - Flags: review?(mcornmesser) → review+
(Assignee)

Updated

10 months ago
Summary: switch relengapi URLs to new mozilla-releng/services URLs → Switch relengapi URLs to new mozilla-releng/services URLs and also deprecase clobberer and archiver services

Updated

10 months ago
Assignee: relops → rgarbas
Summary: Switch relengapi URLs to new mozilla-releng/services URLs and also deprecase clobberer and archiver services → Switch relengapi URLs to new mozilla-releng/services URLs and also deprecate clobberer and archiver services
(Assignee)

Comment 8

10 months ago
Attachment #8988744 - Flags: review?(emorley)
(Assignee)

Updated

10 months ago
Attachment #8988743 - Attachment is obsolete: true

Updated

10 months ago
Attachment #8988744 - Flags: review?(emorley) → review+
(Assignee)

Comment 10

10 months ago
Posted file new treestatus url
Attachment #8988751 - Flags: review?(ehumphries)
(Assignee)

Comment 13

10 months ago
Attachment #8988777 - Flags: review?(mcornmesser)
(Assignee)

Comment 16

10 months ago
Attachment #8988796 - Flags: review?(bstack)
(Assignee)

Comment 17

10 months ago
Attachment #8988811 - Flags: review?(Ms2ger)
(Assignee)

Comment 18

10 months ago
Attachment #8988812 - Flags: review?(jschwartzentruber)
(Assignee)

Comment 20

10 months ago
Attachment #8988819 - Flags: review?(jschwartzentruber)
Comment on attachment 8988764 [details]
Bug 1471541 - switch to new tooltool url, r=rail

Rail Aliiev [:rail] ⌚️ET has approved the revision.

https://phabricator.services.mozilla.com/D1880
Attachment #8988764 - Flags: review+
Comment on attachment 8988814 [details] [diff] [review]
https://github.com/MozillaSecurity/ffpuppet/pull/35

Review of attachment 8988814 [details] [diff] [review]:
-----------------------------------------------------------------

PR merged.
Attachment #8988814 - Attachment is patch: true
Attachment #8988814 - Attachment mime type: text/x-github-pull-request → text/plain
Attachment #8988814 - Flags: review?(twsmith) → review+

Updated

10 months ago
Attachment #8988758 - Attachment is patch: true
Attachment #8988758 - Attachment mime type: text/x-github-pull-request → text/plain
Attachment #8988758 - Flags: review?(april)
Attachment #8988758 - Flags: review+
Attachment #8988758 - Flags: feedback-
Attachment #8988758 - Flags: checked-in+

Updated

10 months ago
Attachment #8988796 - Flags: review?(bstack) → review?(pmoore)

Updated

10 months ago
Attachment #8988812 - Attachment is patch: true
Attachment #8988812 - Attachment mime type: text/x-github-pull-request → text/plain
Attachment #8988812 - Flags: review?(jschwartzentruber)
Attachment #8988812 - Flags: review+
Attachment #8988812 - Flags: checked-in+

Updated

10 months ago
Attachment #8988814 - Flags: checked-in?

Updated

10 months ago
Attachment #8988814 - Flags: checked-in? → checked-in+
(Assignee)

Updated

10 months ago
Duplicate of this bug: 1336363
Attachment #8988784 - Flags: review?(wcosta) → review+
Attachment #8988789 - Flags: review?(wcosta) → review+
Comment on attachment 8988819 [details]
https://github.com/MozillaSecurity/domfuzz/pull/18/files

Merged. Thanks!
Attachment #8988819 - Flags: review?(jschwartzentruber)
Attachment #8988819 - Flags: review+
Attachment #8988819 - Flags: checked-in+
(Assignee)

Updated

10 months ago
Attachment #8988796 - Attachment is obsolete: true
Attachment #8988796 - Flags: review?(pmoore)
Comment on attachment 8989547 [details]
Bug 1471541 - switch to new tooltool url, r=jlund

Jordan Lund (:jlund) has approved the revision.

https://phabricator.services.mozilla.com/D1930
Attachment #8989547 - Flags: review+
(Assignee)

Comment 29

10 months ago
This concludes all the renaming. Thank you everybody for the help!
Status: NEW → RESOLVED
Last Resolved: 10 months ago
Resolution: --- → FIXED
(Assignee)

Comment 32

9 months ago
It was brought to my attention that I should also change url in esr60 tree. i'm reopening this issue.
Status: RESOLVED → REOPENED
Resolution: FIXED → ---
Attachment #8993302 - Attachment is obsolete: true
(Assignee)

Comment 34

9 months ago
:rail this is the patch i was talking to you about. if you have time, i would like to know how to land this patch myself (in theory i know, but i like to look over shoulder the first time) so that i don't bother you with this in the future. thank you!
Attachment #8993600 - Flags: review?(rail)
Comment on attachment 8993600 [details] [diff] [review]
Bug 1471541 - switch to new tooltool url, r=rail

Review of attachment 8993600 [details] [diff] [review]:
-----------------------------------------------------------------

LGTM

I can land this on Monday, just in case.
Attachment #8993600 - Flags: review?(rail) → review+
(Assignee)

Comment 36

9 months ago
:rail thank you!
(Assignee)

Updated

9 days ago
Status: REOPENED → RESOLVED
Last Resolved: 10 months ago9 days ago
Resolution: --- → FIXED
You need to log in before you can comment on or make changes to this bug.