Reparent roots on startup

RESOLVED FIXED in Firefox 63

Status

()

enhancement
P2
normal
RESOLVED FIXED
10 months ago
8 months ago

People

(Reporter: mak, Assigned: lina)

Tracking

(Blocks 2 bugs)

unspecified
mozilla63
Points:
---
Dependency tree / graph

Firefox Tracking Flags

(firefox63 fixed)

Details

(Whiteboard: [fxsearch])

Attachments

(1 attachment)

On startup when we read roots, we can check their parents and reparent them.
We could measure this with telemetry too.
Need to take care of Sync though.
(Assignee)

Comment 1

10 months ago
Misparented roots are going to confuse the mirror, too, and I suspect they're causing bug 1471988. Stealing this bug. :-)
Assignee: nobody → kit
See Also: → 1453994, 1471988
(Assignee)

Comment 2

10 months ago
This patch fixes up user content roots that aren't children of the
Places root. This patch also changes the Sync mirror to always prefer
the local root structure when merging, since the roots on the server
might be wrong.
(Assignee)

Updated

10 months ago
Blocks: 1433177
Comment on attachment 8989032 [details]
Reparent Places roots on startup and handle misparented roots in the Sync mirror.

Marco Bonardo [::mak] has approved the revision.

https://phabricator.services.mozilla.com/D1904
Attachment #8989032 - Flags: review+

Comment 5

10 months ago
Pushed by kcambridge@mozilla.com:
https://hg.mozilla.org/integration/autoland/rev/ddb83501ed00
Reparent Places roots on startup and handle misparented roots in the Sync mirror. r=mak

Comment 6

10 months ago
Backout by csabou@mozilla.com:
https://hg.mozilla.org/integration/autoland/rev/18a6d392999f
Backed out changeset ddb83501ed00 for xpcshell failures on test_current_from_v43. CLOSED TREE
Backed out for xpcshell failures on test_current_from_v43

Push with failures: https://treeherder.mozilla.org/#/jobs?repo=autoland&filter-resultStatus=testfailed&filter-resultStatus=busted&filter-resultStatus=exception&tochange=18a6d392999fb556fd429ce542f49fd5ffd3655f&filter-searchStr=xpc&fromchange=ddb83501ed00ac36bc2cdca537882328d2046394&selectedJob=186728164

Failure log: https://treeherder.mozilla.org/logviewer.html#?job_id=186728164&repo=autoland&lineNumber=2076

Backout link: https://hg.mozilla.org/integration/autoland/rev/18a6d392999fb556fd429ce542f49fd5ffd3655f

[task 2018-07-05T22:54:53.189Z]     INFO -  Retrying tests that failed when run in parallel.
[task 2018-07-05T22:54:53.206Z]     INFO -  TEST-START | toolkit/components/places/tests/migration/test_current_from_v43.js
[task 2018-07-05T22:54:53.592Z]  WARNING -  TEST-UNEXPECTED-FAIL | toolkit/components/places/tests/migration/test_current_from_v43.js | xpcshell return code: 0
[task 2018-07-05T22:54:53.592Z]     INFO -  TEST-INFO took 386ms
[task 2018-07-05T22:54:53.592Z]     INFO -  >>>>>>>
[task 2018-07-05T22:54:53.594Z]     INFO -  (xpcshell/head.js) | test MAIN run_test pending (1)
[task 2018-07-05T22:54:53.595Z]     INFO -  (xpcshell/head.js) | test run_next_test 0 pending (2)
[task 2018-07-05T22:54:53.595Z]     INFO -  (xpcshell/head.js) | test MAIN run_test finished (2)
[task 2018-07-05T22:54:53.596Z]     INFO -  running event loop
[task 2018-07-05T22:54:53.596Z]     INFO -  "CONSOLE_MESSAGE: (info) No chrome package registered for chrome://branding/locale/brand.properties"
[task 2018-07-05T22:54:53.597Z]     INFO -  toolkit/components/places/tests/migration/test_current_from_v43.js | Starting setup
[task 2018-07-05T22:54:53.597Z]     INFO -  (xpcshell/head.js) | test setup pending (2)
[task 2018-07-05T22:54:53.597Z]     INFO -  (xpcshell/head.js) | test run_next_test 0 finished (2)
Flags: needinfo?(kit)

Comment 8

10 months ago
Pushed by kcambridge@mozilla.com:
https://hg.mozilla.org/integration/autoland/rev/4d0ff7720f70
Reparent Places roots on startup and handle misparented roots in the Sync mirror. r=mak
(Assignee)

Comment 9

10 months ago
Sorry about that, rebased and fixed the test. :-)

https://treeherder.mozilla.org/#/jobs?repo=try&revision=2786dd656a68327ba6ea846e406b69803f1f4649
Flags: needinfo?(kit)

Comment 10

10 months ago
bugherder
https://hg.mozilla.org/mozilla-central/rev/4d0ff7720f70
Status: NEW → RESOLVED
Last Resolved: 10 months ago
Resolution: --- → FIXED
Target Milestone: --- → mozilla63
Blocks: 1481795
Duplicate of this bug: 1225464
You need to log in before you can comment on or make changes to this bug.