Using bookmark mirror sometimes causes unwanted reversion of bookmark operations

RESOLVED DUPLICATE of bug 1474033

Status

()

defect
RESOLVED DUPLICATE of bug 1474033
Last year
10 months ago

People

(Reporter: Tobias.Marty, Unassigned)

Tracking

(Blocks 1 bug)

63 Branch
x86_64
Windows 10
Points:
---
Dependency tree / graph

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 obsolete attachment)

Reporter

Description

Last year
User Agent: Mozilla/5.0 (Windows NT 10.0; Win64; x64; rv:63.0) Gecko/20100101 Firefox/63.0
Build ID: 20180702220046

Steps to reproduce:

While using bookmark mirror I noticed that after a while Sync was always reverting one of my bookmark operations. 

I moved ten bookmarks to another folder by dragging and dropping. That operation was completed, even after manually triggering a sync. Then some minutes later I noticed that the bookmarks were moved back to their original folder in 'other bookmarks'. 

I could only solve this by disabling services.sync.engine.bookmarks.buffer. Moving the bookmarks multiple times was always reverted.
Reporter

Updated

Last year
OS: Unspecified → Windows 10
Hardware: Unspecified → x86_64
Blocks: 1433177
Component: Places → Sync
Product: Toolkit → Firefox
Thanks for the report! Could you please enable trace logging (install https://addons.mozilla.org/en-US/firefox/addon/about-sync/, then choose "Actively looking for issues and want detailed logging" under "General Options" in about:sync), try moving the bookmarks again, and attach the logs to this bug?
Flags: needinfo?(Tobias.Marty)
Reporter

Comment 2

Last year
I tried to move some bookmarks again and ran into problems. 
The attached sync logs should show bookmarks that aren't in the folders they are supposed to be in, that aren't in correct order and that don't get synced with synced Firefox installations where bookmark mirror isn't enabled (don't know if that's to be expected, I guess not). 

You probably noticed I also filed a performance bug. While trying to move these bookmarks around I got very long complete hangs of Firefox with slow sql statements in 
/* do not warn (bug 487594) */ SELECT GROUP_CONCAT(tag_title, :private) FROM ( SELECT t.title AS tag_title FROM moz_bookmarks b JOIN moz_bookmarks t ON t.id = +b.parent WHERE b.fk = (SELECT id FROM moz_places WHERE url_hash = hash(:page_url) AND url = :page_url) AND t.parent = :tags_folder ORDER BY t.title COLLATE NOCASE ASC ) /* places.sqlite */ 
(35 hits, 3789 ms)
and
UPDATE moz_places SET frecency = CALCULATE_FRECENCY(id) WHERE frecency = -1 /* places.sqlite */ 
(3 hits, 213901 ms).
Flags: needinfo?(Tobias.Marty)
Reporter

Comment 3

Last year
Posted file sync_log_moving_bookmarks (obsolete) —
Oh, I'm sorry, I meant the Sync logs, not the validation export. There's an option in About Sync to download the logs as a zip file, under "Log Files and Diagnostics", or you can see them in `about:sync-log`. But that `CALCULATE_FRECENCY` statement suggests bug 1463938, where we try to recalculate all frecencies at the end of the sync. I wonder if the other statements are queuing up behind it.

Could you please run this query in About Sync (there's a "SQL" tab under "bookmarks" in `about:sync`) to see how many URLs need new frecencies?

SELECT count(*) FROM moz_places WHERE frecency = -1
Reporter

Updated

Last year
Attachment #8989476 - Attachment is obsolete: true
Reporter

Comment 5

Last year
The file is 38 MB, I uploaded it here: https://send.firefox.com/download/4405d8d793/#uv-XmJt_C9KgqOYB6X3p9w

That statement gives me 44 URLs.
Reporter

Comment 7

11 months ago
I can't reproduce this anymore. I think this might be fixed by bug 1474033.
Cool, I'll close this out, but please reopen if you see the issue again. Thanks for testing~!
Status: UNCONFIRMED → RESOLVED
Closed: 11 months ago
No longer depends on: 1474033
Resolution: --- → DUPLICATE
Duplicate of bug: 1474033
Reporter

Comment 9

10 months ago
I am syncing a new Nightly installation with bookmark buffer now and I am seeing strange things happening to my bookmarks again. Some bookmarks get put in a different folder on the new installation and some regularly change their order.
You need to log in before you can comment on or make changes to this bug.