Missing semicolon at DBusRemoteClient.cpp

RESOLVED FIXED in Firefox -esr60

Status

defect
RESOLVED FIXED
11 months ago
27 days ago

People

(Reporter: stransky, Assigned: stransky)

Tracking

({regression})

Trunk
mozilla63
Dependency tree / graph

Firefox Tracking Flags

(firefox-esr52 unaffected, firefox-esr6063+ fixed, firefox61 unaffected, firefox62 fixed, firefox63 fixed)

Details

Attachments

(1 attachment)

Comment hidden (mozreview-request)

Comment 2

11 months ago
mozreview-review
Comment on attachment 8990687 [details]
Bug 1474265 - Add missing semicolon at DBusRemoteClient.cpp,

https://reviewboard.mozilla.org/r/255772/#review262476
Attachment #8990687 - Flags: review?(jhorak) → review+

Comment 3

11 months ago
Pushed by stransky@redhat.com:
https://hg.mozilla.org/integration/autoland/rev/f1f6e434d3a8
Add missing semicolon at DBusRemoteClient.cpp, r=jhorak

Comment 4

11 months ago
bugherder
https://hg.mozilla.org/mozilla-central/rev/f1f6e434d3a8
Status: NEW → RESOLVED
Last Resolved: 11 months ago
Resolution: --- → FIXED
Target Milestone: --- → mozilla63
Assignee

Comment 5

11 months ago
Comment on attachment 8990687 [details]
Bug 1474265 - Add missing semicolon at DBusRemoteClient.cpp,

Approval Request Comment
[Feature/Bug causing the regression]: Bug 1472611
[User impact if declined]: Build failure on Wayland
[Is this code covered by automated tests?]: no
[Has the fix been verified in Nightly?]: yes
[Needs manual test from QE? If yes, steps to reproduce]: no
[List of other uplifts needed for the feature/fix]: Bug 1472611
[Is the change risky?]: no
[Why is the change risky/not risky?]: Wayland only fix, Mozilla does not ship wayland builds
[String changes made/needed]: none
Attachment #8990687 - Flags: approval-mozilla-beta?
Is this marked as not affecting 62 because we only need to uplift it if we uplift the patch from bug 1472611?
Flags: needinfo?(stransky)
Comment on attachment 8990687 [details]
Bug 1474265 - Add missing semicolon at DBusRemoteClient.cpp,

Let's take this for beta 8, we want Firefox builds to work well on Linux.
Attachment #8990687 - Flags: approval-mozilla-beta? → approval-mozilla-beta+
Assignee

Comment 9

11 months ago
(In reply to Liz Henry (:lizzard) (needinfo? me) from comment #6)
> Is this marked as not affecting 62 because we only need to uplift it if we
> uplift the patch from bug 1472611?

Yes, that's correct. Sorry for the complications.
Flags: needinfo?(stransky)
Assignee

Updated

8 months ago
Duplicate of this bug: 1498477
Assignee

Comment 11

8 months ago
Comment on attachment 8990687 [details]
Bug 1474265 - Add missing semicolon at DBusRemoteClient.cpp,

[ESR Uplift Approval Request]

If this is not a sec:{high,crit} bug, please state case for ESR consideration: Build failure on Linux/cairo-gtk3-wayland target.

User impact if declined: Build failure on Linux/cairo-gtk3-wayland target.

Fix Landed on Version: 62

Risk to taking this patch: Low

Why is the change risky/not risky? (and alternatives if risky): The code is used by distros only, Mozilla official builds do not use cairo-gtk3-wayland target. This is also a reason why it passes try.

String or UUID changes made by this patch: none
Attachment #8990687 - Flags: approval-mozilla-esr60?
Comment on attachment 8990687 [details]
Bug 1474265 - Add missing semicolon at DBusRemoteClient.cpp,

arguably npotb, but in any case, a=me, for 60.3.0.
Attachment #8990687 - Flags: approval-mozilla-esr60? → approval-mozilla-esr60+

Updated

27 days ago
Product: Core → Core Graveyard
You need to log in before you can comment on or make changes to this bug.