Can't build DBusRemoteClient with --enable-default-toolkit=cairo-gtk3-wayland

RESOLVED DUPLICATE of bug 1474265

Status

()

defect
RESOLVED DUPLICATE of bug 1474265
6 months ago
6 months ago

People

(Reporter: ashie, Assigned: ashie)

Tracking

60 Branch
Unspecified
Linux
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment)

(Assignee)

Description

6 months ago
When I build firefox-60.2.2esr with --enable-default-toolkit=cairo-gtk3-wayland, I got a following build error:

> 22:59.54 /build/rzg1-vlp2.1/build/tmp/work/cortexa15hf-neon-poky-linux-gnueabi/firefox/60.2.2esr-r0/firefox-60.2.2/widget/xremoteclient/DBusRemoteClient.cpp: In member function 'bool DBusRemoteClient::GetRemoteDestinationName(const char*, const char*, nsCString&)':
> 22:59.54 /build/rzg1-vlp2.1/build/tmp/work/cortexa15hf-neon-poky-linux-gnueabi/firefox/60.2.2esr-r0/firefox-60.2.2/widget/xremoteclient/DBusRemoteClient.cpp:146:5: error: expected ';' before '}' token
> 22:59.54      }
> 22:59.54      ^
> 22:59.64 /build/rzg1-vlp2.1/build/tmp/work/cortexa15hf-neon-poky-linux-gnueabi/firefox/60.2.2esr-r0/firefox-60.2.2/config/rules.mk:1047: recipe for target 'DBusRemoteClient.o' failed
> 22:59.64 make[4]: *** [DBusRemoteClient.o] Error 1
(Assignee)

Updated

6 months ago
Blocks: 1472611
(Assignee)

Comment 1

6 months ago
Assignee: nobody → ashie
Attachment #9016553 - Flags: review?(stransky)
Thanks, it's a duplicate of Bug 1474265, let's nominate the patch there for uplift.
Status: NEW → RESOLVED
Last Resolved: 6 months ago
Resolution: --- → DUPLICATE
Duplicate of bug: 1474265
Attachment #9016553 - Flags: review?(stransky)
You need to log in before you can comment on or make changes to this bug.