Last Comment Bug 147446 - [FIX] A map definition inside a table and outside the tr element will add an extra space to the table
: [FIX] A map definition inside a table and outside the tr element will add an ...
Status: RESOLVED FIXED
: compat, testcase
Product: Core
Classification: Components
Component: HTML: Parser (show other bugs)
: Trunk
: x86 All
: -- normal (vote)
: ---
Assigned To: Mats Palmgren (vacation)
: Moied
Mentors:
Depends on:
Blocks: html4.01
  Show dependency treegraph
 
Reported: 2002-05-27 14:46 PDT by Roger C. Soares
Modified: 2014-04-26 02:23 PDT (History)
8 users (show)
See Also:
Crash Signature:
(edit)
QA Whiteboard:
Iteration: ---
Points: ---
Has Regression Range: ---
Has STR: ---


Attachments
Testcase showing a map inside a table and a br inside a table (325 bytes, text/html)
2002-05-27 14:51 PDT, Roger C. Soares
no flags Details
Testcase #2 (3.70 KB, text/html)
2003-06-22 11:48 PDT, Mats Palmgren (vacation)
no flags Details
Patch rev. 1 (1.61 KB, patch)
2003-06-22 12:24 PDT, Mats Palmgren (vacation)
harishd: review+
dbaron: superreview+
Details | Diff | Splinter Review

Description Roger C. Soares 2002-05-27 14:46:57 PDT
A table will have an extra space if a map is defined inside the table (see URL -
the first frame).

For other elements, the element is moved to outside the table and the table is
rendered fine.
Comment 1 Roger C. Soares 2002-05-27 14:51:08 PDT
Created attachment 85197 [details]
Testcase showing a map inside a table and a br inside a table

The map element will cause an extra space in the table, the br element will be
move to before the table.
Comment 2 Boris Zbarsky [:bz] 2002-05-27 16:08:38 PDT
To parser.
Comment 3 /\/\arcio Galli 2002-06-03 13:52:15 PDT
Harish, 

We raised this one from the Evangelism Latin America effort. The site is part of
Major AOL partner in Brazil (Itau Bank). 
Comment 4 /\/\arcio Galli 2002-06-25 18:01:18 PDT
I see. If I use the <map> element the generated DOM is: 
-------------------------------------------->
<table bgcolor="green">
<map></map>
<tbody>...

When I replace to another element (For example a div element), I have:
-------------------------->
<div></div>
<table bgcolor="green">
<tbody>...

Harish, 

Do you think we can consider the MAP like the other elements?
Comment 5 Christopher Hoess (gone) 2003-03-16 15:13:13 PST
The URL has been redesigned to eliminate the problem.
Comment 6 Mats Palmgren (vacation) 2003-06-22 11:48:44 PDT
Created attachment 126244 [details]
Testcase #2
Comment 7 Mats Palmgren (vacation) 2003-06-22 12:10:46 PDT
Taking this since I have a simple fix for it...
Comment 8 Mats Palmgren (vacation) 2003-06-22 12:24:54 PDT
Created attachment 126246 [details] [diff] [review]
Patch rev. 1

Remove MAP as valid child of TABLE/THEAD/TFOOT
Comment 9 Mats Palmgren (vacation) 2003-06-22 12:36:02 PDT
The patch makes us compatible with NS4 and IE5.5/IE6.  This is also the right
thing to do with respect to HTML 4 spec.  Opera7 have *exactly* the same bug
as Mozilla currently has though.  I have tested this extensively; the regression
tests pass, the top100 list pass (which means none of them depend on this bug).
I have checked all Parser bugs that mentions "map" and "table" in the same bug
and found no regressions (among them I found bug 58942 which fixed the same bug
for TR).  I also checked all Layout bugs matching "<map" and "table" and saw
no problems.
Comment 10 harishd 2003-06-24 15:48:54 PDT
Comment on attachment 126246 [details] [diff] [review]
Patch rev. 1

r=harishd
Comment 11 Bernd 2004-10-31 22:56:08 PST
Mats what is the status of this patch? Seems like it has a review :-)
Comment 12 Stephen Donner [:stephend] 2005-01-23 21:42:12 PST
Mats, is there still interest in this patch?
Comment 13 Mats Palmgren (vacation) 2005-01-25 17:15:10 PST
Checked in 2005-01-25 16:40 PDT.

-> FIXED

Note You need to log in before you can comment on or make changes to this bug.