Closed Bug 1474784 Opened Last year Closed Last year

Tooltip for the "Home" button in the navigation toolbar is not styled (and, tooltip for sidebar contents is also unstyled when extensions.webextensions.remote=false)

Categories

(Firefox :: Toolbars and Customization, defect)

defect
Not set

Tracking

()

RESOLVED DUPLICATE of bug 1474538
Firefox 63

People

(Reporter: yuki, Unassigned)

Details

(Keywords: regression)

Attachments

(1 file)

# Description

Sidebar-based addons can provide tooltips via HTML's "title" attribute same as webapps, but now it is shown with unstyled appearance - default font size and  transparent background.

# Steps to reproduce

 1. Start Nightly 63.0a1.
 2. Install Tree Style Tab (or something other addon providing custom
    sidebar panel.)
 3. Show the sidebar panel for the addon.
    For example, hit F1 key for TST.
 4. Open something page with very long title, for example: 
    https://github.com/mozilla/mozregression/pull/465
 5. Put the mouse cursor onto the item for the page in the sidebar,
    and wait for a while.

# Expected result

The page title is shown as a tooltip, styled like as regular tooltip (ex. on toolbar buttons)

# Actual result

The page title is shown as a floating text, with no background color.
(Please see the attached screenshot also.)
Summary: Tooltip for sidebar contents is not styled → Tooltip for sidebar contents is not styled when extensions.webextensions.remote=false
Sorry I missed an important condition. To reproduce the problem, I need to set "extensions.webextensions.remote" to "false". It is false by default on Linux, but true by default on Windows.
Mozregression's result says:

# The last good build

app_name: firefox
build_date: 2018-07-09 14:02:55.353000
build_file: C:\Users\clearcode\.mozilla\mozregression\persist\140937d55bd0--mozilla-inbound--target.zip
build_type: inbound
build_url: https://queue.taskcluster.net/v1/task/eyRSVJsJT4WGMysouGUC_w/runs/0/artifacts/public%2Fbuild%2Ftarget.zip
changeset: 140937d55bd0babaaaebabd11e171d2682a8ae01
pushlog_url: https://hg.mozilla.org/integration/mozilla-inbound/pushloghtml?fromchange=140937d55bd0babaaaebabd11e171d2682a8ae01&tochange=e711420b85f70b765c7c69c80a478250bc886229
repo_name: mozilla-inbound
repo_url: https://hg.mozilla.org/integration/mozilla-inbound
task_id: eyRSVJsJT4WGMysouGUC_w

# The first bad build

app_name: firefox
build_date: 2018-07-09
build_file: C:\Users\clearcode\.mozilla\mozregression\persist\2018-07-09--mozilla-central--firefox-63.0a1.en-US.win64.zip
build_type: nightly
build_url: https://archive.mozilla.org/pub/firefox/nightly/2018/07/2018-07-09-22-12-47-mozilla-central/firefox-63.0a1.en-US.win64.zip
changeset: 19edc7c22303a37b7b5fea326171288eba17d788
pushlog_url: https://hg.mozilla.org/mozilla-central/pushloghtml?fromchange=ffb7b5015fc331bdc4c5e6ab52b9de669faa8864&tochange=19edc7c22303a37b7b5fea326171288eba17d788
repo_name: mozilla-central
repo_url: https://hg.mozilla.org/mozilla-central
Component: Frontend → Toolbars and Customization
Keywords: regression
OS: Unspecified → All
Product: WebExtensions → Firefox
Hardware: Unspecified → All
Summary: Tooltip for sidebar contents is not styled when extensions.webextensions.remote=false → Tooltip for the "Home" button in the navigation toolbar is not styled (and, tooltip for sidebar contents is also unstyled when extensions.webextensions.remote=false)
Target Milestone: --- → Firefox 63
After more research, I've realized that this problem affects to more tooltips.

 * In the tab bar
   - "List all tabs" button
 * In the navigation toolbar
   - "Home" button
   - Elements in the location bar (security information, "Show History" button,
     "..." button, "Pocket" button and "Bookmark" button)
   - The hamburger button
     - "Sign in to Sync", "Tracking Protection", and more items under the hamburger menu
   - Toolbar buttons added by addons
https://hg.mozilla.org/integration/mozilla-inbound/rev/e711420b85f7
This change seems expecting that style rules loaded from toolkit/content/widgets.css to be applied to all XUL <tooltip>s. However, it is actually applied only for <tooltip>s defined in browser.xul, and <tooltip default="true"> element dynamically inserted by Gecko itself looks not applied.
Status: NEW → RESOLVED
Closed: Last year
Resolution: --- → DUPLICATE
Duplicate of bug: 1474538
You need to log in before you can comment on or make changes to this bug.