Closed Bug 1474925 Opened Last year Closed Last year

TimePicker swipe not possible in landscape

Categories

(Firefox for Android :: General, defect)

Firefox 63
All
Android
defect
Not set

Tracking

()

VERIFIED FIXED
Firefox 63
Tracking Status
firefox62 --- verified
firefox63 --- verified

People

(Reporter: petru, Assigned: petru)

References

(Blocks 1 open bug)

Details

Attachments

(1 file)

The TimePicker cannot be swiped when in landscape because by being placed in a ScrollView [1] and overflowing it, the ScrollView catches the swipe motion.

Issue easily seen here - https://drive.google.com/file/d/1bqXUnig_JWuSmnmCgOYUl_3pZpDwZYfJ/view?usp=sharing

[1] https://dxr.mozilla.org/mozilla-central/rev/085cdfb90903d4985f0de1dc7786522d9fb45596/mobile/android/base/java/org/mozilla/gecko/prompts/Prompt.java#412
Assignee: nobody → petru.lingurar
Blocks: 1464997
Status: NEW → ASSIGNED
Attachment #8992277 - Flags: review?(sdaswani) → review?(nchen)
Comment on attachment 8992277 [details]
Bug 1474925 - TimePicker swipe not possible in landscape;

https://reviewboard.mozilla.org/r/257160/#review264174
Attachment #8992277 - Flags: review?(nchen) → review+
Keywords: checkin-needed
Pushed by apavel@mozilla.com:
https://hg.mozilla.org/integration/autoland/rev/5bac5fa077ea
TimePicker swipe not possible in landscape; r=jchen
Keywords: checkin-needed
Fixed the lint issue.
Flags: needinfo?(petru.lingurar)
Keywords: checkin-needed
Pushed by aiakab@mozilla.com:
https://hg.mozilla.org/integration/autoland/rev/f3c4739ba1ba
TimePicker swipe not possible in landscape; r=jchen
Keywords: checkin-needed
https://hg.mozilla.org/mozilla-central/rev/f3c4739ba1ba
Status: ASSIGNED → RESOLVED
Closed: Last year
Resolution: --- → FIXED
Target Milestone: --- → Firefox 63
Keywords: checkin-needed
Petru-Mugurel, everything here looks like it has been checked in. Does the "checkin-needed" belong to a different bug?
Flags: needinfo?(petru.lingurar)
Indeed, sorry!
Flags: needinfo?(petru.lingurar) → qe-verify+
Checked this fix in the latest Nightly and everything works as expected.

Marking as Verified.
Status: RESOLVED → VERIFIED
Flags: qe-verify+
Version: unspecified → Firefox 63
Comment on attachment 8992277 [details]
Bug 1474925 - TimePicker swipe not possible in landscape;

Approval Request Comment
[Feature/Bug causing the regression]: TimePicker swipe not possible in landscape
[User impact if declined]: The normal way of swiping to select a certain time in the Material TimePicker is not possible on some devices while on landscape.
[Is this code covered by automated tests?]: No
[Has the fix been verified in Nightly?]: Yes
[Needs manual test from QE? If yes, steps to reproduce]:  --
[List of other uplifts needed for the feature/fix]: --
[Is the change risky?]: No
[Why is the change risky/not risky?]: Has been QE verified and in the time being in Nightly no issues have been reported.
[String changes made/needed]: --
Attachment #8992277 - Flags: approval-mozilla-beta?
Comment on attachment 8992277 [details]
Bug 1474925 - TimePicker swipe not possible in landscape;

One of several small fixes for the date picker related to the switch in 62 to using the platform library. Verified in nightly. 
Let's uplift for next Monday's beta 17 build.
Attachment #8992277 - Flags: approval-mozilla-beta? → approval-mozilla-beta+
Flags: qe-verify+
Can you please check this, Igor?
Flags: needinfo?(igor.lazar)
Devices:
 - HTC Desire 820 (Android 6.0.1);
 - Samsung Galaxy Note 8 (Android 8.0.0).

Verified as fixed in 62.0b17.
Flags: qe-verify+
Flags: needinfo?(igor.lazar)
You need to log in before you can comment on or make changes to this bug.