Closed Bug 1475649 Opened Last year Closed Last year

Can no longer call ./mach try when untracked files are present (with git)

Categories

(Firefox Build System :: General, defect)

defect
Not set

Tracking

(firefox-esr60 unaffected, firefox61 unaffected, firefox62 unaffected, firefox63 fixed)

RESOLVED FIXED
mozilla63
Tracking Status
firefox-esr60 --- unaffected
firefox61 --- unaffected
firefox62 --- unaffected
firefox63 --- fixed

People

(Reporter: jya, Assigned: ahal)

References

Details

(Keywords: regression)

Attachments

(2 files)

Using git.

If untracked files are present, ./mach try will always error like this:

$ ./mach try -b do -p all -u mochitest-media,mochitest-media-e10s,web-platform-tests -t none
ERROR please commit changes before continuing
This is a bug in mozversioncontrol, the doc string for the "working_directory_clean" function state:
> By default, untracked and ignored files are not considered.

But the git implementation for this function runs:
git status --porcelain

Which *does* consider untracked files by default. Instead, we need to run:
git status --porcelain --untracked-files=no

Bug 1413922 regressed |mach try| as it started using this function in favour of its own implementation.
Assignee: nobody → ahal
Status: NEW → ASSIGNED
Product: Testing → Firefox Build System
Version: Version 3 → unspecified
Duplicate of this bug: 1475646
The doc string for the "working_directory_clean" function states:
> By default, untracked and ignored files are not considered.

But the git implementation for this function used to run:
git status --porcelain

Which *does* consider untracked files by default. Instead, we need to run:
git status --porcelain --untracked-files=no
Comment on attachment 8992011 [details]
Bug 1475649 - [mozversioncontrol] Make vcs.working_directory_clean() ignore untracked files by default

James Graham [:jgraham] has approved the revision.

https://phabricator.services.mozilla.com/D2134
Attachment #8992011 - Flags: review+
Pushed by ahalberstadt@mozilla.com:
https://hg.mozilla.org/integration/autoland/rev/a35b188d0e44
[mozversioncontrol] Make vcs.working_directory_clean() ignore untracked files by default r=jgraham
a35b188d0e44 inadvertently regressed behavior in the case where
the Git status.showUntrackedFiles config option was set and
we want to purge untracked files.
Can we have a test for that case too?
I don't have time today to spend more than the ~5 minutes I've already spent on this issue :/ Feel free to commandeer the revision in Phabricator. Or wait until I have time to follow up.
https://hg.mozilla.org/mozilla-central/rev/a35b188d0e44
Status: ASSIGNED → RESOLVED
Closed: Last year
Resolution: --- → FIXED
Target Milestone: --- → mozilla63
Comment on attachment 8992076 [details]
Bug 1475649 - Always use --untracked-files; r?ahal

Andrew Halberstadt [:ahal] has approved the revision.

https://phabricator.services.mozilla.com/D2141
Attachment #8992076 - Flags: review+
Status: RESOLVED → REOPENED
Resolution: FIXED → ---
https://hg.mozilla.org/mozilla-central/rev/633b1aae6b2e
Status: REOPENED → RESOLVED
Closed: Last yearLast year
Resolution: --- → FIXED
You need to log in before you can comment on or make changes to this bug.