SPOCs stop showing after seeing 100 impressions of the same campaign

VERIFIED FIXED in Firefox 63

Status

()

defect
P1
normal
VERIFIED FIXED
Last year
21 days ago

People

(Reporter: tushar, Assigned: thecount)

Tracking

unspecified
Firefox 63
Points:
---
Dependency tree / graph

Firefox Tracking Flags

(firefox63 fixed)

Details

Attachments

(1 attachment)

[Affected versions]:
- Firefox 61.0+

[Affected Platforms]:
- All Windows
- All Mac
- All Linux

[Prerequisites]:
- Have a clean new Firefox profile.
- Have the set-up for the "Personalization1" variant configured (https://goo.gl/cL4Ue3).
- Ensure ability to see SPOCs is checked in about:preferences#home
- Ensure that the entry for browser.newtabpage.activity-stream.feeds.section.topstories.spoc.impressions is blank.


[Steps to reproduce]:
1. Start the browser with the profile from prerequisites.
2. Open 110 Tabs

[Expected result]:
- Should see 500 tabs / day with SPOCs from the same campaign id 

[Actual results]:
- A non-sponsored card is displayed after the 101st SPOC impression
- The browser setting browser.newtabpage.activity-stream.feeds.section.topstories.spoc.impressions has an array that stops increasing after the 100th impression of the same campaign.
The original implementation from https://github.com/mozilla/activity-stream/pull/3710 has a hardcoded 100 limit:

 +const MAX_LIFETIME_CAP = 100; // Guard against misconfiguration on the server 

Is there something that actually wants more than 100? Perhaps this just needs to be increased?
Ah, thank you for letting me know about the hardcoded limit.
Yes, I think increasing it to 500 should suffice.
Hi Tushar,  can you add some details around why this increase is needed, and if there's any particular timeframe required?  Just to help us prioritize.
Flags: needinfo?(tushar)
Hi Jenn - of course, sorry for not including it initially.

Originally, we had much tighter restrictions on frequency caps. Now that we've gotten some insight that loosening them somewhat didn't have an impact on Fx retention, this limit is potentially more of an issue (while still a bit of an edge case). 

The reason I noticed this limit at all was that we've been testing some different personalization configs in a Shield study and I ran into this cap.

It would be ideal if we could get this addressed in the next release.
Flags: needinfo?(tushar)
Assignee: nobody → sdowne
Iteration: --- → 63.3 - Aug 6
Priority: -- → P1
Commits pushed to master at https://github.com/mozilla/activity-stream

https://github.com/mozilla/activity-stream/commit/7de1abf072c63cda5d807cef4d91c02dde673f5f
Fixes Bug 1476045 - SPOCs stop showing after seeing 100 impressions of the same campaign

https://github.com/mozilla/activity-stream/commit/da6c3838c0745de4bde8c6564ee349b7a8e5e5c5
Merge pull request #4283 from ScottDowne/t-1476045

Fixes Bug 1476045 - SPOCs stop showing after seeing 100 impressions o…
Status: NEW → RESOLVED
Closed: 11 months ago
Resolution: --- → FIXED
Blocks: 1482205
https://hg.mozilla.org/mozilla-central/rev/972b3c48c6e9
Iteration: 63.3 - Aug 6 → 63.4 - Aug 20
Target Milestone: --- → Firefox 63

Managed to verify this using 67.0a1 (2019-02-26) on Windows 10, Ubuntu 16.04, macOS 10.11 using steps from this.
Sponsored content does get capped out and multiple sponsored-adds are displayed.

Status: RESOLVED → VERIFIED
Component: Activity Streams: Newtab → New Tab Page
You need to log in before you can comment on or make changes to this bug.