(Re-) Enable WebVR by default for macOS

RESOLVED FIXED in Firefox 64

Status

()

RESOLVED FIXED
8 months ago
4 months ago

People

(Reporter: kip, Assigned: daoshengmu)

Tracking

(Blocks: 1 bug, {dev-doc-complete})

63 Branch
mozilla64
dev-doc-complete
Points:
---
Dependency tree / graph

Firefox Tracking Flags

(relnote-firefox 64+, firefox63- wontfix, firefox64+ fixed)

Details

Attachments

(1 attachment)

(Reporter)

Description

8 months ago
Once the VR process has been enabled by default and we have enabled the macOS small block allocator for the VR process, we can re-enable WebVR by default for macOS.

This bug tracks the re-enabling of the pref to restore the feature.
(Reporter)

Updated

8 months ago
Depends on: 1476092
tracking-firefox63: --- → +
Kip, any timeline for that?
Flags: needinfo?(kgilbert)
(Reporter)

Comment 2

8 months ago
(In reply to Pascal Chevrel:pascalc from comment #1)
> Kip, any timeline for that?

We plan to have this ready before FF63 rides to Beta on 2018-09-04.
If we hit this deadline it should be in release Firefox 63 on 2018-10-23.
Flags: needinfo?(kgilbert)
(In reply to :kip (Kearwood Gilbert) from comment #2)
> (In reply to Pascal Chevrel:pascalc from comment #1)
> > Kip, any timeline for that?
> 
> We plan to have this ready before FF63 rides to Beta on 2018-09-04.
> If we hit this deadline it should be in release Firefox 63 on 2018-10-23.

Please note that the nightly Soft Freeze is August 23 and no pref that activate features should be committed after that date, thanks.
https://wiki.mozilla.org/Release_Management/Release_Process#Nightly_soft_code_freeze
Please track for 64.
ni?self to set 64 tracking flag when it becomes available.  Thanks Lars!
status-firefox63: affected → wontfix
tracking-firefox63: + → -
Flags: needinfo?(jcristau)
status-firefox64: --- → affected
tracking-firefox64: --- → +
relnote-firefox: --- → ?
Flags: needinfo?(jcristau)
Is this still planned for 64?  We're reaching the end of the nightly cycle, and it looks like the dependencies aren't ready yet.
Flags: needinfo?(kgilbert)
(Reporter)

Comment 7

6 months ago
(In reply to Julien Cristau [:jcristau] from comment #6)
> Is this still planned for 64?  We're reaching the end of the nightly cycle,
> and it looks like the dependencies aren't ready yet.

We are still planning this for 64, but it's close.  We've been doing a lot of testing for regressions on physical hardware and verifying the fix.  The last dependencies are landing this week.
Flags: needinfo?(kgilbert)
(Reporter)

Comment 8

6 months ago
(In reply to :kip (Kearwood Gilbert) from comment #7)
> (In reply to Julien Cristau [:jcristau] from comment #6)
> > Is this still planned for 64?  We're reaching the end of the nightly cycle,
> > and it looks like the dependencies aren't ready yet.
> 
> We are still planning this for 64, but it's close.  We've been doing a lot
> of testing for regressions on physical hardware and verifying the fix.  The
> last dependencies are landing this week.

@daoshengmu has confirmed that we can remove most of the dependencies for the macOS, as it appears Valve has fixed the issues in the runtime requiring the VR process (and nano allocator) for that work.  Daosheng has a patch ready that fixes the remaining issues.
(Reporter)

Comment 9

6 months ago
I have amended the original intent-to-ship email, informing that it will finally be landing for FF64:

https://groups.google.com/d/msg/mozilla.dev.platform/MCSJOhbqSVE/jgJ1pyPwAwAJ

Part of the fix was done externally (A SteamVR runtime update).  I have removed the associated work-around dependencies to reflect this (1476090, 1476092).

Bug 1497787 (Crash at OpenVR VRCompositor::Submit() in MacOS) will need to be landed first to fix regressions that occurred since it was last enabled for macOS.
Depends on: 1497787
No longer depends on: 1476090, 1476092
(Reporter)

Updated

6 months ago
Assignee: kgilbert → dmu
(Assignee)

Comment 10

6 months ago
MozReview-Commit-ID: 5bmkpZDo9fz
Keywords: dev-doc-needed
(Assignee)

Comment 11

5 months ago
After apply the patch from  Bug  1497787, it works properly with dom.vr.external;false or dom.vr.external;true. I also have checked it with SteamVR release and beta versions, both of them are good!.
(Assignee)

Comment 12

5 months ago
Qdot, please help review test_interfaces.js file. It needs a review from a dom peer. Thanks!

Comment 13

5 months ago
Pushed by dmu@mozilla.com:
https://hg.mozilla.org/integration/autoland/rev/a18cdefab69c
Enable WebVR in release on macOS. r=qdot,kip

Comment 14

5 months ago
bugherder
https://hg.mozilla.org/mozilla-central/rev/a18cdefab69c
Status: NEW → RESOLVED
Last Resolved: 5 months ago
status-firefox64: affected → fixed
Resolution: --- → FIXED
Target Milestone: --- → mozilla64
Added to 64beta relnotes:
WebVR is now available on MacOS
relnote-firefox: ? → 64+
I've updated the compat data to reflect this change, and added a note to the Fx64 rel notes:

https://github.com/mdn/browser-compat-data/pull/3077
https://developer.mozilla.org/en-US/docs/Mozilla/Firefox/Releases/64#APIs
Keywords: dev-doc-needed → dev-doc-complete
You need to log in before you can comment on or make changes to this bug.