Closed Bug 1476180 Opened 4 years ago Closed 3 years ago

Text layout changed from horizontal to vertical after bug 1472386

Categories

(Core :: Layout: Block and Inline, defect, P3)

63 Branch
defect

Tracking

()

RESOLVED INVALID
Tracking Status
firefox63 --- disabled

People

(Reporter: rontilby, Unassigned)

References

()

Details

(Keywords: regression, site-compat)

Attachments

(2 files)

User Agent: Mozilla/5.0 (Windows NT 10.0; Win64; x64; rv:63.0) Gecko/20100101 Firefox/63.0
Build ID: 20180716221418

Steps to reproduce:

Ancestry.com > Trees > Any person profile page with multiple "Facts".
The far left column forms a time-line with the event year and the person's age.
The year text and age text should be horizontal, after bug 1472386 the text is vertical regardless of window width.

Example URL: https://www.ancestry.com/family-tree/person/tree/66923936/person/42160495984/facts


Actual results:

Text layout change from horizontal to vertical


Expected results:

Text layout should be horizontal
Blocks: 1472386
Component: Untriaged → Layout: Block and Inline
Product: Firefox → Core
It seems that page requires paid account to visit :/

What is changed in bug 1472386 is that overflow-wrap: break-word now affects the intrinsic width. From the screenshot, I guess the website use that property without specifying a width to the column.

It's unclear to me what should we do here. If there are getting more compatible issues, we may need to backout bug 1472386 and implement word-break: break-word instead, but I'm unconvinced for now.
The desired text orientation is horizontal.
Google Chrome 68 shows the text horizontal.
Firefox production and nightly showed the text horizontal before Bug 1472386.
Firefox nightly 63.0a1 (2018-07-21) (64-bit) shows the text in vertical orientation.
(In reply to Ronald Tilby from comment #3)
Please put HTML with CSS there. We can not say more from screen
Ou, nevermind, I dont saw your last attachment.
From attachment 899398 i see where is a problem. Using right: 100% is wrong because there is no space for content in p. You should se width/min-width or not use overflow-wrap: break-word. For me it's wrong usage CSS
Status: UNCONFIRMED → NEW
Ever confirmed: true
Keywords: regression
We're not sure how widespread this issue could be. Do we have a plan of action for this?
Flags: needinfo?(xidorn+moz)
Priority: -- → P3
See bug 1479302 comment 4.
Flags: needinfo?(xidorn+moz)
See Also: → 1480284
Keywords: site-compat
Per Bug 1479302#c6, it sounds as if this behavior was put behind a pref.
Disabled in bug 1484587 and then new value is added for the original purpose in bug 1505786. I think we can close this bug now.
Status: NEW → RESOLVED
Closed: 3 years ago
Resolution: --- → INVALID
You need to log in before you can comment on or make changes to this bug.