Closed Bug 1476681 Opened 3 years ago Closed 3 years ago

Crash in android.os.FileUriExposedException: file:///storage/emulated/0/Download/fennec-63.0a1.multi.android-arm.apk exposed beyond app through Intent.getData() at android.os.StrictMode.onFileUriExposed(StrictMode.java)

Categories

(Firefox for Android Graveyard :: General, defect)

All
Android
defect
Not set
critical

Tracking

(firefox-esr52 unaffected, firefox-esr60 unaffected, firefox61 unaffected, firefox62 unaffected, firefox63 verified)

VERIFIED FIXED
Firefox 63
Tracking Status
firefox-esr52 --- unaffected
firefox-esr60 --- unaffected
firefox61 --- unaffected
firefox62 --- unaffected
firefox63 --- verified

People

(Reporter: calixte, Assigned: JanH)

References

(Blocks 1 open bug)

Details

(Keywords: crash, regression)

Crash Data

Attachments

(1 file)

This bug was filed from the Socorro interface and is
report bp-89b5ad1e-48ae-4288-b1e9-e5dc20180718.
=============================================================

android.os.FileUriExposedException: file:///storage/emulated/0/Download/fennec-63.0a1.multi.android-arm.apk exposed beyond app through Intent.getData()
	at android.os.StrictMode.onFileUriExposed(StrictMode.java:1978)
	at android.net.Uri.checkFileUriExposed(Uri.java:2371)
	at android.content.Intent.prepareToLeaveProcess(Intent.java:10247)
	at android.content.Intent.prepareToLeaveProcess(Intent.java:10201)
	at android.app.Instrumentation.execStartActivity(Instrumentation.java:1667)
	at android.app.ContextImpl.startActivity(ContextImpl.java:917)
	at android.app.ContextImpl.startActivity(ContextImpl.java:888)
	at android.content.ContextWrapper.startActivity(ContextWrapper.java:379)
	at org.mozilla.gecko.updater.Updater.applyUpdate(Updater.java:520)
	at org.mozilla.gecko.updater.Updater.applyUpdate(Updater.java:213)
	at org.mozilla.gecko.updater.UpdatesApplyService.onHandleWork(UpdatesApplyService.java:16)
	at android.support.v4.app.JobIntentService$CommandProcessor.doInBackground(JobIntentService.java:391)
	at android.support.v4.app.JobIntentService$CommandProcessor.doInBackground(JobIntentService.java:382)
	at android.os.AsyncTask$2.call(AsyncTask.java:333)
	at java.util.concurrent.FutureTask.run(FutureTask.java:266)
	at java.util.concurrent.ThreadPoolExecutor.runWorker(ThreadPoolExecutor.java:1167)
	at java.util.concurrent.ThreadPoolExecutor$Worker.run(ThreadPoolExecutor.java:641)
	at java.lang.Thread.run(Thread.java:764)

There are 8 crashes (from 2 installation) in nightly 63 with buildid 20180717100050. In analyzing the backtrace, the regression may have been introduced by patch [1] to fix bug 1407046.

[1] https://hg.mozilla.org/mozilla-central/rev?node=2c647187c1a2
Flags: needinfo?(petru.lingurar)
I did the other file URI patch, so I'll take this one as well.
Assignee: nobody → jh+bugzilla
It seems like my changes from bug 1450449, which were intended to prevent this very problem, got lost during the refactoring for bug 1407046.
Flags: needinfo?(petru.lingurar)
OS: Unspecified → Android
Hardware: Unspecified → All
See Also: → 1450449
Can reproduce this crash and Bug 1476754(alternatively) by updating Nightly 2018-07-17 to the 07/18 build. Cannot install the update on these devices:
Google Pixel (Android 9)
Samsung Galaxy S8 (Android 8.0)

Doesn't reproduce on these lower Android versions:
HTC Desire 820 (Android 6.0.1)
Nokia 6 (Android 7.1.1)
Also, STR similar to Bug 1476606.
It looks like the blank pop-up described there it's the Nightly crash reporter, which can be seen better on a Samsung S8: https://www.screencast.com/t/vHHs2Hiwe.
Blocks: android-o
Comment on attachment 8993064 [details]
Bug 1476681 - Starting from Nougat, install updates via content:// URIs.

https://reviewboard.mozilla.org/r/257870/#review265238
Attachment #8993064 - Flags: review?(nchen) → review+
Pushed by mozilla@buttercookie.de:
https://hg.mozilla.org/integration/autoland/rev/fe3e4345a4a3
Starting from Nougat, install updates via content:// URIs. r=jchen
https://hg.mozilla.org/mozilla-central/rev/fe3e4345a4a3
Status: NEW → RESOLVED
Closed: 3 years ago
Resolution: --- → FIXED
Target Milestone: --- → Firefox 63
No more crashes on build updates. Also, the pop-up crash reporter doesn't appear anymore. 
Marking this as fixed. 
Google Pixel (Android 9)
Samsung Galaxy S8 (Android 8.0)
Status: RESOLVED → VERIFIED
Product: Firefox for Android → Firefox for Android Graveyard
You need to log in before you can comment on or make changes to this bug.