Closed Bug 1349309 (android-o) Opened 6 years ago Closed 2 years ago

[meta] Android Oreo issues

Categories

(Firefox for Android Graveyard :: General, enhancement, P2)

All
Android
enhancement

Tracking

(Not tracked)

RESOLVED INCOMPLETE

People

(Reporter: sebastian, Unassigned)

References

(Depends on 1 open bug, )

Details

(Keywords: feature, meta, Whiteboard: --do_not_change--[priority:high])

The first Android O preview is here!
Depends on: 1349522
Depends on: 1349523
Depends on: 1352009
Depends on: 1352011
Depends on: 1359048
Depends on: 1368539
Depends on: 1368536
Depends on: 1365865
Depends on: 1371815
Depends on: 1372040
Depends on: 1372926
QA Contact: ioana.chiorean
Depends on: 1378348
Depends on: 1380266
Depends on: 1384866
Depends on: 1385464
Depends on: 1392746
Depends on: 1393165
Depends on: 1408677
Summary: [meta] Android O issues → [meta] Android Oreo issues
Depends on: 1411827
tracking-fennec: --- → ?
Depends on: 1434603
Depends on: 1434648
tracking-fennec: ? → ---
[triage] Bulk edit from title: this is a non-critical issue or [meta] bug.
Priority: -- → P3
Depends on: 1444776
[triage] It's critical that we get targetSdk=26 (Oreo) by November. From the Android blog [1]:

> As we announced recently, Google Play will require all app updates to target Android Oreo (targetSdkVersion 26 or higher) by November 2018, with support for 64-bit hardware on the horizon for 2019.

We currently target SDK 23 (according to my config.status).

[1]: https://android-developers.googleblog.com/2018/03/previewing-android-p.html
Flags: needinfo?(sdaswani)
Priority: P3 → P1
Thanks Mike. Snorp and Nick - do you foresee any issues moving to 26?
Flags: needinfo?(snorp)
Flags: needinfo?(sdaswani)
Flags: needinfo?(nalexander)
(In reply to :sdaswani from comment #3)
> Thanks Mike. Snorp and Nick - do you foresee any issues moving to 26?

In terms of building, not really -- probably just some routine deprecation work-arounds.  In terms of actually running, yes -- I expect we'll have a lot of subtle bustage, that won't be revealed by what testing we have, and that will take an unknown amount of time to work through.
Flags: needinfo?(nalexander)
OK understood - I am hoping it's an effort that both the Softvision devs and QA can work through together.

Flagging Andreas and Barbara for prioritization - note the deadline is November, so it could get into 62, or maybe even 63.
Flags: needinfo?(abovens)
Flags: needinfo?(bbermes)
I suggest we aim for 62, so that if there are issues, we can still get them fixed. If we target 63 from the start, there will be little wiggle room in case things don't work out as planned.
Flags: needinfo?(abovens)
Whiteboard: [Leanplum] [62]
Yeah, comment #4 captures my thoughts as well.
Flags: needinfo?(snorp)
Depends on: 1450447
Depends on: target-android-o
Andrei, this was the bug that I was talking about - if we can move to 26 earlier, then we can more easily use the LP SDK.
Vlad, is this something you think you, Petru or Andrei can work on? It requires a lot of moving parts, so maybe not, but just asking.
Flags: needinfo?(vlad.baicu)
Sure, we will asign it to one of us
Flags: needinfo?(vlad.baicu)
Depends on: 1451061
Blocks: 1438716
No longer blocks: 1438716
Vlad, is this something you're tracking for 62? If so, 62 just hit Nightly so I think we should get cracking on it soon: these are usually a lot of work to get working correctly.
Flags: needinfo?(vlad.baicu)
Flags: needinfo?(sdaswani)
QA Contact: ioana.chiorean → oana.horvath
Yes, we are currently working on these with top priority.
Flags: needinfo?(vlad.baicu)
Yes Mike, these are currently top priority, but I also want to understand what's strictly necessary to accomplish this:

"Google Play will require all app updates to target Android Oreo (targetSdkVersion 26 or higher) by November 2018, with support for 64-bit hardware on the horizon for 2019."
Flags: needinfo?(sdaswani)
Everything listed as blocking bug 1450450 (https://bugzilla.mozilla.org/showdependencytree.cgi?id=1450450&hide_resolved=1) is something where raising the target API to 26 will turn off a compatibility behaviour that we are currently depending on when running on Android N or O.
Since that list was determined only by looking at the documentation, other things might potentially crop up when actually testing things in practice, but it should be mostly complete.

The second half of that sentence means that the currently experimental Aarch64 builds of Gecko need to go into production some time next year, and that'll affect GeckoView, too.
Whiteboard: [Leanplum] [62] → --do_not_change--[priority:high]
Depends on: 1474961
Depends on: 1476754
Depends on: 1476900
Depends on: 1476681
Depends on: 1476606
Depends on: 1476596
Depends on: 1476966
Depends on: 1476970
No longer depends on: 1476970
Depends on: 1477700
Re-triaging per https://bugzilla.mozilla.org/show_bug.cgi?id=1473195

Needinfo :susheel if you think this bug should be re-triaged.
Priority: P1 → P5
Depends on: 1278364
Depends on: 1478970
Depends on: 1480079
This is a feature we are tracking for 63 and therefore should be P1 priority. The bulk update perhaps needed to look at the whiteboard tag before updating the priority field. NI Emma, Susheel, Marcia, Pascal as FYI.
Flags: needinfo?(sdaswani)
Flags: needinfo?(pascalc)
Flags: needinfo?(mozillamarcia.knous)
Flags: needinfo?(ehumphries)
Priority: P5 → P1
The query to re-prioritize should had ignored [priority:high] bugs, so I'm not sure what happened. Following up.
Flags: needinfo?(ehumphries)
Clearing NI, doesn't seem necessary any more. Agree this should be a P1.
Flags: needinfo?(sdaswani)
Flags: needinfo?(mozillamarcia.knous)
No longer blocks: 1480083
Depends on: 1480083
Depends on: 1482733
Depends on: 1482997
Depends on: 1482105
Flags: needinfo?(pascalc)
Depends on: 1483855
Depends on: 1483857
Depends on: 1480091
Depends on: 1479532
Depends on: 1486432
Marcia do you think it's safe to close this now?
Flags: needinfo?(bbermes) → needinfo?(mozillamarcia.knous)
(In reply to :sdaswani only needinfo from comment #19)
> Marcia do you think it's safe to close this now?

We usually don't close them out until all the dependent bugs are closed. We should probably work on that and then close this one out.
Flags: needinfo?(mozillamarcia.knous)
Depends on: 1494026
Keywords: meta

Downgrading priority from P1 to P2

Priority: P1 → P2
We have completed our launch of our new Firefox on Android. The development of the new versions use GitHub for issue tracking. If the bug report still reproduces in a current version of [Firefox on Android nightly](https://play.google.com/store/apps/details?id=org.mozilla.fenix) an issue can be reported at the [Fenix GitHub project](https://github.com/mozilla-mobile/fenix/). If you want to discuss your report please use [Mozilla's chat](https://wiki.mozilla.org/Matrix#Connect_to_Matrix) server https://chat.mozilla.org and join the [#fenix](https://chat.mozilla.org/#/room/#fenix:mozilla.org) channel.
Status: NEW → RESOLVED
Closed: 2 years ago
Resolution: --- → INCOMPLETE
Product: Firefox for Android → Firefox for Android Graveyard
You need to log in before you can comment on or make changes to this bug.