Enable block autoplay in Nightly only

RESOLVED FIXED in Firefox 63

Status

()

P2
normal
RESOLVED FIXED
8 months ago
5 months ago

People

(Reporter: cpearce, Assigned: cpearce)

Tracking

(Blocks: 1 bug)

unspecified
mozilla63
Points:
---
Dependency tree / graph

Firefox Tracking Flags

(relnote-firefox ?, firefox63 verified)

Details

Attachments

(5 attachments)

(Assignee)

Description

8 months ago
In order to gather feedback on our block autoplay implementation, we'd like to enable it in Nightly only.
Comment hidden (mozreview-request)
Comment hidden (mozreview-request)
Comment hidden (mozreview-request)
Comment hidden (mozreview-request)
Comment hidden (mozreview-request)

Comment 6

8 months ago
mozreview-review
Comment on attachment 8993273 [details]
Bug 1476853 - Don't block WebAudio autoplay by default.

https://reviewboard.mozilla.org/r/258052/#review264978
Attachment #8993273 - Flags: review?(padenot) → review+

Comment 7

8 months ago
mozreview-review
Comment on attachment 8993274 [details]
Bug 1476853 - Enable block autoplay on Nightly only on desktop.

https://reviewboard.mozilla.org/r/258054/#review264990
Attachment #8993274 - Flags: review?(jyavenard) → review+

Comment 8

8 months ago
mozreview-review
Comment on attachment 8993275 [details]
Bug 1476853 - Set autoplay to allowed for testing purposes.

https://reviewboard.mozilla.org/r/258056/#review264994

thanks!
Attachment #8993275 - Flags: review?(jmaher) → review+

Comment 9

8 months ago
mozreview-review
Comment on attachment 8993277 [details]
Bug 1476853 - Remove obsolete use of media.autoplay.enabled.

https://reviewboard.mozilla.org/r/258060/#review264996
Attachment #8993277 - Flags: review?(rbarker) → review+
:snorp is on PTO this week. Maybe ask :jchen for review?
(Assignee)

Updated

8 months ago
Attachment #8993276 - Flags: review?(snorp) → review?(nchen)
(Assignee)

Comment 11

8 months ago
(In reply to Randall Barker [:rbarker] from comment #10)
> :snorp is on PTO this week. Maybe ask :jchen for review?

OK, thanks!

Comment 12

8 months ago
mozreview-review
Comment on attachment 8993276 [details]
Bug 1476853 - Enable block autoplay v2 on Nightly only on Fennec by default.

https://reviewboard.mozilla.org/r/258058/#review265252
Attachment #8993276 - Flags: review?(nchen) → review+

Comment 13

8 months ago
Pushed by cpearce@mozilla.com:
https://hg.mozilla.org/integration/autoland/rev/ea9220c21a7b
Don't block WebAudio autoplay by default. r=padenot
https://hg.mozilla.org/integration/autoland/rev/7d8ce14346a3
Enable block autoplay on Nightly only on desktop. r=jya
https://hg.mozilla.org/integration/autoland/rev/a44577a773a7
Set autoplay to allowed for testing purposes. r=jmaher
https://hg.mozilla.org/integration/autoland/rev/82ace642ac7e
Enable block autoplay v2 on Nightly only on Fennec by default. r=jchen
https://hg.mozilla.org/integration/autoland/rev/8dcdd881fd09
Remove obsolete use of media.autoplay.enabled. r=rbarker

Updated

8 months ago
Depends on: 1477249

Updated

8 months ago
Depends on: 1477421
(Assignee)

Updated

8 months ago
No longer depends on: 1477294
Chris, since this is sticking on nightly, could you please request a release notes addition for Nightly? Thanks
https://wiki.mozilla.org/Release_Management/Release_Notes#How_to_nominate_a_bug_for_release_notes_addition.3F
Flags: needinfo?(cpearce)
(Assignee)

Comment 16

8 months ago
(Requesting release note via "relnote-firefox?" but that didn't autofill a comment here with. I had to find the questions from the YouTube video. I assume that's a recent regression in b.m.o)

Release note request: Block autoplay media with sound enabled by default in Firefox Nightly on desktop and Android.
[Why this is notable]: This changes the default behaviour to block autoplay enabled, previously disabled by default.
[Affects Firefox for Android]: Yes
[Suggested wording]: Firefox Nightly by default now prompts for permission before allowing pages to automatically play media with sound.
[Links]: TBD
relnote-firefox: --- → ?
Flags: needinfo?(cpearce)
relnote-firefox: ? → 63+
resetting relnote flag until this is enabled on release.
relnote-firefox: 63+ → ?
Any way to remove this feature for some url or on local filesystem (file:///) ? This is problematic when I have to make some tests on <audio>/<video> tags, making them play with javascript.

Comment 19

6 months ago
Verified, that block autoplay is enabled by default in Nightly.
status-firefox63: fixed → verified

Updated

5 months ago
See Also: → bug 1502349
You need to log in before you can comment on or make changes to this bug.