Disable the dump for the tippytop collection

RESOLVED FIXED in Firefox 62

Status

()

defect
RESOLVED FIXED
11 months ago
9 months ago

People

(Reporter: leplatrem, Assigned: leplatrem)

Tracking

Trunk
Firefox 63
Points:
---
Dependency tree / graph
Bug Flags:
qe-verify -

Firefox Tracking Flags

(firefox62 fixed, firefox63 fixed)

Details

Attachments

(1 attachment)

Assignee

Description

11 months ago
Since the tippytop collection contains third-party URLs and assets, we don't want it to be dumped in ``services/settings/dumps``.

Removing the file tippytop.json would be enough :)

https://searchfox.org/mozilla-central/rev/88199de427d3c5762b7f3c2a4860c10734abd867/taskcluster/docker/periodic-updates/scripts/periodic_file_updates.sh#312-326
Comment hidden (mozreview-request)
Assignee

Updated

11 months ago
Assignee: nobody → mathieu

Comment 2

11 months ago
mozreview-review
Comment on attachment 8993363 [details]
Bug 1476934 - Disable the dump for the tippytop collection

https://reviewboard.mozilla.org/r/258148/#review265100
Attachment #8993363 - Flags: review?(najiang) → review+

Updated

11 months ago
Blocks: 1437671
Comment hidden (mozreview-request)

Comment 4

11 months ago
Pushed by mleplatre@mozilla.com:
https://hg.mozilla.org/integration/autoland/rev/e56a701fc960
Disable the dump for the tippytop collection r=nanj

Comment 5

11 months ago
Backout by csabou@mozilla.com:
https://hg.mozilla.org/integration/autoland/rev/285ade739cd2
Backed out changeset e56a701fc960 for build bustages on moz-automation.mk. CLOSED TREE
Push with failures: https://treeherder.mozilla.org/#/jobs?repo=autoland&filter-resultStatus=testfailed&filter-resultStatus=busted&filter-resultStatus=exception&fromchange=e56a701fc960ad035011da615ec13907d4f693a1&tochange=285ade739cd21e156a9236c3e4bd242b5837604c&selectedJob=189224038

Failure log: https://treeherder.mozilla.org/logviewer.html#?job_id=189224004&repo=autoland&lineNumber=166590

Backout link: https://hg.mozilla.org/integration/autoland/rev/285ade739cd21e156a9236c3e4bd242b5837604c

[task 2018-07-20T17:18:53.025Z] 17:18:53     INFO -  package> make[2]: *** [package] Error 2
[task 2018-07-20T17:18:53.025Z] 17:18:53     INFO -  /builds/worker/workspace/build/src/build/moz-automation.mk:89: recipe for target 'automation/package' failed
[task 2018-07-20T17:18:53.025Z] 17:18:53     INFO -  make[1]: *** [automation/package] Error 2
[task 2018-07-20T17:18:53.025Z] 17:18:53     INFO -  make[1]: *** Waiting for unfinished jobs....
[task 2018-07-20T17:18:54.004Z] 17:18:54     INFO -  package-generated-sources> make[2]: Entering directory '/builds/worker/workspace/build/src/obj-firefox'
[task 2018-07-20T17:18:54.004Z] 17:18:54     INFO -  package-generated-sources> /builds/worker/workspace/build/src/obj-firefox/_virtualenvs/init/bin/python -m mozbuild.action.package_generated_sources 'dist/target.generated-files.tar.gz'
[task 2018-07-20T17:18:54.004Z] 17:18:54     INFO -  package-generated-sources> make[2]: Leaving directory '/builds/worker/workspace/build/src/obj-firefox'
Flags: needinfo?(mathieu)
Assignee

Comment 7

11 months ago
This is annoying... Tests were passing:
https://treeherder.mozilla.org/#/jobs?repo=try&revision=f24f44e70f44615ef13a664a55127a8e4d0123d0

I will change strategy of the patch, the ``.gitkeep`` is not enough because the error is:
```
Error: /builds/worker/workspace/build/src/browser/installer/package-manifest.in:458: Missing file(s): bin/browser/defaults/settings/main
```
Flags: needinfo?(mathieu)
Comment hidden (mozreview-request)

Comment 9

11 months ago
Pushed by mleplatre@mozilla.com:
https://hg.mozilla.org/integration/autoland/rev/f00da9b0a455
Disable the dump for the tippytop collection r=nanj

Comment 10

11 months ago
bugherder
https://hg.mozilla.org/mozilla-central/rev/f00da9b0a455
Status: NEW → RESOLVED
Closed: 11 months ago
Resolution: --- → FIXED
Target Milestone: --- → Firefox 63

Comment 11

11 months ago
Pushed by mozilla@jorgk.com:
https://hg.mozilla.org/comm-central/rev/7c72a167ddb5
Port bug 1476934 to C-C [Disable the dump for the tippytop collection]. rs=bustage-fix
Per bug 1477818, please request Beta approval on this.
Flags: needinfo?(mathieu)
Assignee

Comment 13

11 months ago
I'm sorry to sound stupid, but how do I do this?
Flags: needinfo?(mathieu)
On the attachment, set the approval-mozilla-beta dropdown to ? and answer the questions in the comment box.
Assignee

Comment 15

11 months ago
Comment on attachment 8993363 [details]
Bug 1476934 - Disable the dump for the tippytop collection

Approval Request Comment
[Feature/Bug causing the regression]: Remote Settings initial data from JSON dumps
[User impact if declined]: None
[Is this code covered by automated tests?]: Yes
[Has the fix been verified in Nightly?]: Yes
[Needs manual test from QE? If yes, steps to reproduce]: No
[List of other uplifts needed for the feature/fix]: Relies on Bug 1451050
[Is the change risky?]: No
[Why is the change risky/not risky?]: The feature relying on this (ActivityStream Tippytop Bug 1437671) was not shipped yet, so 62 is not relying on it. We backported it just to avoid the xpcshell tests to fail when the periodic_file_updates.sh jobs runs.
[String changes made/needed]: None
Attachment #8993363 - Flags: approval-mozilla-beta?
I'll go ahead and mark this affected for 62 though it sounds like this only affect tests.
Comment on attachment 8993363 [details]
Bug 1476934 - Disable the dump for the tippytop collection

Looks like this should help us avoid the test failures from bug 1477818. 
Let's try it for beta 13.
Attachment #8993363 - Flags: approval-mozilla-beta? → approval-mozilla-beta+
Flags: qe-verify-
You need to log in before you can comment on or make changes to this bug.