Need to show in-field labels (small text and placeholder)

VERIFIED FIXED in Firefox 63

Status

()

defect
P1
normal
VERIFIED FIXED
11 months ago
10 months ago

People

(Reporter: jgong, Assigned: jaws)

Tracking

unspecified
Firefox 63
Points:
---
Dependency tree / graph

Firefox Tracking Flags

(firefox63 verified)

Details

(Whiteboard: [webpayments-reserve])

Attachments

(1 attachment, 1 obsolete attachment)

Reporter

Description

11 months ago
No description provided.
Reporter

Comment 1

11 months ago
Need to show labels in field label and animation between empty and selected state.  For example, for City field the label should be "City *" in empty state and animate when user starts typing in selected state.
Reporter

Comment 2

11 months ago
Animation is M4 and not needed for fx63.
Summary: Need to show in-field label and animation between empty and selected state → Need to show in-field label between empty and selected state
Whiteboard: [webpayments][triage] → [webpayments] [triage] [user-testing]
Whiteboard: [webpayments] [triage] [user-testing] → [webpayments-reserve]

Updated

11 months ago
Priority: P2 → P3
Summary: Need to show in-field label between empty and selected state → Need to show in-field labels (small text and placeholder)
Priority: P3 → P2

Updated

11 months ago
Flags: qe-verify?
Assignee: nobody → jaws
Status: NEW → ASSIGNED
Priority: P2 → P1
Blocks: 1480886
See Also: 1480886
Show the labels as placeholders inside of the fields.

Updated

11 months ago
Attachment #8998631 - Attachment description: Bug 1477100 - Show the labels as placeholders inside of the fields. r?mattn → Bug 1477100 - Show the labels as placeholders inside of the fields. r?MattN
Attachment #8998249 - Attachment is obsolete: true

Updated

11 months ago
Flags: qe-verify? → qe-verify+
QA Contact: hani.yacoub
Comment on attachment 8998631 [details]
Bug 1477100 - Show the labels as placeholders inside of the fields. r?MattN

Matthew N. [:MattN] (PM if requests are blocking you) has approved the revision.
Attachment #8998631 - Flags: review+

Comment 6

10 months ago
Pushed by jwein@mozilla.com:
https://hg.mozilla.org/integration/autoland/rev/32e2d0ddc56a
Show the labels as placeholders inside of the fields. r=MattN
There were also mochitest failures on test_address_form

Log link: https://treeherder.mozilla.org/logviewer.html#?job_id=194613101&repo=autoland&lineNumber=2086

Comment 9

10 months ago
Pushed by mozilla@noorenberghe.ca:
https://hg.mozilla.org/integration/mozilla-inbound/rev/8a7bbdede1c9
Show the labels as placeholders inside of the fields. r=MattN
Flags: needinfo?(jaws)

Comment 10

10 months ago
Pushed by mozilla@noorenberghe.ca:
https://hg.mozilla.org/integration/mozilla-inbound/rev/3575c52180c4
Scroll the country picker into view to fix browser_dropdowns.js. r=me

Comment 11

10 months ago
bugherder
https://hg.mozilla.org/mozilla-central/rev/8a7bbdede1c9
https://hg.mozilla.org/mozilla-central/rev/3575c52180c4
Status: ASSIGNED → RESOLVED
Closed: 10 months ago
Resolution: --- → FIXED
Target Milestone: --- → Firefox 63

Comment 12

10 months ago
verification-steps
Please wait to verify this bug until bug 1480886 lands as there are some temporary regressions about the address field positioning.
Duplicate of this bug: 1477104

Comment 14

10 months ago
The labels appear and are animated when their fields are active as the user starts to type.

However, in Edit mode, if there is a field with the red validation border triggered and the user clicks on the field, the label color will not turn to blue (as for the active state) until the user starts typing. 

Is this the expected behavior of the active state animation if an invalid field is selected?
Here is a screen recording of the behavior: https://streamable.com/ojmcn
Flags: needinfo?(jaws)
(In reply to Timea Babos from comment #14)
> The labels appear and are animated when their fields are active as the user
> starts to type.
> 
> However, in Edit mode, if there is a field with the red validation border
> triggered and the user clicks on the field, the label color will not turn to
> blue (as for the active state) until the user starts typing. 
> 
> Is this the expected behavior of the active state animation if an invalid
> field is selected?
> Here is a screen recording of the behavior: https://streamable.com/ojmcn

No, that's not expected. We should show the text as blue when the field is focused even if the field is marked as invalid. Can you file a follow-up bug to fix this?
Flags: needinfo?(jaws) → needinfo?(timea.babos)

Comment 16

10 months ago
Here it is: Bug 1488764. Will close this issue once the new one will be fixed. Thank you.
Flags: needinfo?(timea.babos)

Comment 17

10 months ago
Since Bug 1488764 is not an issue, I will mark this issue as Verified - Fixed based on Comment  14 on Windows 10, Ubuntu 18.04 and Mac OS 10.13.
Status: RESOLVED → VERIFIED
Flags: qe-verify+
You need to log in before you can comment on or make changes to this bug.