Closed Bug 1477234 Opened 2 years ago Closed 2 years ago

WeekPicker starts with incorrect values

Categories

(Firefox for Android :: General, defect)

All
Android
defect
Not set

Tracking

()

VERIFIED FIXED
Firefox 63
Tracking Status
firefox61 --- wontfix
firefox62 --- verified
firefox63 --- verified

People

(Reporter: petru, Assigned: petru)

References

(Blocks 1 open bug)

Details

Attachments

(1 file)

Environment: 
Existing bug, is reproducing on all devices.

Steps to reproduce:
1. Launch Firefox;
2. Go to http://www.456bereastreet.com/lab/html5-input-types/.
3. Tap on Week (week).

Expected result:
The spinner that allows setting the week should start at the current week and show all possible values to the user.

Actual result:
The weeks spinner:
- always starts with the selected value "01"
- the maximum week number is the current week number in the year and is displayed on top of the selected value.
Only after scrolling the starting maximum week number out of view the week spinner will actually display all possible values.

Issue can be seen reproduced here - https://drive.google.com/file/d/1xAbEVJcxNUnTEs-ECAzaUyGhXOBnsCIx/view?usp=sharing
Assignee: nobody → petru.lingurar
Status: NEW → ASSIGNED
Attachment #8994112 - Flags: review?(sdaswani) → review?(nchen)
Comment on attachment 8994112 [details]
Bug 1477234 - WeekPicker starts with incorrect values;

https://reviewboard.mozilla.org/r/258734/#review265792
Attachment #8994112 - Flags: review?(nchen) → review+
Keywords: checkin-needed
Pushed by rgurzau@mozilla.com:
https://hg.mozilla.org/integration/autoland/rev/79defe08cdbf
WeekPicker starts with incorrect values; r=jchen
Keywords: checkin-needed
https://hg.mozilla.org/mozilla-central/rev/79defe08cdbf
Status: ASSIGNED → RESOLVED
Closed: 2 years ago
Resolution: --- → FIXED
Target Milestone: --- → Firefox 63
Flags: qe-verify+
Verified as fixed on build 63.0a1 - 2018/07/29 following the steps from the description.
Device: Motorola Nexus 6(Android 7.1.1), Sony Xperia Z5 Premium (Android 6.0.1).
Flags: qe-verify+
Please nominate this for Beta approval when you get a chance.
Flags: needinfo?(petru.lingurar)
Comment on attachment 8994112 [details]
Bug 1477234 - WeekPicker starts with incorrect values;

Approval Request Comment
[Feature/Bug causing the regression]: WeekPicker starts with incorrect values
[User impact if declined]: Bad UX; User has to scroll to get access to all weeks which are not shown the first time the widget is shown.
[Is this code covered by automated tests?]: No
[Has the fix been verified in Nightly?]: Yes
[Needs manual test from QE? If yes, steps to reproduce]: --
[List of other uplifts needed for the feature/fix]: --
[Is the change risky?]: No
[Why is the change risky/not risky?]: Has been QE verified and in the time being in Nightly no issues have been reported.
[String changes made/needed]: --
Flags: needinfo?(petru.lingurar)
Attachment #8994112 - Flags: approval-mozilla-beta?
Petru, just a note that in the uplift request template  "Feature/Bug causing the regression" should refer to the bug or patch where the problem was caused. So for this and several other related issues, it looks to me like that means bug 1318046.
Comment on attachment 8994112 [details]
Bug 1477234 - WeekPicker starts with incorrect values;

One of several small fixes for the date picker related to the switch in 62 to using the platform library. Verified in nightly. 
Let's uplift for next Monday's beta 17 build.
Attachment #8994112 - Flags: approval-mozilla-beta? → approval-mozilla-beta+
Flags: qe-verify+
Can you please check this, Igor?
Flags: needinfo?(igor.lazar)
Device:
 - Samsung Galaxy Note 8 (Android 8.0.0)

Verified as fixed in 62.0b17 following the steps provided in Comment 0.
Status: RESOLVED → VERIFIED
Flags: qe-verify+
Flags: needinfo?(igor.lazar)
You need to log in before you can comment on or make changes to this bug.