remove obsolete pref network.hosts.nntp_server

RESOLVED FIXED in mozilla1.9.1b1

Status

defect
P4
trivial
RESOLVED FIXED
17 years ago
10 years ago

People

(Reporter: asmozilla2, Assigned: mkmelin)

Tracking

Trunk
mozilla1.9.1b1

Firefox Tracking Flags

(Not tracked)

Details

(URL)

Attachments

(1 attachment, 1 obsolete attachment)

(Reporter)

Description

17 years ago
In defaults/pref/all.js there is a note that the default of 'news.mozilla.org'
needs to be changed to 'news' once the beta ends. So this is a reminder to do that.

The note is by, or to, 'sspitzer' but I don't know his email to add him as a CC.

Comment 1

17 years ago
Ring Ring....... Seth, Ben, 

has this been done, or is it still in neeed of being done? and what exactly does
this refer to? NS7 or Moz1.0?

Moz1.0 is almost out the door, so whichever it is, this should be looked at.

confirming since this seems to be known anyway.... 
Status: UNCONFIRMED → NEW
Ever confirmed: true
(Reporter)

Comment 2

17 years ago
Nominating for mozilla 1.0.1 and for the netscape (adt) release.

If this bug is determined to be invalid, at least remove the reminder message in
the prefs file, and close this bug.
Target Milestone: --- → mozilla1.0.1
pls have this reviewed by the Nav triage team, attach a patch, and get r/sr=
before nominating for checkin to the 1.0 branch. thanks!

removing adt1.0.1
Keywords: adt1.0.0approval, nsbeta1
Whiteboard: [Need Impact]

Comment 4

17 years ago
-> MailNews
Assignee: ben → sspitzer
Component: Preferences → Networking: News
Product: Browser → MailNews
QA Contact: sairuh → stephend
Target Milestone: mozilla1.0.1 → ---
(Reporter)

Comment 5

17 years ago
Does this need to be fixed? sspitzer? You added this, isn't it time to remove it
and change the default nntp_server back to just news?
(Reporter)

Comment 6

17 years ago
Posted patch Patch to remove old text. (obsolete) — Splinter Review
Change default nntp_sever to just 'news' instead of news.mozilla.org.
(Reporter)

Updated

17 years ago
Attachment #109665 - Flags: review?
(Reporter)

Updated

17 years ago

Updated

17 years ago
Attachment #109665 - Flags: superreview?(sspitzer)
Attachment #109665 - Flags: review?(sspitzer)
Attachment #109665 - Flags: review?
Guessing here because the pref is never used :-)
Severity: normal → trivial
Summary: pref network.hosts.nntp_server needs to be changed (reminder) → pref network.hosts.nntp_server needs to be removed
Product: MailNews → Core

Updated

14 years ago
Attachment #109665 - Flags: superreview?(sspitzer)
Attachment #109665 - Flags: superreview?(neil.parkwaycc.co.uk)
Attachment #109665 - Flags: review?(sspitzer)
Attachment #109665 - Flags: review?(neil.parkwaycc.co.uk)
Comment on attachment 109665 [details] [diff] [review]
Patch to remove old text.

This is an unused pref to IMHO the correct fix is to remote the pref completely
and also the line in nsNntpService.cpp that refers to it.
Attachment #109665 - Flags: superreview?(neil.parkwaycc.co.uk)
Attachment #109665 - Flags: superreview-
Attachment #109665 - Flags: review?(neil.parkwaycc.co.uk)
sorry for the spam.  making bugzilla reflect reality as I'm not working on these bugs.  filter on FOOBARCHEESE to remove these in bulk.
Assignee: sspitzer → nobody
Neil in comment #8
> (From update of attachment 109665 [details] [diff] [review])
> This is an unused pref to IMHO the correct fix is to remote (sic) the pref completely
> and also the line in nsNntpService.cpp that refers to it.

If this pref is no longer appropriate, is there a need for a different implementation of default news server?

FWIW this was wontfixed in bug 8053 - perhaps for reasons that are no longer relevant.
QA Contact: stephend → networking.news
(Assignee)

Updated

11 years ago
Keywords: polish
Summary: pref network.hosts.nntp_server needs to be removed → remove obsolte pref network.hosts.nntp_server
Whiteboard: [Need Impact]
(Assignee)

Comment 12

11 years ago
Posted patch proposed fixSplinter Review
Remove it. 
Now, if I can only figure out the repo situation :/
Assignee: nobody → mkmelin+mozilla
Attachment #109665 - Attachment is obsolete: true
Status: NEW → ASSIGNED
Attachment #327389 - Flags: superreview?(neil)
Attachment #327389 - Flags: review?(neil)
(Assignee)

Updated

11 years ago
Priority: -- → P4

Updated

11 years ago
Attachment #327389 - Flags: superreview?(neil)
Attachment #327389 - Flags: superreview+
Attachment #327389 - Flags: review?(neil)
Attachment #327389 - Flags: review+
(Assignee)

Comment 13

11 years ago
changeset:   209:771f940f90f5
http://hg.mozilla.org/comm-central/index.cgi/rev/771f940f90f5

Checking in minimo/customization/all.js;
/cvsroot/mozilla/minimo/customization/all.js,v  <--  all.js
new revision: 1.55; previous revision: 1.54
done

mozilla-central part of the patch still to go...
(Assignee)

Comment 14

11 years ago
pushed to mozilla-central also, changeset:   19107:853fde538b60
http://hg.mozilla.org/mozilla-central/rev/853fde538b60

->FIXED
Status: ASSIGNED → RESOLVED
Last Resolved: 11 years ago
Resolution: --- → FIXED
Target Milestone: --- → mozilla1.9.1b1
Summary: remove obsolte pref network.hosts.nntp_server → remove obsolete pref network.hosts.nntp_server
Product: Core → MailNews Core
You need to log in before you can comment on or make changes to this bug.