Closed Bug 14781 Opened 21 years ago Closed 21 years ago

View Source refetches the document!

Categories

(SeaMonkey :: UI Design, defect, P3)

x86
Windows 98
defect

Tracking

(Not tracked)

VERIFIED DUPLICATE of bug 6119

People

(Reporter: ian, Assigned: fur)

References

()

Details

When you choose View Source, Mozilla goes and refetches the document on the net!

This means that you cannot view the source of dynamically created documents.

TO REPRODUCE:
  1. Go to http://www.bath.ac.uk/%7Epy8ieh/cgi/formtester.pl
  2. Click on the check box in the "Simple POST Form".
  3. Submit the POST form.
  4. Notice it says "Results of Last Submission" at the top of the page.
  5. Choose View Source (in Viewer, File|ViewSource).
  6. Look for the text "Results of Last Submission".

ACTUAL RESULTS:
  The source shown in ViewSource is NOT that used to render the document.
  This can be clearly seen by the fact that the markup in ViewSource could
  not generate the document seen! The entire "Results" section at the top of
  the document is missing, because Mozilla went and refetched the page.

EXPECTED RESULTS:
  Mozilla just uses its (in-memory) cached copy of the document for the
  ViewSource window. No network connection should be made for ViewSource.

NOTES:
  IE does this fine. Also note that making sure that the document is refetched
  using exactly the same call IS NOT a suitable fix, since:
   a. If the document is the result of a POST submission, refetching it could
      trigger things like a bank transfer!
   b. In any case, dynamically created documents may be different on each fetch
      regardless of whether it is a GET or a POST -- think random quote pages.
   c. If the page takes a long time to load (e.g., it is created by a slow
      script) then you don't want to wait the time again!
  We must use a local copy of the page for View Source!
Assignee: rickg → warren
Warren -- I'm giving this to you as a placeholder. When the cache is in, this
bug will go away by itself.
Assignee: warren → fur
Depends on: 8305
Target Milestone: M14
Status: NEW → RESOLVED
Closed: 21 years ago
Resolution: --- → DUPLICATE
*** This bug has been marked as a duplicate of 6119 ***
Status: RESOLVED → VERIFIED
Yup, it's a dup.
Component: XP Utilities → XP Apps: GUI Features
Product: Core → Mozilla Application Suite
Component: XP Apps: GUI Features → UI Design
You need to log in before you can comment on or make changes to this bug.