[Arch] Cache needs to be implemented

VERIFIED FIXED in M13

Status

()

P2
normal
VERIFIED FIXED
20 years ago
19 years ago

People

(Reporter: morse, Assigned: fur)

Tracking

Trunk
Points:
---
Dependency tree / graph

Firefox Tracking Flags

(Not tracked)

Details

(URL)

(Reporter)

Description

20 years ago
dp wanted to know why we are not eating dogfood yet and encouraged us to spend an hour with the 5.0 browser to see what is blocking us.  OK, I tried it and attemted to file a bug report with bugzilla.  Filled in a form but had an error in it.  Got the bugzilla error messagae that instructed me to press the back button and correct my error.  I did so but all the information that I had previously entered on the form was missing -- I had to re-enter it all over again.  In 4.x, that information is cached and so automatically reappears when the back button is pressed.
(Reporter)

Comment 1

20 years ago
Sorry about the description line on this bug not wrapping.  That's another bug
(see 8507).  I filed this original report using 5.0 but I am filling this
comment using 4.5 so it should wrap properly.

Updated

20 years ago
Assignee: dp → warren

Comment 2

20 years ago
CGIs arent cached in session history. Maybe this requires a real cache.

Updated

20 years ago
Assignee: warren → dp

Comment 3

20 years ago
I don't know what I'm supposed to do with this. When necko is switched on, it
won't yet have a cache. We know we have to fix that. Do you just want this to be
a bug to hang dependencies on?

Updated

20 years ago
Assignee: dp → warren

Comment 4

20 years ago
Naa. If you think you already have a bug on this, just mark this dup.

Updated

20 years ago
Status: NEW → ASSIGNED

Updated

20 years ago
Component: Cache → Necko
Target Milestone: M10

Comment 5

20 years ago
Changing the component to necko to make it easier to track this.

Updated

19 years ago
Blocks: 12833

Updated

19 years ago
Assignee: warren → fur
Status: ASSIGNED → NEW

Comment 6

19 years ago
Scott Furman is going to take over the cache stuff.

Updated

19 years ago
Blocks: 6119
(Assignee)

Comment 7

19 years ago
Wait a minute.  The original reporter of this bug reported a problem with
caching of forms values, i.e. so that when you go back to a page it fills out
the forms the same way that they were filled in the last time you visited that
page.  That's part of the session history - not the Necko cache.  Who owns
session history ?

Comment 8

19 years ago
there is a bug 13537 assigned to Don right now that deals with form caching

Updated

19 years ago
Depends on: 6292

Updated

19 years ago
OS: Windows 95 → All
Hardware: PC → All
Summary: cache not working (or: "Why I'm not eating dogfood yet") → Cache needs to be implemented

Comment 9

19 years ago
Okay, I am calling this the great cache bug, if anyone has a problem speak up
(this is actually paulmac). Setting component to all.

Updated

19 years ago
Blocks: 14050

Comment 10

19 years ago
I had set up a meta bug 14050 for cache.

Updated

19 years ago
Blocks: 14781

Updated

19 years ago
Target Milestone: M10 → M11

Comment 11

19 years ago
sound like m11.  our hopes and prayers are with you.  gods speed scott furman.
;-)

Updated

19 years ago
Blocks: 15162

Updated

19 years ago
Priority: P3 → P2

Updated

19 years ago
Blocks: 16950

Updated

19 years ago
Summary: Cache needs to be implemented → [Arch] Cache needs to be implemented

Comment 12

19 years ago
Added a new keyword Arch to the title to help make it easier for pointy heads
like me that are scanning summary to see this is fundamental architectural stuff
that we want landed sooner, and hence should have a high priority.  I know it
already has the priority... it is just easier to spot in the summary :-).

Updated

19 years ago
Blocks: 17432

Updated

19 years ago
Blocks: 17907

Updated

19 years ago
Target Milestone: M11 → M12

Comment 13

19 years ago
shooting for m12 tree open

Updated

19 years ago
Blocks: 18471
(Assignee)

Updated

19 years ago
Status: NEW → ASSIGNED
(Assignee)

Updated

19 years ago
No longer depends on: 6292
(Assignee)

Updated

19 years ago
Blocks: 6292

Comment 14

19 years ago
*** Bug 19443 has been marked as a duplicate of this bug. ***
Blocks: 17309
(Assignee)

Updated

19 years ago
Blocks: 5030
(Assignee)

Updated

19 years ago
Blocks: 20893

Updated

19 years ago
Blocks: 21036

Comment 15

19 years ago
Moving what's not done for M12 to M13.
(Assignee)

Comment 16

19 years ago
Cache is currently implemented, but needs to be turned on by pref.  See message
on n.p.m.seamonkey
(Assignee)

Updated

19 years ago
Status: ASSIGNED → RESOLVED
Last Resolved: 19 years ago
Resolution: --- → FIXED
(Assignee)

Comment 17

19 years ago
I'm going to mark this as FIXED, since the code is basically working and checked
in.  I've filed separate bugs for individual problems observed with the new
cache implementaion.

Comment 18

19 years ago
Bulk move of all Necko (to be deleted component) bugs to new Networking

component.

Updated

19 years ago
Status: RESOLVED → VERIFIED

Comment 19

19 years ago
marking as verified, cache exists now, other bugs to surely follow

Updated

19 years ago
No longer blocks: 17309

Updated

19 years ago
No longer blocks: 17432

Updated

19 years ago
No longer blocks: 17907

Updated

19 years ago
No longer blocks: 18471
You need to log in before you can comment on or make changes to this bug.