Closed Bug 1479312 Opened 2 years ago Closed 2 years ago

Move WebNavigation and WebProgress listeners out of browser-child.js

Categories

(Toolkit :: General, enhancement)

enhancement
Not set

Tracking

()

RESOLVED FIXED
mozilla63
Tracking Status
firefox63 --- fixed

People

(Reporter: kmag, Assigned: kmag)

References

(Blocks 1 open bug)

Details

(Whiteboard: [overhead:5k])

Attachments

(1 file)

In addition to the extra base overhead of having these in a frame script rather than the shared JSM global, instantiating these from a frame script means that we have to re-evaluate their scripts in a new global for every frameloader we create, rather than just sharing a single instance of the scripts.
Comment on attachment 8995833 [details]
Bug 1479312: Move WebNavigation and WebContent child listeners to JSMs.

https://reviewboard.mozilla.org/r/260174/#review267388

uber-nit: commit msg says WebContent instead of WebProgress
Attachment #8995833 - Flags: review?(felipc) → review+
(In reply to :Felipe Gomes (needinfo me!) from comment #2)
> uber-nit: commit msg says WebContent instead of WebProgress

Yeah, sorry. I noticed that after I pushed, but it didn't seem worth updating for.
https://hg.mozilla.org/integration/mozilla-inbound/rev/d403426d1dcdd7b7cd5b51e62b7b71c5d69631a3
Bug 1479312: Move WebNavigation and WebProgress child listeners to JSMs. r=felipe
:/ This is because of bug 1478305
Flags: needinfo?(kmaglione+bmo)
https://hg.mozilla.org/integration/mozilla-inbound/rev/a68daa762119d5f2f67fdb2c29d2d70bf9ec89c8
Bug 1479312: Move WebNavigation and WebProgress child listeners to JSMs. r=felipe
https://hg.mozilla.org/mozilla-central/rev/a68daa762119
Status: NEW → RESOLVED
Closed: 2 years ago
Resolution: --- → FIXED
Target Milestone: --- → mozilla63
Backed out for causing a big performance regression on OS X and as request by igoldan. 

https://hg.mozilla.org/mozilla-central/rev/fe6020e5c9d901a40fa2e7ea2f1ab2a36bf6d856
Status: RESOLVED → REOPENED
Flags: needinfo?(kmaglione+bmo)
Resolution: FIXED → ---
Target Milestone: mozilla63 → ---
https://hg.mozilla.org/integration/mozilla-inbound/rev/d9c4348fdca4a4fd96e234aed4886f444834f1d5
Bug 1479312: Move WebNavigation and WebProgress child listeners to JSMs. r=felipe
https://hg.mozilla.org/mozilla-central/rev/d9c4348fdca4
Status: REOPENED → RESOLVED
Closed: 2 years ago2 years ago
Resolution: --- → FIXED
Target Milestone: --- → mozilla63
Flags: needinfo?(kmaglione+bmo)
Depends on: 1489762
No longer depends on: 1489762
You need to log in before you can comment on or make changes to this bug.