BUGZILLA.bug_url is wrong on bug page after POSTed, Copy Summary doesn’t work as expected

RESOLVED FIXED

Status

()

RESOLVED FIXED
8 months ago
5 months ago

People

(Reporter: kohei, Assigned: kohei)

Tracking

Production

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment, 1 obsolete attachment)

After creating or updating a bug, the long `post_bug.cgi` URL will be replaced with a short `show_bug.cgi` URL using `history.replaceState()`, but `BUGZILLA.bug_url` variable and `<meta property="og:url">` are not updated. Clicking the Copy Summary button copies the unwanted `post_bug.cgi` URL.
Comment hidden (obsolete)
Status: ASSIGNED → RESOLVED
Last Resolved: 5 months ago
Resolution: --- → DUPLICATE
Duplicate of bug: 1468848
Duplicate of this bug: 1502196
Let’s fix this first without waiting for Bug 1468848.
Status: RESOLVED → REOPENED
Resolution: DUPLICATE → ---
Status: REOPENED → ASSIGNED
Summary: BUGZILLA.bug_url is wrong on bug page after POSTed → BUGZILLA.bug_url is wrong on bug page after POSTed, Copy Summary doesn’t work as expected
Attachment #8996055 - Attachment is obsolete: true
Merged to master.
Status: ASSIGNED → RESOLVED
Last Resolved: 5 months ago5 months ago
Resolution: --- → FIXED
You need to log in before you can comment on or make changes to this bug.