Closed Bug 1479724 Opened Last year Closed 9 months ago

Provide Adaptive icons for Beta and Dev builds

Categories

(Firefox for Android :: General, defect, P1)

All
Android
defect

Tracking

()

RESOLVED FIXED
Firefox 65
Tracking Status
firefox63 --- wontfix
firefox64 --- wontfix
firefox65 --- verified

People

(Reporter: petru, Assigned: petru)

References

(Blocks 1 open bug)

Details

Attachments

(3 files)

This is a continuation of the work from bug 1349522.
That ensured adaptive icons for the Release and Nightly builds.
This will add the remaining icons for the Beta and Unnoficial builds.
Blocks: android-o
Bram, when the adaptive icons resources for the Release and Unofficial builds are ready (can be just one xxxhdpi foreground layer image and a color code) please add them to this ticket.
Flags: needinfo?(bram)
Hi Petru,

attachment 8995027 [details] contains the adaptive icons for the Dev/Nightly channel.

The beta one still needs some thinking.
Flags: needinfo?(bram)
(In reply to Bram Pitoyo [:bram] from comment #2)
> Hi Petru,
> 
> attachment 8995027 [details] contains the adaptive icons for the Dev/Nightly
> channel.
> 
> The beta one still needs some thinking.

Hey Bram, just to confirm,
Until now the Dev builds/Unnoficial builds had different icons than the Nightly builds.
https://dxr.mozilla.org/mozilla-central/rev/085cdfb90903d4985f0de1dc7786522d9fb45596/mobile/android/branding/unofficial/res/drawable-xxhdpi/icon.png
vs
https://dxr.mozilla.org/mozilla-central/rev/085cdfb90903d4985f0de1dc7786522d9fb45596/mobile/android/branding/nightly/res/drawable-xxhdpi/icon.png

From now on they will use the same?
NI bram so he can address.
Flags: needinfo?(bram)
Petru,

Aha. I didn’t know that the dev/unofficial builds uses a different icon than the Nightly builds.

Can you help me understand the difference between dev/unofficial and Nightly?
Flags: needinfo?(bram) → needinfo?(petru.lingurar)
(In reply to Bram Pitoyo [:bram] from comment #5)
> Petru,
> 
> Aha. I didn’t know that the dev/unofficial builds uses a different icon than
> the Nightly builds.
> 
> Can you help me understand the difference between dev/unofficial and Nightly?

The unofficial builds are what anybody can can build from the publicly available mozilla-central repo.
All our patches are based on mozilla-central and all the builds we do as part of developing Fennec will be these unofficial builds.

The nightly builds are official builds, built twice a day and contain all the patches previously submitted. 

The important difference here is that while the unofficial builds must be individually built with patches from Mozilla central and are usually just for personal use or for testing, the nightly builds are ~automatically built by and made available from Mozilla.
Flags: needinfo?(petru.lingurar)
Flags: needinfo?(bram)
Thanks a lot for the clarification, Petru!

This is a question for our visual designers. I’ve asked them for feedback, and will get back to you once I heard back.

It’s likely that we’d like to design a different icon from Nightly.
We are getting close to the beta merge. It would be good to have the icons for Beta and Release landed so that this is in from B1. Can we do a follow up bug on the icon for unbranded builds.
Sending a needinfo request to Shorlander.
Flags: needinfo?(bram) → needinfo?(shorlander)
Too late to fix in 63 but we could still take a patch for 65 and potentially 64. 

Kevin, what is the current state here? Do we have the beta and release icons, but still lack one for unbranded builds?
Flags: needinfo?(kbrosnan)
Priority: -- → P1
you should fix it to upload new version to google play
https://www.xda-developers.com/google-play-app-updates-must-target-android-8-0/
This works for me in all channels including developer builds. I get the expected adaptive icons.
Status: NEW → RESOLVED
Closed: 9 months ago
Flags: needinfo?(shorlander)
Flags: needinfo?(kbrosnan)
Resolution: --- → WORKSFORME
Please note that the current icons for Beta and Dev builds are "placeholder icons" I've added in bug 1349522. 
See bug 1349522 comment 29
For them I've used the old icons and the already provided background color for the Fennec Release icons.
The plan was to update them whenever official resources would be available.
I see some confusing comments related to the different icons. Probably because there are so many variants.
Bug 1349522 which added all current adaptive icons only had official resources (from UX team) for Release and Nightly builds. (the .zip attachments).
The rest - Beta and Developer builds use "placeholder" icons.
Hi Petru,

I’ve just uploaded the adaptive icons for Firefox for Android Beta and Dev (unofficial) builds on bug 1349522.

* Beta adaptive icons: attachment 9025225 [details] 
* Dev adaptive icons: attachment 9025226 [details]

This complements our other adaptive icon assets:

* Release adaptive icons: attachment 8995026 [details]
* Nightly adaptive icons: attachment 8995027 [details]


On bug 1349522 comment 32, I wrote:

> I’ll leave it up to engineering whether they’d like to use the provided background image, or add an `ic_background` colour value. I’d be okay if we don’t use the PNG background provided.

This also applies to these Beta and Dev icons. Feel free to either use the colour value provided, or add your own value of ink-80: #202340.


With all four sets of the adaptive icons posted (Release, Beta, Nightly and Dev), this should complete our set.

Are we missing anything else?
Flags: needinfo?(petru.lingurar)
This are used as logos and by SiteIdentityPopup.java

Depends on D12024
Nice work on the icons!
Especially on that for the dev builds, much better than the old!

Beside the new adaptive icons there were icons to be used pre-Oreo (see bug 1480854) and also logos and such.
I've took the liberty to update them myself to speed up ticket's resolution.
For that I've tried to add you Bram also as a reviewer but I couldn't find you on Phabricator. Possibly because you don't have an account there? Anyhow, I'd appreciate if you'd take a look on the icons and validate they all respect the intended directions.
Flags: needinfo?(petru.lingurar) → needinfo?(bram)
(In reply to Petru-Mugurel Lingurar[:petru] from comment #19)
> I've took the liberty to update them myself to speed up ticket's resolution.
> For that I've tried to add you Bram also as a reviewer but I couldn't find
> you on Phabricator. Possibly because you don't have an account there?
> Anyhow, I'd appreciate if you'd take a look on the icons and validate they
> all respect the intended directions.

Hi Petru, I’ve just registered for a Phabricator account and submitted my reviews there.
Flags: needinfo?(bram)
Attachment #9025370 - Attachment description: Bug 1479724 - Part 3: Logos for Beta and Dev builds; r?sdaswani → Bug 1479724 - Part 3: Logos for Dev builds; r?sdaswani, bram
Attachment #9025369 - Attachment description: Bug 1479724 - Part 2: Pre-Oreo icons for Beta and Dev builds; r?sdaswani → Bug 1479724 - Part 2: Pre-Oreo icons for Dev builds; r?sdaswani, bram
Assignee: nobody → petru.lingurar
Status: RESOLVED → REOPENED
Resolution: WORKSFORME → ---
As Jan suggested I will try to use pngcrush for all the newly added images to try to reduce their size.
@Jan in the hope that you've used pngcrush before, what do you think about the following arguments for it?
> -rem allb — remove all extraneous data
> -brute - attempt all optimization methods 
> -reduce — eliminate unused colors and reduce bit-depth 
> -l9 - try different compressions, choose the one that compresses the file the most

I see a 23%-25% filesize reduction
Flags: needinfo?(jh+bugzilla)
I didn't, but those options and numbers look reasonable, thanks.
Flags: needinfo?(jh+bugzilla)
Keywords: checkin-needed
Pushed by ebalazs@mozilla.com:
https://hg.mozilla.org/integration/autoland/rev/0a6efd77a79e
Part 1: Adaptive icons for Beta and Dev builds; r=sdaswani,bram,JanH
https://hg.mozilla.org/integration/autoland/rev/a314851c740f
Part 2: Pre-Oreo icons for  Dev builds; r=sdaswani,bram,JanH
https://hg.mozilla.org/integration/autoland/rev/5335dd9d85ca
Part 3: Logos for  Dev builds; r=sdaswani,bram,JanH
Keywords: checkin-needed
Flags: qe-verify+
Comment on attachment 9025368 [details]
Bug 1479724 - Part 1: Adaptive icons for Beta and Dev builds; r?sdaswani

[Beta/Release Uplift Approval Request]

Feature/Bug causing the regression: None

User impact if declined: New image assets for beta are only relevant for beta builds. Doesn't need to ride the trains.

Is this code covered by automated tests?: No

Has the fix been verified in Nightly?: No

Needs manual test from QE?: Yes

If yes, steps to reproduce: Verify that the new adaptive icons are properly displayed on Android >=8 and that the previous behavior for devices running older Android versions is unaffected.

List of other uplifts needed: None

Risk to taking this patch: Low

Why is the change risky/not risky? (and alternatives if risky): Small change in the images used as Adaptive Icons.

String changes made/needed:
Attachment #9025368 - Flags: approval-mozilla-beta?
We're close to the end of beta64 and this is not a new issue, IMO it can ride to 65.
Attachment #9025368 - Flags: approval-mozilla-beta? → approval-mozilla-beta-
https://hg.mozilla.org/mozilla-central/rev/0a6efd77a79e
https://hg.mozilla.org/mozilla-central/rev/a314851c740f
https://hg.mozilla.org/mozilla-central/rev/5335dd9d85ca
Status: REOPENED → RESOLVED
Closed: 9 months ago9 months ago
Resolution: --- → FIXED
Target Milestone: --- → Firefox 65
Verified as fixed on latest Nightly build (2018-12-07).
Devices: 
- Xiaomi Mi4i (Android 5.0.2)
- Nexus 5(Android 6.0.1)
- HTC Desire 820 (Android 6.0.1)
- Sony Xperia Z5 Premium(Android 7.1.1)
- Samsung Galaxy S8 (Android 8.0)
Flags: qe-verify+
Note: tested also with unofficial builds. Adding again the qe-verify flag to test in Beta.
Flags: qe-verify+
Verified as fixed in build 65.0b4 with the following devices:
- Nokia 6P (Android 7.1.1);
- Huawei MediaPad M2 (Android 5.1.1)
- Nexus 6P (Android 8.1.0)

On Google Pixel (Android 9) here is a screenshot:https://i.imgur.com/7JAwUQb.png. Is this expected because of the round icon?
Flags: qe-verify+ → needinfo?(bram)
(In reply to Sorina Florean [:sorina] from comment #30)
> Verified as fixed in build 65.0b4 with the following devices:
> - Nokia 6P (Android 7.1.1);
> - Huawei MediaPad M2 (Android 5.1.1)
> - Nexus 6P (Android 8.1.0)
> 
> On Google Pixel (Android 9) here is a
> screenshot:https://i.imgur.com/7JAwUQb.png. Is this expected because of the
> round icon?

Update: is expected that the green band containing the word "Beta" to be cut off in the round icon?
(In reply to Sorina Florean [:sorina] from comment #31)
> Update: is expected that the green band containing the word "Beta" to be cut
> off in the round icon?

Yes. That’s expected. Our beta band extends all the way to the edge of the icon, so whatever the icon frame may be (square, circle, etc.), it will always fit and never get cut off.
Flags: needinfo?(bram)
You need to log in before you can comment on or make changes to this bug.