Closed Bug 1480228 (hg47) Opened Last year Closed Last year

[meta] Mercurial 4.7 upgrade and compatibility

Categories

(Developer Services :: Mercurial: hg.mozilla.org, defect)

defect
Not set

Tracking

(Not tracked)

RESOLVED FIXED

People

(Reporter: sheehan, Assigned: sheehan)

References

(Blocks 1 open bug)

Details

(Keywords: leave-open, meta)

Attachments

(14 files)

46 bytes, text/x-phabricator-request
gps
: review+
Details | Review
46 bytes, text/x-phabricator-request
gps
: review+
Details | Review
46 bytes, text/x-phabricator-request
gps
: review+
Details | Review
46 bytes, text/x-phabricator-request
gps
: review+
Details | Review
46 bytes, text/x-phabricator-request
gps
: review+
Details | Review
46 bytes, text/x-phabricator-request
gps
: review+
Details | Review
46 bytes, text/x-phabricator-request
gps
: review+
Details | Review
46 bytes, text/x-phabricator-request
gps
: review+
Details | Review
46 bytes, text/x-phabricator-request
Details | Review
46 bytes, text/x-phabricator-request
Details | Review
46 bytes, text/x-phabricator-request
Details | Review
46 bytes, text/x-phabricator-request
Details | Review
46 bytes, text/x-phabricator-request
Details | Review
46 bytes, text/x-phabricator-request
Details | Review
Mercurial 4.7 is out. This bug tracks progress for upgrading hg.mozilla.org and other components.
Summary: [meta] Mercurial 4.7 upgrade → [meta] Mercurial 4.7 upgrade and compatibility
Depends on: 1480232
Depends on: 1480557
Depends on: 1482325
Depends on: 1483722
Depends on: 1485873
Depends on: 1485874
Depends on: 1485876
Depends on: 1485877
Depends on: 1485878
Depends on: 1485880
Depends on: 1485882
Tests pass with no changes. We also remove
4.3 support with this commit.
Tests pass with no changes. Also remove 4.3
support with this commit.
Test pass with no changes. I've decided not to remove
legacy compatibility since the extension itself is
legacy.
Tests pass with no changes.
Remove all the 4.5 compatibility code for a nice cleanup
while we're at it.
Comment on attachment 9003821 [details]
manualoverlay: mark as Mercurial 4.7 compatible (Bug 1480228) r?gps

Gregory Szorc [:gps] has approved the revision.
Attachment #9003821 - Flags: review+
Pushed by gszorc@mozilla.com:
https://hg.mozilla.org/hgcustom/version-control-tools/rev/58ac33356793
manualoverlay: mark as Mercurial 4.7 compatible r=gps
Comment on attachment 9003822 [details]
obsolescencehacks: mark as compatible with Mercurial 4.7 (Bug 1480228) r?gps

Gregory Szorc [:gps] has approved the revision.
Attachment #9003822 - Flags: review+
Pushed by gszorc@mozilla.com:
https://hg.mozilla.org/hgcustom/version-control-tools/rev/36d10f94cbfd
obsolescencehacks: mark as compatible with Mercurial 4.7 r=gps
Pushed by gszorc@mozilla.com:
https://hg.mozilla.org/hgcustom/version-control-tools/rev/c46bd2e22da7
push-to-try: mark as compatible with Mercurial 4.7 r=gps
Comment on attachment 9003823 [details]
push-to-try: mark as compatible with Mercurial 4.7 (Bug 1480228) r?gps

Gregory Szorc [:gps] has approved the revision.
Attachment #9003823 - Flags: review+
Comment on attachment 9003825 [details]
qbackout: mark as compatible with Mercurial 4.7 (Bug 1480228) r?gps

Gregory Szorc [:gps] has approved the revision.
Attachment #9003825 - Flags: review+
Pushed by gszorc@mozilla.com:
https://hg.mozilla.org/hgcustom/version-control-tools/rev/8ae0e0aaf000
qbackout: mark as compatible with Mercurial 4.7 r=gps
Comment on attachment 9003826 [details]
qimportbz: mark as compatible with Mercurial 4.7 (Bug 1480228) r?gps

Gregory Szorc [:gps] has approved the revision.
Attachment #9003826 - Flags: review+
Pushed by gszorc@mozilla.com:
https://hg.mozilla.org/hgcustom/version-control-tools/rev/e681681e3368
qimportbz: mark as compatible with Mercurial 4.7 r=gps
Comment on attachment 9003827 [details]
readonly: mark as compatible with Mercurial 4.7 (Bug 1480228) r?gps

Gregory Szorc [:gps] has approved the revision.
Attachment #9003827 - Flags: review+
Pushed by gszorc@mozilla.com:
https://hg.mozilla.org/hgcustom/version-control-tools/rev/d4d2e1551226
readonly: mark as compatible with Mercurial 4.7 r=gps
Comment on attachment 9003828 [details]
replicateowner: mark as Mercurial 4.7 compatible (Bug 1480228) r?gps

Gregory Szorc [:gps] has approved the revision.
Attachment #9003828 - Flags: review+
Pushed by gszorc@mozilla.com:
https://hg.mozilla.org/hgcustom/version-control-tools/rev/db1bdb576089
replicateowner: mark as Mercurial 4.7 compatible r=gps
Upgrading to 4.7.1 will apply a fix to a performance regression
that was introduced in 4.7.
Comment on attachment 9006313 [details]
Bug 1480228: upgrade Mercurial clients to 4.7.1 in Debian based Docker images r?gps

Gregory Szorc [:gps] has approved the revision.
Attachment #9006313 - Flags: review+
Pushed by gszorc@mozilla.com:
https://hg.mozilla.org/integration/autoland/rev/1b49fa4d4842
upgrade Mercurial clients to 4.7.1 in Debian based Docker images r=gps
It was infra related due to network access problems. We'll reland later.
Flags: needinfo?(sheehan)
[
  {
    "size": 250774,
    "visibility": "public",
    "digest": "cbc3eafbc7598c7eafee81f4fb95f8d58dea5fede0fca6a04334eaa29667b9b464e3070fa24be91276d7294ba4629d7b7a648cbf969256289e9a28f5da684d09",
    "algorithm": "sha512",
    "filename": "mercurial_4.7.1_amd64.deb"
  },
  {
    "size": 6023354,
    "visibility": "public",
    "digest": "f5fd476f0be213276572ec509efd7be6d67f5e9c6c78410d32482f2339832e057f352e8765f8f70df88caab583e7a039a6fc8474e4e36532b5a3a4a0ed5cfe01",
    "algorithm": "sha512",
    "filename": "mercurial_4.7.1.orig.tar.gz"
  },
  {
    "size": 2315652,
    "visibility": "public",
    "digest": "15f9c72dba116d33c2d60831bc17cd714d66b830089aebe547c846b910dbc929200f7863e167a8dade67c77c4347b8e967e6da505c2fdffa4faaa7143eccdfd8",
    "algorithm": "sha512",
    "filename": "mercurial-common_4.7.1_all.deb"
  }
]
Bumping the Mercurial version to 4.7.1 to apply a fix for a
performance regression introduced in 4.7.
Pushed by gszorc@mozilla.com:
https://hg.mozilla.org/integration/mozilla-inbound/rev/c3dab9cc38fe
install Mercurial 4.7.1 in Non-Debian Linux Docker images r=gps
https://hg.mozilla.org/integration/mozilla-inbound/rev/2ed6b9236c66
upgrade Mercurial clients to 4.7.1 in Debian based Docker images r=gps
Comment on attachment 9006313 [details]
Bug 1480228: upgrade Mercurial clients to 4.7.1 in Debian based Docker images r?gps

[Approval Request Comment]
Regression caused by (bug #): N/A
User impact if declined: Possibly slower CI
Testing completed (on m-c, etc.): Part of infra. It either works or it doesn't.
Risk to taking this patch (and alternatives if risky): No end-user risk.
String changes made by this patch: None

I'd like to request that commits 2ed6b9236c66e182511fc9c233e4480410dd216b and 2ed6b9236c66e182511fc9c233e4480410dd216b (https://hg.mozilla.org/integration/mozilla-inbound/rev/2ed6b9236c66e182511fc9c233e4480410dd216b and https://hg.mozilla.org/integration/mozilla-inbound/rev/2ed6b9236c66e182511fc9c233e4480410dd216b) be uplifted to mozilla-beta so that CI for that release branch is using Mercurial 4.7.1 instead of 4.7.

Mercurial 4.7 had a significant performance regression that could impact operations in CI and I want to upgrade to 4.7.1 to ensure CI isn't inadvertently slow.
Attachment #9006313 - Flags: approval-comm-beta?
Depends on: 1490703
Depends on: 1492878
Comment on attachment 9006313 [details]
Bug 1480228: upgrade Mercurial clients to 4.7.1 in Debian based Docker images r?gps

Odd that we only have comm* flags in this component, but taking this nonetheless.
Attachment #9006313 - Flags: approval-comm-beta?
Depends on: 1501660
Blocks: hg48
Depends on: 1501810
Depends on: 1501519
This commit vendors upstream changes to Mercurial
templates from version 4.7.2 into v-c-t. After
applying these changes, we get the upstream
graph link fix and no longer require the
`missing-graph-link` template patch, so it is removed.
Assignee: nobody → sheehan
Status: NEW → ASSIGNED
4.7.2 is live on the ssh and http servers. We still need to update some clients and a few of the client extensions before closing out this bug.
Pushed by gszorc@mozilla.com:
https://hg.mozilla.org/hgcustom/version-control-tools/rev/a48878cb5f0e
testing: upgrade to Mercurial 4.7.2 in testing virtualenvs r=gps
https://hg.mozilla.org/hgcustom/version-control-tools/rev/1fc1c481ac99
hgweb: upgrade to Mercurial 4.7.2 in hgweb virtualenvs r=gps
https://hg.mozilla.org/hgcustom/version-control-tools/rev/27d9f59932cf
hgtemplates: apply upstream gitweb changes to gitweb_mozilla r=gps
Pushed by cosheehan@mozilla.com:
https://hg.mozilla.org/hgcustom/version-control-tools/rev/f7db01759e01
hgssh: upgrade to Mercurial 4.7.2 in hgssh virtualenvs r=gps
https://hg.mozilla.org/hgcustom/version-control-tools/rev/7bb6be1f62d1
vcssync: upgrade to Mercurial 4.7.2 in vcssync virtualenv r=gps
Status: ASSIGNED → RESOLVED
Closed: Last year
Resolution: --- → FIXED
You need to log in before you can comment on or make changes to this bug.