Closed Bug 1480500 Opened 2 years ago Closed 2 years ago

Leak in nsTArray_base due to new XPIDL Array

Categories

(Core :: XPConnect, defect)

defect
Not set
normal

Tracking

()

RESOLVED DUPLICATE of bug 1480624

People

(Reporter: zbraniecki, Unassigned)

References

Details

In bug 1474369 :nika introduced nsTArray support in xpconnect. In bug 1475903 I tried to use the new feature and the patch was backed out due to a leak in nsTArray.

:bz looked at the patch:

```
— @bz reads patch
10:21 AM <@bz> So this is  all JS-to-JS calls?
10:21 AM <@bz> no C++ involved?
10:21 AM <gandalf> yes
10:21 AM <@bz> Sounds like a bug in the xpconnect TArray support, then
```
Blocks: 1475903
Depends on: 1474369
Flags: needinfo?(nika)
Do you have a test case?
Only the patch in bug 1475903. Nika said that it's enough.
Depends on: 1480624
Status: NEW → RESOLVED
Closed: 2 years ago
Flags: needinfo?(nika)
Resolution: --- → DUPLICATE
Duplicate of bug: 1480624
You need to log in before you can comment on or make changes to this bug.