Closed Bug 1480541 Opened Last year Closed Last year

Remove em-dash from search string dropdown text when the search query is empty

Categories

(Firefox :: New Tab Page, enhancement, P3)

enhancement

Tracking

()

VERIFIED FIXED
Firefox 63
Iteration:
63.4 - Aug 20
Tracking Status
firefox62 --- verified
firefox63 --- verified

People

(Reporter: k88hudson, Assigned: adw)

References

(Blocks 1 open bug)

Details

(Whiteboard: [fxsearch])

Attachments

(1 file)

We have discussed that removing the em-dash from the "– Search with Amazon" drop down text UI.
Whiteboard: [fx-search]
Iteration: --- → 63.4 - Aug 20
(In reply to Kate Hudson :k88hudson from comment #0)
> We have discussed that removing the em-dash from the "– Search with Amazon"
> drop down text UI.

But IIRC only before the user has typed a search string.  Once the user starts typing something, we should keep the dash between the search string and the "Search with".

i.e., right now, if you type only a search alias, the first result in the urlbar is " – Search with Foo".  It should probably only be "Search with Foo".
Whiteboard: [fx-search] → [fxsearch]
Assignee: nobody → adw
Status: NEW → ASSIGNED
Summary: Remove em-dash from search string dropdown text → Remove em-dash from search string dropdown text when the search query is empty
Comment on attachment 8998388 [details]
Bug 1480541 - Remove em-dash from search string dropdown text when the search query is empty. r?mak

Marco Bonardo [::mak] (Away 9-26 Aug) has approved the revision.
Attachment #8998388 - Flags: review+
Pushed by dwillcoxon@mozilla.com:
https://hg.mozilla.org/integration/autoland/rev/36642e9b970a
Remove em-dash from search string dropdown text when the search query is empty. r=mak
https://hg.mozilla.org/mozilla-central/rev/36642e9b970a
Status: ASSIGNED → RESOLVED
Closed: Last year
Resolution: --- → FIXED
Target Milestone: --- → Firefox 63
Blocks: 1482398
Depends on: 1484067
I have verified that the issue is no longer reproducible in the latest Nightly (63.0a1, Build ID 20180816100035) and Beta (62.0b18 Build ID 20180816151750) on Windows 10, Mac 10.13 and Arch Linux x64.
Status: RESOLVED → VERIFIED
Component: Activity Streams: Newtab → New Tab Page
You need to log in before you can comment on or make changes to this bug.