Closed Bug 1480701 Opened 4 years ago Closed 3 years ago

WebIDE can't connect to FF Nightly

Categories

(DevTools Graveyard :: WebIDE, defect)

63 Branch
ARM
Android
defect
Not set
blocker

Tracking

(firefox61 unaffected, firefox62 unaffected, firefox63 verified)

VERIFIED FIXED
Tracking Status
firefox61 --- unaffected
firefox62 --- unaffected
firefox63 --- verified

People

(Reporter: bsurd, Unassigned)

Details

(Keywords: qablocker)

Attachments

(2 files, 1 obsolete file)

Build:
 - Nightly (2018-08-02);

Steps to reproduce: 
 1. Open Fennec and go into Settings > Advanced and toggle Remote debugging via USB;
 2. Connect the device to your computer and in FF press Shift+F8 to open the WebIDE;
 3. Click on the Firefox Custom on Android option;

Expected results:
 WebIDE is able to connect to the device.

Actual results:
 WebIDE is not able to connect to the device. An operation failed error message is displayed.

Note:
 WebIDE works without any kind of issue for FF Beta and Release. Only Nightly seems to be affected.
 This issue is blocking the WebCompat team from diagnosing issues.
Attached image Screenshot.png
Adding an attachment.
I suspect that the fact that it says "Firefox Custom" is the reason this is an issue.
Attached image opFailed.jpg
Makoto: would that be related to the recent changes for adbhelper? Is that blocked on the new adbrelease?
Flags: needinfo?(m_kato)
(In reply to Julian Descottes [:jdescottes][:julian] from comment #3)
> Makoto: would that be related to the recent changes for adbhelper? Is that
> blocked on the new adbrelease?

This has already fixed by new adb helper.  If Pixel is Android 7.0/7.1, set devtools.debugger.unix-domain-socket=/data/data/org.mozilla.fennec_aurora/firefox-debugger-socket as workaround with old adb helper.
Flags: needinfo?(m_kato)
Will this pref be enabled by default on the current Nightly channel? And if so, starting when?
On webcompat, we often reset the Nightly app, so we can test in a clean environment.
If I understand correctly the workaround will only be necessary until the new version of the ADB Helper addon is released: https://github.com/mozilla/adbhelper (I expect we should do it sometime next week)
:( I still cannot connect to the phone.

I tried connecting both to
Google Pixel (Android 8.1.0) - 1080 x 1920 pixels (~441 ppi pixel density)
and
LG G5 (Android 7.0) - 1440 x 2560 pixels (~554 ppi pixel density)

The result is the same: http://prntscr.com/ke8ci0
(In reply to Sergiu Logigan [:sergiu] from comment #7)
> :( I still cannot connect to the phone.
> 
> I tried connecting both to
> Google Pixel (Android 8.1.0) - 1080 x 1920 pixels (~441 ppi pixel density)

Android Oreo requires new adb helper after landing bug 1473872.
By landing bug 1473872, Target SDK of Android is 26.  Due to this change,
debugger socket cannot use file path based UNIX domain socket on some Android
version.  So I change to socket address to abstract socket address by
bug 1462019.

But this change requires new adb helper addon, so until it is rolled out,
I would like to revert socket type to path based for Fennec.

GeckoView still keeps abstract socket address because test application
already use abstract socket address.
Thanks for the patch Makoto! Let's wait until Thursday to see if we can release a new addon. If by then we haven't released a new adbhelper, we will land your patch.
New adbhelper addon released today thanks to :ochameau.

Can you test again tomorrow, maybe make sure to uninstall/reinstall adbhelper?
Flags: needinfo?(sergiu.logigan)
Attachment #8997780 - Attachment is obsolete: true
It has been fixed. Thank you!

Tested with Google Pixel (Android 9) - 1080 x 1920 pixels (~441 ppi pixel density) and Nightly 63.
Flags: needinfo?(sergiu.logigan)
Thanks for checking, forgot to close the bug :)
Status: NEW → RESOLVED
Closed: 3 years ago
Resolution: --- → FIXED
Status: RESOLVED → VERIFIED
Product: DevTools → DevTools Graveyard
You need to log in before you can comment on or make changes to this bug.