Closed Bug 1480714 Opened 3 years ago Closed 3 years ago

Unifinder does not remember the last selected state on startup

Categories

(Calendar :: General, defect)

defect
Not set
normal

Tracking

(Not tracked)

RESOLVED FIXED

People

(Reporter: Paenglab, Assigned: darktrojan)

References

Details

Attachments

(1 file)

The Unifinder falls always back to "Events in the next 7 Days" on startup. Changes after the start are stored until restart.
Would be worth checking if this wasn't the same way before. I seem to remember that given "All Events" had perf issues, we decided to always reset to something known to not produce any, so that users that select "All Events" wouldn't be stuck with a slow Lightning forever.
Then this should only happen when "All Events" is set but this also resets when it's set to "Today's Events" which should be less perf using than "Events in the next 7 Days".
nfm. It resets after restart to "Events in the next 7 Days" of TB.
Oh sorry, I was a bit brief. I meant a patch that changes it to only reset if it is a bad perf view like "All Events" would work for me.
This is always set to 7 days, regardless of you configured today or 14 days before closing TB. Persistiting to xulstore works, its a matter of not restoring the predating configuration at startup.
Blocks: 1480752
No longer blocks: 1480752
Blocks: 1478608
This fixes the cause of the problem with the menulists (not just this one, but they are rare), and also another stuff-up I made: blocking the loading of the tree view until after the loading of the tree view.
Assignee: nobody → geoff
Status: NEW → ASSIGNED
Attachment #8997693 - Flags: review?(philipp)
Attachment #8997693 - Flags: review?(philipp) → review+
Keywords: checkin-needed
Pushed by mozilla@jorgk.com:
https://hg.mozilla.org/comm-central/rev/b01c98478582
Menulists do not properly return to the last selected state on startup. r=philipp
Status: ASSIGNED → RESOLVED
Closed: 3 years ago
Keywords: checkin-needed
Resolution: --- → FIXED
Target Milestone: --- → 6.5
You need to log in before you can comment on or make changes to this bug.