Closed Bug 1480863 Opened 3 years ago Closed 3 years ago

Shaped extension menus have black border instead of transparency (aren't shaped) with accelerated compositing

Categories

(Core :: Widget: Gtk, defect)

Unspecified
Linux
defect
Not set
normal

Tracking

()

RESOLVED DUPLICATE of bug 1479181

People

(Reporter: jld, Unassigned)

References

Details

STR: use a WebExtension with a menu, like HTTPS Everywhere, and click on it.

Expected: The menu is displayed and the region around the menu is transparent.

Actual: with basic compositing, as expected; with accelerated compositing the area around the menu is opaque black.  This is, I think, what bug 1406533 fixed for basic compositing.

This might be a duplicate of part of bug 1478454.
I should add that this is on Debian unstable with the NVIDIA proprietary driver.  I can also test with Mesa/amdgpu and maybe Mesa/intel if needed, but I'd have to reboot for it.
This happens with panels of OOP webextensions when using OpenGL or WebRender.
(Note: bug 1357487, which turned OOP webextensions on, has been backed out because of an unanswered needinfo.)

If this bug is about a non-transparent panel border with
* layers.acceleration.force-enabled;true: it's a dupe of bug 1479135 (which has been duped over to bug 1479181).
* gfx.webrender.all;true: it's dupe of bug 1479181.

> Debian unstable with the NVIDIA proprietary driver
bug 1478454 is about getting a fallback from WebRender to OpenGL ("Compositing on about:support) when you hover an icon of an OOP webextension (e.g. uBlock Origin) while using a proprietary Nvidia driver on Linux.
Status: NEW → RESOLVED
Closed: 3 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 1479181
I tried with both WebRender and non-WebRender layers.acceleration.force-enabled, and both cases reproduced it, but the WebRender case had fallen back to regular OpenGL (according to about:support) because of bug 1478454 (I assume).
See Also: → 1538338
You need to log in before you can comment on or make changes to this bug.