Delete RECEIVE_BOOT_COMPLETED permission

RESOLVED FIXED in Firefox 68

Status

()

defect
RESOLVED FIXED
11 months ago
Last month

People

(Reporter: sysrqb, Assigned: sysrqb)

Tracking

Trunk
Firefox 68
Points:
---

Firefox Tracking Flags

(firefox68 fixed)

Details

Attachments

(1 attachment)

Assignee

Description

11 months ago
User Agent: Mozilla/5.0 (Windows NT 6.1; rv:52.0) Gecko/20100101 Firefox/52.0
Build ID: 20100101

Steps to reproduce:

Bug 1396604 deleted all the |BootReceiver| code, but the |RECEIVE_BOOT_COMPLETED| permission is still specified in the Android manifest.


Actual results:

Fennec and GeckoView request |RECEIVE_BOOT_COMPLETED| permission

<uses-permission android:name="android.permission.RECEIVE_BOOT_COMPLETED"/>


Expected results:

This permission is not used anymore. Can it be deleted from both manifests?

mobile/android/base/FennecManifest_permissions.xml.in
mobile/android/geckoview/src/main/AndroidManifest.xml
Hi Jan, I saw your comments in bug 1396604 and could you please take a look here? Thanks
Flags: needinfo?(jh+bugzilla)
Assignee

Comment 3

10 months ago
(In reply to Jan Henning [:JanH] from comment #2)
> It's still used for the Stumbler:
> https://dxr.mozilla.org/mozilla-central/rev/
> 4e56a2f51ad739ca52046723448f3129a58f1666/mobile/android/stumbler/java/org/
> mozilla/mozstumbler/service/mainthread/SystemReceiver.java#18-19,33
> https://dxr.mozilla.org/mozilla-central/rev/
> 4e56a2f51ad739ca52046723448f3129a58f1666/mobile/android/stumbler/manifests/
> StumblerManifest_services.xml.in#28

Ah, okay. Would an acceptable patch either move the |android.permission.RECEIVE_BOOT_COMPLETED| permission into mobile/android/stumbler/manifests/StumblerManifest_services.xml.in? Or, would it be better to guard |RECEIVE_BOOT_COMPLETED| inside a |MOZ_ANDROID_MLS_STUMBLER| ifdef within base/FennecManifest_permissions.xml.in (and delete it from GeckoView)?

GeckoView doesn't need or know about the stumbler at this point, right?
Assignee

Comment 4

Last month

(In reply to Matthew Finkel [:sysrqb] from comment #3)

(In reply to Jan Henning [:JanH] from comment #2)

It's still used for the Stumbler:
https://dxr.mozilla.org/mozilla-central/rev/
4e56a2f51ad739ca52046723448f3129a58f1666/mobile/android/stumbler/java/org/
mozilla/mozstumbler/service/mainthread/SystemReceiver.java#18-19,33
https://dxr.mozilla.org/mozilla-central/rev/
4e56a2f51ad739ca52046723448f3129a58f1666/mobile/android/stumbler/manifests/
StumblerManifest_services.xml.in#28

Ah, okay. Would an acceptable patch either move the
|android.permission.RECEIVE_BOOT_COMPLETED| permission into
mobile/android/stumbler/manifests/StumblerManifest_services.xml.in? Or,
would it be better to guard |RECEIVE_BOOT_COMPLETED| inside a
|MOZ_ANDROID_MLS_STUMBLER| ifdef within
base/FennecManifest_permissions.xml.in (and delete it from GeckoView)?

Okay, I went with the second option (the first option doesn't work due to the location of the include).

I have a patch that may have a green try build (it's still running):
https://treeherder.mozilla.org/#/jobs?repo=try&revision=4b0cd10b4bfeddb85cdb3624edf2d961ba0ab629

GeckoView doesn't need or know about the stumbler at this point, right?

It looks like this was removed in with bug 927831

Assignee

Comment 6

Last month

Pushed to phabricator. JanH, can I add you as a reviewer?

https://phabricator.services.mozilla.com/D31525

Flags: needinfo?(jh+bugzilla)

Feel free.

Flags: needinfo?(jh+bugzilla)
Assignee

Comment 8

Last month

This patch is ready to land. Can it be uplifted to mozilla-beta?

I might've done this backwards - the current patch is against mozilla-beta instead of m-c.

Keywords: checkin-needed

Comment 9

Last month

Pushed by cbrindusan@mozilla.com:
https://hg.mozilla.org/integration/autoland/rev/65747386d437
Only add RECEIVE_BOOT_COMPLETED Android permission with Stumbler r=JanH

Keywords: checkin-needed

Comment 10

Last month
bugherder
Status: UNCONFIRMED → RESOLVED
Closed: Last month
Resolution: --- → FIXED
Target Milestone: --- → Firefox 68
Assignee: nobody → matthew.finkel
You need to log in before you can comment on or make changes to this bug.