Closed Bug 1481199 Opened Last year Closed 11 months ago

Drop the obsolete dataType parameter for nsIBrowserSearchService.addEngine

Categories

(Firefox :: Search, enhancement, P5)

enhancement

Tracking

()

RESOLVED FIXED
Firefox 64
Tracking Status
firefox63 --- wontfix
firefox64 --- fixed

People

(Reporter: standard8, Assigned: dpino)

References

Details

(Keywords: good-first-bug)

Attachments

(2 files, 6 obsolete files)

The documentation for the parameter says this is unused, and as far as I can tell it is.

Now that we don't have add-ons to worry about for the API, we should just drop it and simplify the calls.

https://searchfox.org/mozilla-central/rev/3fdc491e118c5cdfbaf6e2d52f3466d2b27ad1de/netwerk/base/nsIBrowserSearchService.idl#298-299,323-325
Assignee: nobody → mozilla
Status: NEW → ASSIGNED
Priority: -- → P3
Assignee: mozilla → nobody
Status: ASSIGNED → NEW
Keywords: good-first-bug
Priority: P3 → P5
Here's a patch to fix the issue. Please take a look.
Attachment #9001289 - Flags: review?(mozilla)
Comment on attachment 9001289 [details] [diff] [review]
0001-Bug-1481199-Drop-the-obsolete-dataType-parameter-for.patch

Review of attachment 9001289 [details] [diff] [review]:
-----------------------------------------------------------------

This looks great, thank you!
I'm going to run some tests to double check things.
Attachment #9001289 - Flags: review?(mozilla) → review+
This is failing tests and I can't figure out why. It looks exactly right. I'm still looking.
One of the tests failing is:

toolkit/components/search/tests/xpcshell/test_addEngine_callback.js

I verified that everything works fine in the browser, only the test fails. For some reason, things just don't finish (test times out).
I figured it out.

You forgot to remove the parameter from the actual search service:

https://searchfox.org/mozilla-central/source/toolkit/components/search/nsSearchService.js#3865

(Or forgot to check it in the patch).

With that change, everything looks good.

Can you update your patch?

Thanks!
Thanks for the valuable feedback. I updated the patch.
Attachment #9001289 - Attachment is obsolete: true
Attachment #9003036 - Flags: review?(mozilla)
Attached patch A few more places (obsolete) — Splinter Review
I found a few more places that were missed by running the tests.

Were you able to build Firefox locally in order to check this?

I wanted to let you know how to run tests.

Thanks for your work on this!
Comment on attachment 9003036 [details] [diff] [review]
0001-Bug-1481199-Drop-the-obsolete-dataType-parameter-for.patch

You're missing a few more places. I've attached in the other patch.

If you're able to build Firefox locally, you can run the tests like this:

./mach test browser/components/search
and
./mach test toolkit/components/search
Attachment #9003036 - Flags: review?(mozilla) → review-
Thank you for the tips and pointers.

Previously I managed to build Firefox, despite there were failing tests. I didn't actually run the tests (I don't know why, likely cause I didn't know although I could have researched a bit on my own).

With your patch applied, all tests in `toolkit/components/search` pass. I run `browser/components/search` too. I got a few failing tests due to timeout errors. I think it's unrelated with the patch though.

I amended the original patch with your changes (since AFAIK every feature/bug-fix is a commit). I don't know if that's the right thing to do.
Attachment #9003036 - Attachment is obsolete: true
Attachment #9003515 - Flags: review?(mozilla)
Comment on attachment 9003515 [details] [diff] [review]
Bug-1481199-Drop-the-obsolete-dataType-parameter-for.patch

This looks great and passes all my tests.
Attachment #9003515 - Flags: review?(mozilla) → review+
Assignee: nobody → dpino
Attachment #9003219 - Attachment is obsolete: true
Pushed by ryanvm@gmail.com:
https://hg.mozilla.org/integration/mozilla-inbound/rev/d47a2f5db828
Drop the obsolete dataType parameter for nsIBrowserSearchService.addEngine. r=mkaply
Keywords: checkin-needed
Backed out changeset d47a2f5db828 (bug 1481199) browser/base/content/test/urlbar/browser_autocomplete_a11y_label.js. CLOSED TREE

Log:
https://treeherder.mozilla.org/logviewer.html#?job_id=195607899&repo=mozilla-inbound&lineNumber=2359

TEST-START | browser/base/content/test/urlbar/browser_autocomplete_a11y_label.js
[task 2018-08-23T20:25:45.222Z] 20:25:45     INFO - TEST-INFO | started process screentopng
[task 2018-08-23T20:25:45.728Z] 20:25:45     INFO - TEST-INFO | screentopng: exit 0
[task 2018-08-23T20:25:45.729Z] 20:25:45     INFO - Buffered messages logged at 20:25:44
[task 2018-08-23T20:25:45.731Z] 20:25:45     INFO - Entering test bound switchToTab
[task 2018-08-23T20:25:45.732Z] 20:25:45     INFO - Disable popup animation. Change dontAnimate value from true to true.
[task 2018-08-23T20:25:45.733Z] 20:25:45     INFO - Restore popup dontAnimate value to true
[task 2018-08-23T20:25:45.735Z] 20:25:45     INFO - Buffered messages logged at 20:25:45
[task 2018-08-23T20:25:45.737Z] 20:25:45     INFO - TEST-PASS | browser/base/content/test/urlbar/browser_autocomplete_a11y_label.js | Expect right type attribute - 
[task 2018-08-23T20:25:45.739Z] 20:25:45     INFO - TEST-PASS | browser/base/content/test/urlbar/browser_autocomplete_a11y_label.js | Result a11y label should be: <title> <url> Tab - 
[task 2018-08-23T20:25:45.743Z] 20:25:45     INFO - Leaving test bound switchToTab
[task 2018-08-23T20:25:45.744Z] 20:25:45     INFO - Entering test bound searchSuggestions
[task 2018-08-23T20:25:45.747Z] 20:25:45     INFO - Buffered messages finished
[task 2018-08-23T20:25:45.748Z] 20:25:45     INFO - TEST-UNEXPECTED-FAIL | browser/base/content/test/urlbar/browser_autocomplete_a11y_label.js | Uncaught exception - [Exception... "Could not convert JavaScript argument arg 3 [nsIBrowserSearchService.addEngine]"  nsresult: "0x80570009 (NS_ERROR_XPC_BAD_CONVERT_JS)"  location: "JS frame :: resource://testing-common/SearchTestUtils.jsm :: promiseNewSearchEngine/< :: line 31"  data: no]
[task 2018-08-23T20:25:45.751Z] 20:25:45     INFO - Stack trace:
[task 2018-08-23T20:25:45.752Z] 20:25:45     INFO - promiseNewSearchEngine/<@resource://testing-common/SearchTestUtils.jsm:31:7
[task 2018-08-23T20:25:45.754Z] 20:25:45     INFO - promiseNewSearchEngine@resource://testing-common/SearchTestUtils.jsm:30:12
[task 2018-08-23T20:25:45.756Z] 20:25:45     INFO - searchSuggestions@chrome://mochitests/content/browser/browser/base/content/test/urlbar/browser_autocomplete_a11y_label.js:22:22
[task 2018-08-23T20:25:45.757Z] 20:25:45     INFO - Async*Tester_execTest/<@chrome://mochikit/content/browser-test.js:1106:34
[task 2018-08-23T20:25:45.760Z] 20:25:45     INFO - async*Tester_execTest@chrome://mochikit/content/browser-test.js:1097:16
[task 2018-08-23T20:25:45.761Z] 20:25:45     INFO - nextTest/<@chrome://mochikit/content/browser-test.js:999:9
[task 2018-08-23T20:25:45.763Z] 20:25:45     INFO - SimpleTest.waitForFocus/waitForFocusInner/focusedOrLoaded/<@chrome://mochikit/content/tests/SimpleTest/SimpleTest.js:795:59
[task 2018-08-23T20:25:45.765Z] 20:25:45     INFO - Leaving test bound searchSuggestions
[task 2018-08-23T20:25:45.766Z] 20:25:45     INFO - GECKO(1679) | MEMORY STAT | vsize 20973902MB | residentFast 1104MB
[task 2018-08-23T20:25:45.767Z] 20:25:45     INFO - TEST-OK | browser/base/content/test/urlbar/browser_autocomplete_a11y_label.js | took 982ms

Push with failures:
https://treeherder.mozilla.org/#/jobs?repo=mozilla-inbound&revision=d47a2f5db82884f89e4a7aedfc7de00b13e9078d&filter-searchStr=browser%20chrome&filter-resultStatus=testfailed&filter-resultStatus=busted&filter-resultStatus=exception&filter-classifiedState=unclassified

Backout:
https://hg.mozilla.org/integration/mozilla-inbound/rev/c456c8a288b35a5dd1b4bba4682ccbc0f9e7fea8
Flags: needinfo?(dpino)
So it looks like an addEngine we missed.

I should have done a try build with this before checkin. It happens.

I'm going to update the patch and do a try to see if there's anything else we missed.
I looked a bit into this, although I don't have a fix yet.

It seems there's an 'null' pending to be removed here: https://searchfox.org/mozilla-central/source/browser/components/search/test/SearchTestUtils.jsm#31

Upon removing that null and running './mach test browser/base/content/test/urlbar/browser_autocomplete_a11y_label.js' I got 3 tests failing. In my case, logging revealed the error happened when trying to instantiate a searchEngine:

```
 0:05.92 INFO Console message: _initFromURIAndLoad: Downloading engine from: "chrome://mochitests/content/browser/browser/base/content/test/urlbar/searchSuggestionEngine.xml".
 0:05.92 GECKO(4113) *** Search: loadListener: Starting request: file:///home/dpino/workspace/gecko-dev/obj-x86_64-pc-linux-gnu/_tests/testing/mochitest/browser/browser/base/content/test/urlbar/searchSuggestionEngine.xml
 0:05.92 GECKO(4113) *** Search: loadListener: Stopping request: file:///home/dpino/workspace/gecko-dev/obj-x86_64-pc-linux-gnu/_tests/testing/mochitest/browser/browser/base/content/test/urlbar/searchSuggestionEngine.xml
 0:05.92 GECKO(4113) *** Search: loadListener: request failed!
```

Apparently 'searchSuggestionEngine.xml' didn't exist into 'obj-x86_64-pc-linux-gnu/_tests/testing/mochitest/browser/browser/base/content/test/urlbar/' (despite I run './mach build'). I manually copied 'browser/base/content/test/urlbar/searchSuggestionEngine.xml' into that folder to fix the issue.

I run the test again and I got 1 unexpected result:

```
Unexpected Results
------------------
browser/base/content/test/urlbar/browser_autocomplete_a11y_label.js
  FAIL Uncaught exception - Waiting for the autocomplete result for "foo" at [2] to appear - timed out after 50 tries.
```
Flags: needinfo?(dpino)
So we can run the tests on our servers (a try build) to see what will happen. I did this with the SearchTestUtils change:

https://treeherder.mozilla.org/#/jobs?repo=try&revision=5ce154224c307ac9d3225164a1e9d90e3cb940ba

And I think that's the last change that will make this work.

The orange you see (you can click on them) are things that are unrelated to this work.
Attached patch Updated patchSplinter Review
This has the one additional fix.
Sorry for the back and forth on this. The most recent patch is ready for checkin.

I can't check it in through phabricator because I am a reviewer.

According to my try run, we should be good now.
Keywords: checkin-needed
Pushed by ebalazs@mozilla.com:
https://hg.mozilla.org/integration/mozilla-inbound/rev/b24238e8e714
Drop the obsolete dataType parameter for nsIBrowserSearchService.addEngine. r=mkaply
Keywords: checkin-needed
Backout by nerli@mozilla.com:
https://hg.mozilla.org/integration/mozilla-inbound/rev/acb4a0fc62ee
Backed out changeset b24238e8e714 for failures in mobile/android/tests/browser/chrome/test_device_search_engine.html
This patch is killing me :).

Forgot about android. I'll do some more testing.
I amended the patch to include a fix in the failing test (./mobile/android/tests/browser/chrome/test_device_search_engine.html). I grepped for "addEngine" in html files and this file was the only one I found. I hope it goes fine this time :)
Attachment #9003515 - Attachment is obsolete: true
Attachment #9006240 - Flags: review?(mozilla)
I did a try run targeting Android devices:

https://treeherder.mozilla.org/#/jobs?repo=try&resultStatus=testfailed,busted,exception&classifiedState=unclassified&revision=198240ef3a21fc7e8d3a4d35e6a257dcb7fbfecc&selectedJob=202701731

Test `mobile/android/tests/browser/chrome/test_device_search_engine.html` is reported as failing (orange color) despite the latest change. There are actually 2 failed tests in one of the Android targets. I don't know how to interpret these results (did the tests failed due to the changes? are the errors intermittent?).
Flags: needinfo?(mozilla)
I'm having trouble interpreting as well. I'm seeing if I can run those tests locally to verify.

We'll get this checked in eventually :)
Flags: needinfo?(mozilla)
I just took a look. The try results show that "TV" is failing - this is a test verification task that typically runs the tests several times to verify if it works in different scenarios.

The failure log indicates:

INFO TEST-START | mobile/android/tests/browser/chrome/test_device_search_engine.html
INFO -  Buffered messages logged at 19:58:59
INFO -  11 INFO Loading search engine
INFO -  Buffered messages logged at 19:59:00
INFO -  12 INFO Observer: engine-changed for Test search engine
INFO -  Buffered messages finished
INFO TEST-UNEXPECTED-FAIL | mobile/android/tests/browser/chrome/test_device_search_engine.html | Test timed out.

The interesting part here is that the "Observer" line indicates that the observer notification has been received - which indicates that the add engine was successful. As the patch only affects the addEngine part, it seemed strange this was hitting a failure. 

Going back to the try results, clicking the job and looking in the failure summary section at the bottom, I noticed that bug 1482468 was highlighted but crossed-out - meaning it was "resolved". Looking at it, it is a bug from a couple of months ago that has been resolved incomplete. The failure mode log is exactly the same.

Therefore this is a pre-existing failure that only happens when test-verify runs.

I further confirmed this by looking through the "c#" successful jobs (in the "M()" section), and finding test_device_search_engine.html passes successfully in this log:

https://taskcluster-artifacts.net/TDIbfAu-Sj2i58EYdsbKXg/0/public/logs/live_backing.log

INFO TEST-START | mobile/android/tests/browser/chrome/test_device_search_engine.html
INFO TEST-OK | mobile/android/tests/browser/chrome/test_device_search_engine.html | took 1207ms

The R1 failure is just a intermittent that I've now starred (the failure summary shows the possible bugs & highlights where it matches).

As TV failure is pre-existing, and it is a tier-2 which means you don't get backed out if it fails, we don't need to worry about it here.

Hence, I think you're good to go!
Thanks Mark for the detailed explanation, very informative.

I'll wait for Mike's review on the final version of the patch and then hopefully get it landed (I don't have commit permissions so I'd need someone to land it for me).
Comment on attachment 9006240 [details] [diff] [review]
Bug-1481199-Drop-the-obsolete-dataType-parameter-for.patch

Thanks, Mark for that awesome investigation.

I was getting a local Android build to try to reproduce.
Attachment #9006240 - Flags: review?(mozilla) → review+
Keywords: checkin-needed
We were unable to land this patch.
patch failed, unable to continue (try -v)
patch failed, rejects left in working directory
errors during apply, please fix and qrefresh Bug-1481199-Drop-the-obsolete-dataType-parameter-for.patch
Flags: needinfo?(mozilla)
Keywords: checkin-needed
Rebased patch to latest "master".
Attachment #9006240 - Attachment is obsolete: true
Attachment #9014818 - Flags: review?(mozilla)
Comment on attachment 9014818 [details] [diff] [review]
Bug-1481199-Drop-the-obsolete-dataType-parameter-for.patch

Thanks, was just about to do that.
Flags: needinfo?(mozilla)
Attachment #9014818 - Flags: review?(mozilla) → review+
Keywords: checkin-needed
QA Contact: adw
Pushed by ccoroiu@mozilla.com:
https://hg.mozilla.org/integration/mozilla-inbound/rev/a858092c4df7
Drop the obsolete dataType parameter for nsIBrowserSearchService.addEngine. r=mkaply
Keywords: checkin-needed
Backed out changeset a858092c4df7 (bug 1481199) for browser chrome failure in browser/base/content/test/general/browser_contentSearchUI.js

Log:
https://treeherder.mozilla.org/logviewer.html#?job_id=203680239&repo=mozilla-inbound&lineNumber=4691

INFO - TEST-START | browser/base/content/test/general/browser_contentSearchUI.js
[task 2018-10-05T16:10:09.126Z] 16:10:09     INFO - TEST-INFO | started process screentopng
[task 2018-10-05T16:10:09.811Z] 16:10:09     INFO - TEST-INFO | screentopng: exit 0
[task 2018-10-05T16:10:09.811Z] 16:10:09     INFO - Buffered messages logged at 16:10:09
[task 2018-10-05T16:10:09.814Z] 16:10:09     INFO - Entering test bound emptyInput
[task 2018-10-05T16:10:09.815Z] 16:10:09     INFO - Removing default search engines
[task 2018-10-05T16:10:09.819Z] 16:10:09     INFO - Adding test search engines
[task 2018-10-05T16:10:09.821Z] 16:10:09     INFO - Buffered messages finished
[task 2018-10-05T16:10:09.822Z] 16:10:09     INFO - TEST-UNEXPECTED-FAIL | browser/base/content/test/general/browser_contentSearchUI.js | Uncaught exception - [Exception... "Could not convert JavaScript argument arg 3 [nsIBrowserSearchService.addEngine]"  nsresult: "0x80570009 (NS_ERROR_XPC_BAD_CONVERT_JS)"  location: "JS frame :: resource://testing-common/SearchTestUtils.jsm :: promiseNewSearchEngine/< :: line 31"  data: no]
[task 2018-10-05T16:10:09.824Z] 16:10:09     INFO - Stack trace:
[task 2018-10-05T16:10:09.826Z] 16:10:09     INFO - promiseNewSearchEngine/<@resource://testing-common/SearchTestUtils.jsm:31:7
[task 2018-10-05T16:10:09.828Z] 16:10:09     INFO - promiseNewSearchEngine@resource://testing-common/SearchTestUtils.jsm:30:12
[task 2018-10-05T16:10:09.829Z] 16:10:09     INFO - setUpEngines/<@chrome://mochitests/content/browser/browser/base/content/test/general/browser_contentSearchUI.js:744:25
[task 2018-10-05T16:10:09.835Z] 16:10:09     INFO - async*setUpEngines@chrome://mochitests/content/browser/browser/base/content/test/general/browser_contentSearchUI.js:738:17
[task 2018-10-05T16:10:09.836Z] 16:10:09     INFO - setUp/<@chrome://mochitests/content/browser/browser/base/content/test/general/browser_contentSearchUI.js:645:13
[task 2018-10-05T16:10:09.838Z] 16:10:09     INFO - async*setUp@chrome://mochitests/content/browser/browser/base/content/test/general/browser_contentSearchUI.js:634:17
[task 2018-10-05T16:10:09.840Z] 16:10:09     INFO - emptyInput@chrome://mochitests/content/browser/browser/base/content/test/general/browser_contentSearchUI.js:20:9
[task 2018-10-05T16:10:09.841Z] 16:10:09     INFO - Async*Tester_execTest/<@chrome://mochikit/content/browser-test.js:1093:34
[task 2018-10-05T16:10:09.844Z] 16:10:09     INFO - async*Tester_execTest@chrome://mochikit/content/browser-test.js:1084:16
[task 2018-10-05T16:10:09.845Z] 16:10:09     INFO - nextTest/<@chrome://mochikit/content/browser-test.js:986:9
[task 2018-10-05T16:10:09.847Z] 16:10:09     INFO - SimpleTest.waitForFocus/waitForFocusInner/focusedOrLoaded/<@chrome://mochikit/content/tests/SimpleTest/SimpleTest.js:795:59
[task 2018-10-05T16:10:09.849Z] 16:10:09     INFO - Leaving test bound emptyInput
[task 2018-10-05T16:10:09.850Z] 16:10:09     INFO - Entering test bound blur
[task 2018-10-05T16:10:09.853Z] 16:10:09     INFO - Removing default search engines
[task 2018-10-05T16:10:09.855Z] 16:10:09     INFO - Adding test search engines
[task 2018-10-05T16:10:09.858Z] 16:10:09     INFO - Not taking screenshot here: see the one that was previously logged
[task 2018-10-05T16:10:09.878Z] 16:10:09     INFO - TEST-UNEXPECTED-FAIL | browser/base/content/test/general/browser_contentSearchUI.js | Uncaught exception - [Exception... "Could not convert JavaScript argument arg 3 [nsIBrowserSearchService.addEngine]"  nsresult: "0x80570009 (NS_ERROR_XPC_BAD_CONVERT_JS)"  location: "JS frame :: resource://testing-common/SearchTestUtils.jsm :: promiseNewSearchEngine/< :: line 31"  data: no]
[task 2018-10-05T16:10:09.879Z] 16:10:09     INFO - Stack trace:
[task 2018-10-05T16:10:09.882Z] 16:10:09     INFO - promiseNewSearchEngine/<@resource://testing-common/SearchTestUtils.jsm:31:7
[task 2018-10-05T16:10:09.883Z] 16:10:09     INFO - promiseNewSearchEngine@resource://testing-common/SearchTestUtils.jsm:30:12
[task 2018-10-05T16:10:09.884Z] 16:10:09     INFO - setUpEngines/<@chrome://mochitests/content/browser/browser/base/content/test/general/browser_contentSearchUI.js:744:25
[task 2018-10-05T16:10:09.886Z] 16:10:09     INFO - async*setUpEngines@chrome://mochitests/content/browser/browser/base/content/test/general/browser_contentSearchUI.js:738:17
[task 2018-10-05T16:10:09.887Z] 16:10:09     INFO - setUp/<@chrome://mochitests/content/browser/browser/base/content/test/general/browser_contentSearchUI.js:645:13
[task 2018-10-05T16:10:09.888Z] 16:10:09     INFO - async*setUp@chrome://mochitests/content/browser/browser/base/content/test/general/browser_contentSearchUI.js:634:17
[task 2018-10-05T16:10:09.890Z] 16:10:09     INFO - blur@chrome://mochitests/content/browser/browser/base/content/test/general/browser_contentSearchUI.js:32:9
[task 2018-10-05T16:10:09.892Z] 16:10:09     INFO - Async*Tester_execTest/<@chrome://mochikit/content/browser-test.js:1093:34
[task 2018-10-05T16:10:09.893Z] 16:10:09     INFO - async*Tester_execTest@chrome://mochikit/content/browser-test.js:1084:16
[task 2018-10-05T16:10:09.894Z] 16:10:09     INFO - nextTest/<@chrome://mochikit/content/browser-test.js:986:9
[task 2018-10-05T16:10:09.895Z] 16:10:09     INFO - SimpleTest.waitForFocus/waitForFocusInner/focusedOrLoaded/<@chrome://mochikit/content/tests/SimpleTest/SimpleTest.js:795:59
[task 2018-10-05T16:10:09.896Z] 16:10:09     INFO - Leaving test bound blur
[task 2018-10-05T16:10:09.899Z] 16:10:09     INFO - Entering test bound upDownKeys
[task 2018-10-05T16:10:09.900Z] 16:10:09     INFO - Removing default search engines
[task 2018-10-05T16:10:09.901Z] 16:10:09     INFO - Adding test search engines
[task 2018-10-05T16:10:09.906Z] 16:10:09     INFO - Not taking screenshot here: see the one that was previously logged
[task 2018-10-05T16:10:09.907Z] 16:10:09     INFO - TEST-UNEXPECTED-FAIL | browser/base/content/test/general/browser_contentSearchUI.js | Uncaught exception - [Exception... "Could not convert JavaScript argument arg 3 [nsIBrowserSearchService.addEngine]"  nsresult: "0x80570009 (NS_ERROR_XPC_BAD_CONVERT_JS)"  location: "JS frame :: resource://testing-common/SearchTestUtils.jsm :: promiseNewSearchEngine/< :: line 31"  data: no]
[task 2018-10-05T16:10:09.908Z] 16:10:09     INFO - Stack trace:
[task 2018-10-05T16:10:09.909Z] 16:10:09     INFO - promiseNewSearchEngine/<@resource://testing-common/SearchTestUtils.jsm:31:7
[task 2018-10-05T16:10:09.910Z] 16:10:09     INFO - promiseNewSearchEngine@resource://testing-common/SearchTestUtils.jsm:30:12
[task 2018-10-05T16:10:09.911Z] 16:10:09     INFO - setUpEngines/<@chrome://mochitests/content/browser/browser/base/content/test/general/browser_contentSearchUI.js:744:25
[task 2018-10-05T16:10:09.912Z] 16:10:09     INFO - async*setUpEngines@chrome://mochitests/content/browser/browser/base/content/test/general/browser_contentSearchUI.js:738:17
[task 2018-10-05T16:10:09.913Z] 16:10:09     INFO - setUp/<@chrome://mochitests/content/browser/browser/base/content/test/general/browser_contentSearchUI.js:645:13
[task 2018-10-05T16:10:09.915Z] 16:10:09     INFO - async*setUp@chrome://mochitests/content/browser/browser/base/content/test/general/browser_contentSearchUI.js:634:17
[task 2018-10-05T16:10:09.916Z] 16:10:09     INFO - upDownKeys@chrome://mochitests/content/browser/browser/base/content/test/general/browser_contentSearchUI.js:44:9
[task 2018-10-05T16:10:09.917Z] 16:10:09     INFO - Async*Tester_execTest/<@chrome://mochikit/content/browser-test.js:1093:34
[task 2018-10-05T16:10:09.920Z] 16:10:09     INFO - async*Tester_execTest@chrome://mochikit/content/browser-test.js:1084:16
[task 2018-10-05T16:10:09.920Z] 16:10:09     INFO - nextTest/<@chrome://mochikit/content/browser-test.js:986:9
[task 2018-10-05T16:10:09.920Z] 16:10:09     INFO - SimpleTest.waitForFocus/waitForFocusInner/focusedOrLoaded/<@chrome://mochikit/content/tests/SimpleTest/SimpleTest.js:795:59
[task 2018-10-05T16:10:09.921Z] 16:10:09     INFO - Leaving test bound upDownKeys
[task 2018-10-05T16:10:09.922Z] 16:10:09     INFO - Entering test bound rightLeftKeys
[task 2018-10-05T16:10:09.929Z] 16:10:09     INFO - Removing default search engines
[task 2018-10-05T16:10:09.930Z] 16:10:09     INFO - Adding test search engines
[task 2018-10-05T16:10:09.931Z] 16:10:09     INFO - Not taking screenshot here: see the one that was previously logged
[task 2018-10-05T16:10:09.933Z] 16:10:09     INFO - TEST-UNEXPECTED-FAIL | browser/base/content/test/general/browser_contentSearchUI.js | Uncaught exception - [Exception... "Could not convert JavaScript argument arg 3 [nsIBrowserSearchService.addEngine]"  nsresult: "0x80570009 (NS_ERROR_XPC_BAD_CONVERT_JS)"  location: "JS frame :: resource://testing-common/SearchTestUtils.jsm :: promiseNewSearchEngine/< :: line 31"  data: no]
[task 2018-10-05T16:10:09.934Z] 16:10:09     INFO - Stack trace:
[task 2018-10-05T16:10:09.935Z] 16:10:09     INFO - promiseNewSearchEngine/<@resource://testing-common/SearchTestUtils.jsm:31:7
[task 2018-10-05T16:10:09.937Z] 16:10:09     INFO - promiseNewSearchEngine@resource://testing-common/SearchTestUtils.jsm:30:12
[task 2018-10-05T16:10:09.939Z] 16:10:09     INFO - setUpEngines/<@chrome://mochitests/content/browser/browser/base/content/test/general/browser_contentSearchUI.js:744:25
[task 2018-10-05T16:10:09.940Z] 16:10:09     INFO - async*setUpEngines@chrome://mochitests/content/browser/browser/base/content/test/general/browser_contentSearchUI.js:738:17
[task 2018-10-05T16:10:09.942Z] 16:10:09     INFO - setUp/<@chrome://mochitests/content/browser/browser/base/content/test/general/browser_contentSearchUI.js:645:13
[task 2018-10-05T16:10:09.943Z] 16:10:09     INFO - async*setUp@chrome://mochitests/content/browser/browser/base/content/test/general/browser_contentSearchUI.js:634:17
[task 2018-10-05T16:10:09.947Z] 16:10:09     INFO - rightLeftKeys@chrome://mochitests/content/browser/browser/base/content/test/general/browser_contentSearchUI.js:85:9
[task 2018-10-05T16:10:09.949Z] 16:10:09     INFO - Async*Tester_execTest/<@chrome://mochikit/content/browser-test.js:1093:34
[task 2018-10-05T16:10:09.951Z] 16:10:09     INFO - async*Tester_execTest@chrome://mochikit/content/browser-test.js:1084:16
[task 2018-10-05T16:10:09.952Z] 16:10:09     INFO - nextTest/<@chrome://mochikit/content/browser-test.js:986:9
[task 2018-10-05T16:10:09.954Z] 16:10:09     INFO - SimpleTest.waitForFocus/waitForFocusInner/focusedOrLoaded/<@chrome://mochikit/content/tests/SimpleTest/SimpleTest.js:795:59
[task 2018-10-05T16:10:09.956Z] 16:10:09     INFO - Leaving test bound rightLeftKeys
[task 2018-10-05T16:10:09.957Z] 16:10:09     INFO - Entering test bound tabKey
[task 2018-10-05T16:10:09.959Z] 16:10:09     INFO - Removing default search engines
[task 2018-10-05T16:10:09.960Z] 16:10:09     INFO - Adding test search engines
[task 2018-10-05T16:10:09.962Z] 16:10:09     INFO - Not taking screenshot here: see the one that was previously logged
[task 2018-10-05T16:10:09.963Z] 16:10:09     INFO - TEST-UNEXPECTED-FAIL | browser/base/content/test/general/browser_contentSearchUI.js | Uncaught exception - [Exception... "Could not convert JavaScript argument arg 3 [nsIBrowserSearchService.addEngine]"  nsresult: "0x80570009 (NS_ERROR_XPC_BAD_CONVERT_JS)"  location: "JS frame :: resource://testing-common/SearchTestUtils.jsm :: promiseNewSearchEngine/< :: line 31"  data: no]
[task 2018-10-05T16:10:09.965Z] 16:10:09     INFO - Stack trace:
[task 2018-10-05T16:10:09.966Z] 16:10:09     INFO - promiseNewSearchEngine/<@resource://testing-common/SearchTestUtils.jsm:31:7
[task 2018-10-05T16:10:09.968Z] 16:10:09     INFO - promiseNewSearchEngine@resource://testing-common/SearchTestUtils.jsm:30:12
[task 2018-10-05T16:10:09.969Z] 16:10:09     INFO - setUpEngines/<@chrome://mochitests/content/browser/browser/base/content/test/general/browser_contentSearchUI.js:744:25
[task 2018-10-05T16:10:09.971Z] 16:10:09     INFO - async*setUpEngines@chrome://mochitests/content/browser/browser/base/content/test/general/browser_contentSearchUI.js:738:17
[task 2018-10-05T16:10:09.972Z] 16:10:09     INFO - setUp/<@chrome://mochitests/content/browser/browser/base/content/test/general/browser_contentSearchUI.js:645:13
[task 2018-10-05T16:10:09.973Z] 16:10:09     INFO - async*setUp@chrome://mochitests/content/browser/browser/base/content/test/general/browser_contentSearchUI.js:634:17
[task 2018-10-05T16:10:09.975Z] 16:10:09     INFO - tabKey@chrome://mochitests/content/browser/browser/base/content/test/general/browser_contentSearchUI.js:136:9
[task 2018-10-05T16:10:09.977Z] 16:10:09     INFO - Async*Tester_execTest/<@chrome://mochikit/content/browser-test.js:1093:34
[task 2018-10-05T16:10:09.978Z] 16:10:09     INFO - async*Tester_execTest@chrome://mochikit/content/browser-test.js:1084:16
[task 2018-10-05T16:10:09.979Z] 16:10:09     INFO - nextTest/<@chrome://mochikit/content/browser-test.js:986:9
[task 2018-10-05T16:10:09.981Z] 16:10:09     INFO - SimpleTest.waitForFocus/waitForFocusInner/focusedOrLoaded/<@chrome://mochikit/content/tests/SimpleTest/SimpleTest.js:795:59
[task 2018-10-05T16:10:09.982Z] 16:10:09     INFO - Leaving test bound tabKey
[task 2018-10-05T16:10:09.984Z] 16:10:09     INFO - Entering test bound cycleSuggestions
[task 2018-10-05T16:10:09.985Z] 16:10:09     INFO - Removing default search engines
[task 2018-10-05T16:10:09.987Z] 16:10:09     INFO - Adding test search engines
[task 2018-10-05T16:10:09.988Z] 16:10:09     INFO - Not taking screenshot here: see the one that was previously logged
[task 2018-10-05T16:10:09.989Z] 16:10:09     INFO - TEST-UNEXPECTED-FAIL | browser/base/content/test/general/browser_contentSearchUI.js | Uncaught exception - [Exception... "Could not convert JavaScript argument arg 3 [nsIBrowserSearchService.addEngine]"  nsresult: "0x80570009 (NS_ERROR_XPC_BAD_CONVERT_JS)"  location: "JS frame :: resource://testing-common/SearchTestUtils.jsm :: promiseNewSearchEngine/< :: line 31"  data: no]
[task 2018-10-05T16:10:09.991Z] 16:10:09     INFO - Stack trace:
[task 2018-10-05T16:10:09.992Z] 16:10:09     INFO - promiseNewSearchEngine/<@resource://testing-common/SearchTestUtils.jsm:31:7
[task 2018-10-05T16:10:09.994Z] 16:10:09     INFO - promiseNewSearchEngine@resource://testing-common/SearchTestUtils.jsm:30:12
[task 2018-10-05T16:10:09.996Z] 16:10:09     INFO - setUpEngines/<@chrome://mochitests/content/browser/browser/base/content/test/general/browser_contentSearchUI.js:744:25
[task 2018-10-05T16:10:09.997Z] 16:10:09     INFO - async*setUpEngines@chrome://mochitests/content/browser/browser/base/content/test/general/browser_contentSearchUI.js:738:17
[task 2018-10-05T16:10:09.997Z] 16:10:09     INFO - setUp/<@chrome://mochitests/content/browser/browser/base/content/test/general/browser_contentSearchUI.js:645:13
[task 2018-10-05T16:10:09.998Z] 16:10:09     INFO - async*setUp@chrome://mochitests/content/browser/browser/base/content/test/general/browser_contentSearchUI.js:634:17
[task 2018-10-05T16:10:09.999Z] 16:10:09     INFO - cycleSuggestions@chrome://mochitests/content/browser/browser/base/content/test/general/browser_contentSearchUI.js:194:9
[task 2018-10-05T16:10:10.000Z] 16:10:09     INFO - Async*Tester_execTest/<@chrome://mochikit/content/browser-test.js:1093:34
[task 2018-10-05T16:10:10.000Z] 16:10:09     INFO - async*Tester_execTest@chrome://mochikit/content/browser-test.js:1084:16
[task 2018-10-05T16:10:10.001Z] 16:10:09     INFO - nextTest/<@chrome://mochikit/content/browser-test.js:986:9
[task 2018-10-05T16:10:10.002Z] 16:10:09     INFO - SimpleTest.waitForFocus/waitForFocusInner/focusedOrLoaded/<@chrome://mochikit/content/tests/SimpleTest/SimpleTest.js:795:59
[task 2018-10-05T16:10:10.003Z] 16:10:09     INFO - Leaving test bound cycleSuggestions
[task 2018-10-05T16:10:10.004Z] 16:10:09     INFO - Entering test bound cycleOneOffs
[task 2018-10-05T16:10:10.005Z] 16:10:09     INFO - Removing default search engines
[task 2018-10-05T16:10:10.005Z] 16:10:09     INFO - Adding test search engines
[task 2018-10-05T16:10:10.006Z] 16:10:09     INFO - Not taking screenshot here: see the one that was previously logged
[task 2018-10-05T16:10:10.007Z] 16:10:09     INFO - TEST-UNEXPECTED-FAIL | browser/base/content/test/general/browser_contentSearchUI.js | Uncaught exception - [Exception... "Could not convert JavaScript argument arg 3 [nsIBrowserSearchService.addEngine]"  nsresult: "0x80570009 (NS_ERROR_XPC_BAD_CONVERT_JS)"  location: "JS frame :: resource://testing-common/SearchTestUtils.jsm :: promiseNewSearchEngine/< :: line 31"  data: no]
[task 2018-10-05T16:10:10.008Z] 16:10:09     INFO - Stack trace:
[task 2018-10-05T16:10:10.009Z] 16:10:09     INFO - promiseNewSearchEngine/<@resource://testing-common/SearchTestUtils.jsm:31:7
[task 2018-10-05T16:10:10.009Z] 16:10:09     INFO - promiseNewSearchEngine@resource://testing-common/SearchTestUtils.jsm:30:12
[task 2018-10-05T16:10:10.010Z] 16:10:09     INFO - setUpEngines/<@chrome://mochitests/content/browser/browser/base/content/test/general/browser_contentSearchUI.js:744:25
[task 2018-10-05T16:10:10.011Z] 16:10:09     INFO - async*setUpEngines@chrome://mochitests/content/browser/browser/base/content/test/general/browser_contentSearchUI.js:738:17
[task 2018-10-05T16:10:10.012Z] 16:10:09     INFO - setUp/<@chrome://mochitests/content/browser/browser/base/content/test/general/browser_contentSearchUI.js:645:13
[task 2018-10-05T16:10:10.012Z] 16:10:09     INFO - async*setUp@chrome://mochitests/content/browser/browser/base/content/test/general/browser_contentSearchUI.js:634:17
[task 2018-10-05T16:10:10.013Z] 16:10:09     INFO - cycleOneOffs@chrome://mochitests/content/browser/browser/base/content/test/general/browser_contentSearchUI.js:244:9
[task 2018-10-05T16:10:10.013Z] 16:10:09     INFO - Async*Tester_execTest/<@chrome://mochikit/content/browser-test.js:1093:34
[task 2018-10-05T16:10:10.013Z] 16:10:09     INFO - async*Tester_execTest@chrome://mochikit/content/browser-test.js:1084:16
[task 2018-10-05T16:10:10.014Z] 16:10:09     INFO - nextTest/<@chrome://mochikit/content/browser-test.js:986:9
[task 2018-10-05T16:10:10.014Z] 16:10:09     INFO - SimpleTest.waitForFocus/waitForFocusInner/focusedOrLoaded/<@chrome://mochikit/content/tests/SimpleTest/SimpleTest.js:795:59
[task 2018-10-05T16:10:10.014Z] 16:10:09     INFO - Leaving test bound cycleOneOffs
[task 2018-10-05T16:10:10.014Z] 16:10:09     INFO - Entering test bound mouse
[task 2018-10-05T16:10:10.015Z] 16:10:09     INFO - Removing default search engines
[task 2018-10-05T16:10:10.015Z] 16:10:09     INFO - Adding test search engines
[task 2018-10-05T16:10:10.015Z] 16:10:09     INFO - Not taking screenshot here: see the one that was previously logged
[task 2018-10-05T16:10:10.015Z] 16:10:09     INFO - TEST-UNEXPECTED-FAIL | browser/base/content/test/general/browser_contentSearchUI.js | Uncaught exception - [Exception... "Could not convert JavaScript argument arg 3 [nsIBrowserSearchService.addEngine]"  nsresult: "0x80570009 (NS_ERROR_XPC_BAD_CONVERT_JS)"  location: "JS frame :: resource://testing-common/SearchTestUtils.jsm :: promiseNewSearchEngine/< :: line 31"  data: no]
[task 2018-10-05T16:10:10.015Z] 16:10:09     INFO - Stack trace:
[task 2018-10-05T16:10:10.015Z] 16:10:09     INFO - promiseNewSearchEngine/<@resource://testing-common/SearchTestUtils.jsm:31:7
[task 2018-10-05T16:10:10.015Z] 16:10:09     INFO - promiseNewSearchEngine@resource://testing-common/SearchTestUtils.jsm:30:12
[task 2018-10-05T16:10:10.015Z] 16:10:09     INFO - setUpEngines/<@chrome://mochitests/content/browser/browser/base/content/test/general/browser_contentSearchUI.js:744:25
[task 2018-10-05T16:10:10.019Z] 16:10:09     INFO - async*setUpEngines@chrome://mochitests/content/browser/browser/base/content/test/general/browser_contentSearchUI.js:738:17
[task 2018-10-05T16:10:10.019Z] 16:10:09     INFO - setUp/<@chrome://mochitests/content/browser/browser/base/content/test/general/browser_contentSearchUI.js:645:13
[task 2018-10-05T16:10:10.019Z] 16:10:09     INFO - async*setUp@chrome://mochitests/content/browser/browser/base/content/test/general/browser_contentSearchUI.js:634:17
[task 2018-10-05T16:10:10.020Z] 16:10:09     INFO - mouse@chrome://mochitests/content/browser/browser/base/content/test/general/browser_contentSearchUI.js:296:9
[task 2018-10-05T16:10:10.020Z] 16:10:09     INFO - Async*Tester_execTest/<@chrome://mochikit/content/browser-test.js:1093:34
[task 2018-10-05T16:10:10.021Z] 16:10:09     INFO - async*Tester_execTest@chrome://mochikit/content/browser-test.js:1084:16
[task 2018-10-05T16:10:10.021Z] 16:10:09     INFO - nextTest/<@chrome://mochikit/content/browser-test.js:986:9
[task 2018-10-05T16:10:10.021Z] 16:10:09     INFO - SimpleTest.waitForFocus/waitForFocusInner/focusedOrLoaded/<@chrome://mochikit/content/tests/SimpleTest/SimpleTest.js:795:59
[task 2018-10-05T16:10:10.021Z] 16:10:09     INFO - Leaving test bound mouse
[task 2018-10-05T16:10:10.023Z] 16:10:09     INFO - Entering test bound formHistory
[task 2018-10-05T16:10:10.023Z] 16:10:09     INFO - Removing default search engines
[task 2018-10-05T16:10:10.024Z] 16:10:09     INFO - Adding test search engines
[task 2018-10-05T16:10:10.024Z] 16:10:09     INFO - Not taking screenshot here: see the one that was previously logged
[task 2018-10-05T16:10:10.024Z] 16:10:09     INFO - TEST-UNEXPECTED-FAIL | browser/base/content/test/general/browser_contentSearchUI.js | Uncaught exception - [Exception... "Could not convert JavaScript argument arg 3 [nsIBrowserSearchService.addEngine]"  nsresult: "0x80570009 (NS_ERROR_XPC_BAD_CONVERT_JS)"  location: "JS frame :: resource://testing-common/SearchTestUtils.jsm :: promiseNewSearchEngine/< :: line 31"  data: no]
[task 2018-10-05T16:10:10.024Z] 16:10:09     INFO - Stack trace:
[task 2018-10-05T16:10:10.025Z] 16:10:09     INFO - promiseNewSearchEngine/<@resource://testing-common/SearchTestUtils.jsm:31:7
[task 2018-10-05T16:10:10.026Z] 16:10:09     INFO - promiseNewSearchEngine@resource://testing-common/SearchTestUtils.jsm:30:12
[task 2018-10-05T16:10:10.026Z] 16:10:09     INFO - setUpEngines/<@chrome://mochitests/content/browser/browser/base/content/test/general/browser_contentSearchUI.js:744:25
[task 2018-10-05T16:10:10.027Z] 16:10:09     INFO - async*setUpEngines@chrome://mochitests/content/browser/browser/base/content/test/general/browser_contentSearchUI.js:738:17
[task 2018-10-05T16:10:10.028Z] 16:10:09     INFO - setUp/<@chrome://mochitests/content/browser/browser/base/content/test/general/browser_contentSearchUI.js:645:13
[task 2018-10-05T16:10:10.028Z] 16:10:09     INFO - async*setUp@chrome://mochitests/content/browser/browser/base/content/test/general/browser_contentSearchUI.js:634:17
[task 2018-10-05T16:10:10.028Z] 16:10:09     INFO - formHistory@chrome://mochitests/content/browser/browser/base/content/test/general/browser_contentSearchUI.js:335:9
[task 2018-10-05T16:10:10.028Z] 16:10:09     INFO - Async*Tester_execTest/<@chrome://mochikit/content/browser-test.js:1093:34
[task 2018-10-05T16:10:10.029Z] 16:10:09     INFO - async*Tester_execTest@chrome://mochikit/content/browser-test.js:1084:16
[task 2018-10-05T16:10:10.030Z] 16:10:09     INFO - nextTest/<@chrome://mochikit/content/browser-test.js:986:9
[task 2018-10-05T16:10:10.030Z] 16:10:09     INFO - SimpleTest.waitForFocus/waitForFocusInner/focusedOrLoaded/<@chrome://mochikit/content/tests/SimpleTest/SimpleTest.js:795:59
[task 2018-10-05T16:10:10.030Z] 16:10:09     INFO - Leaving test bound formHistory
[task 2018-10-05T16:10:10.031Z] 16:10:09     INFO - Entering test bound cycleEngines
[task 2018-10-05T16:10:10.032Z] 16:10:09     INFO - Removing default search engines
[task 2018-10-05T16:10:10.032Z] 16:10:09     INFO - Adding test search engines
[task 2018-10-05T16:10:10.032Z] 16:10:09     INFO - Not taking screenshot here: see the one that was previously logged
[task 2018-10-05T16:10:10.032Z] 16:10:09     INFO - TEST-UNEXPECTED-FAIL | browser/base/content/test/general/browser_contentSearchUI.js | Uncaught exception - [Exception... "Could not convert JavaScript argument arg 3 [nsIBrowserSearchService.addEngine]"  nsresult: "0x80570009 (NS_ERROR_XPC_BAD_CONVERT_JS)"  location: "JS frame :: resource://testing-common/SearchTestUtils.jsm :: promiseNewSearchEngine/< :: line 31"  data: no]
[task 2018-10-05T16:10:10.033Z] 16:10:09     INFO - Stack trace:
[task 2018-10-05T16:10:10.033Z] 16:10:09     INFO - promiseNewSearchEngine/<@resource://testing-common/SearchTestUtils.jsm:31:7
[task 2018-10-05T16:10:10.034Z] 16:10:09     INFO - promiseNewSearchEngine@resource://testing-common/SearchTestUtils.jsm:30:12
[task 2018-10-05T16:10:10.036Z] 16:10:09     INFO - setUpEngines/<@chrome://mochitests/content/browser/browser/base/content/test/general/browser_contentSearchUI.js:744:25
[task 2018-10-05T16:10:10.037Z] 16:10:09     INFO - async*setUpEngines@chrome://mochitests/content/browser/browser/base/content/test/general/browser_contentSearchUI.js:738:17
[task 2018-10-05T16:10:10.037Z] 16:10:09     INFO - setUp/<@chrome://mochitests/content/browser/browser/base/content/test/general/browser_contentSearchUI.js:645:13
[task 2018-10-05T16:10:10.038Z] 16:10:09     INFO - async*setUp@chrome://mochitests/content/browser/browser/base/content/test/general/browser_contentSearchUI.js:634:17
[task 2018-10-05T16:10:10.039Z] 16:10:09     INFO - cycleEngines@chrome://mochitests/content/browser/browser/base/content/test/general/browser_contentSearchUI.js:390:9
[task 2018-10-05T16:10:10.039Z] 16:10:09     INFO - Async*Tester_execTest/<@chrome://mochikit/content/browser-test.js:1093:34
[task 2018-10-05T16:10:10.039Z] 16:10:09     INFO - async*Tester_execTest@chrome://mochikit/content/browser-test.js:1084:16
[task 2018-10-05T16:10:10.041Z] 16:10:09     INFO - nextTest/<@chrome://mochikit/content/browser-test.js:986:9
[task 2018-10-05T16:10:10.041Z] 16:10:09     INFO - SimpleTest.waitForFocus/waitForFocusInner/focusedOrLoaded/<@chrome://mochikit/content/tests/SimpleTest/SimpleTest.js:795:59
[task 2018-10-05T16:10:10.042Z] 16:10:09     INFO - Leaving test bound cycleEngines
[task 2018-10-05T16:10:10.042Z] 16:10:09     INFO - Entering test bound search
[task 2018-10-05T16:10:10.042Z] 16:10:09     INFO - Removing default search engines
[task 2018-10-05T16:10:10.043Z] 16:10:09     INFO - Adding test search engines
[task 2018-10-05T16:10:10.044Z] 16:10:09     INFO - Not taking screenshot here: see the one that was previously logged
[task 2018-10-05T16:10:10.044Z] 16:10:10     INFO - TEST-UNEXPECTED-FAIL | browser/base/content/test/general/browser_contentSearchUI.js | Uncaught exception - [Exception... "Could not convert JavaScript argument arg 3 [nsIBrowserSearchService.addEngine]"  nsresult: "0x80570009 (NS_ERROR_XPC_BAD_CONVERT_JS)"  location: "JS frame :: resource://testing-common/SearchTestUtils.jsm :: promiseNewSearchEngine/< :: line 31"  data: no]
[task 2018-10-05T16:10:10.045Z] 16:10:10     INFO - Stack trace:
[task 2018-10-05T16:10:10.046Z] 16:10:10     INFO - promiseNewSearchEngine/<@resource://testing-common/SearchTestUtils.jsm:31:7
[task 2018-10-05T16:10:10.047Z] 16:10:10     INFO - promiseNewSearchEngine@resource://testing-common/SearchTestUtils.jsm:30:12
[task 2018-10-05T16:10:10.048Z] 16:10:10     INFO - setUpEngines/<@chrome://mochitests/content/browser/browser/base/content/test/general/browser_contentSearchUI.js:744:25
[task 2018-10-05T16:10:10.048Z] 16:10:10     INFO - async*setUpEngines@chrome://mochitests/content/browser/browser/base/content/test/general/browser_contentSearchUI.js:738:17
[task 2018-10-05T16:10:10.049Z] 16:10:10     INFO - setUp/<@chrome://mochitests/content/browser/browser/base/content/test/general/browser_contentSearchUI.js:645:13
[task 2018-10-05T16:10:10.049Z] 16:10:10     INFO - async*setUp@chrome://mochitests/content/browser/browser/base/content/test/general/browser_contentSearchUI.js:634:17
[task 2018-10-05T16:10:10.050Z] 16:10:10     INFO - search@chrome://mochitests/content/browser/browser/base/content/test/general/browser_contentSearchUI.js:419:9
[task 2018-10-05T16:10:10.050Z] 16:10:10     INFO - Async*Tester_execTest/<@chrome://mochikit/content/browser-test.js:1093:34
[task 2018-10-05T16:10:10.052Z] 16:10:10     INFO - async*Tester_execTest@chrome://mochikit/content/browser-test.js:1084:16
[task 2018-10-05T16:10:10.052Z] 16:10:10     INFO - nextTest/<@chrome://mochikit/content/browser-test.js:986:9
[task 2018-10-05T16:10:10.053Z] 16:10:10     INFO - SimpleTest.waitForFocus/waitForFocusInner/focusedOrLoaded/<@chrome://mochikit/content/tests/SimpleTest/SimpleTest.js:795:59
[task 2018-10-05T16:10:10.053Z] 16:10:10     INFO - Leaving test bound search
[task 2018-10-05T16:10:10.054Z] 16:10:10     INFO - Entering test bound settings
[task 2018-10-05T16:10:10.054Z] 16:10:10     INFO - Removing default search engines
[task 2018-10-05T16:10:10.054Z] 16:10:10     INFO - Adding test search engines
[task 2018-10-05T16:10:10.054Z] 16:10:10     INFO - Not taking screenshot here: see the one that was previously logged
[task 2018-10-05T16:10:10.056Z] 16:10:10     INFO - TEST-UNEXPECTED-FAIL | browser/base/content/test/general/browser_contentSearchUI.js | Uncaught exception - [Exception... "Could not convert JavaScript argument arg 3 [nsIBrowserSearchService.addEngine]"  nsresult: "0x80570009 (NS_ERROR_XPC_BAD_CONVERT_JS)"  location: "JS frame :: resource://testing-common/SearchTestUtils.jsm :: promiseNewSearchEngine/< :: line 31"  data: no]
[task 2018-10-05T16:10:10.056Z] 16:10:10     INFO - Stack trace:
[task 2018-10-05T16:10:10.058Z] 16:10:10     INFO - promiseNewSearchEngine/<@resource://testing-common/SearchTestUtils.jsm:31:7
[task 2018-10-05T16:10:10.058Z] 16:10:10     INFO - promiseNewSearchEngine@resource://testing-common/SearchTestUtils.jsm:30:12
[task 2018-10-05T16:10:10.059Z] 16:10:10     INFO - setUpEngines/<@chrome://mochitests/content/browser/browser/base/content/test/general/browser_contentSearchUI.js:744:25
[task 2018-10-05T16:10:10.060Z] 16:10:10     INFO - async*setUpEngines@chrome://mochitests/content/browser/browser/base/content/test/general/browser_contentSearchUI.js:738:17
[task 2018-10-05T16:10:10.060Z] 16:10:10     INFO - setUp/<@chrome://mochitests/content/browser/browser/base/content/test/general/browser_contentSearchUI.js:645:13
[task 2018-10-05T16:10:10.060Z] 16:10:10     INFO - async*setUp@chrome://mochitests/content/browser/browser/base/content/test/general/browser_contentSearchUI.js:634:17
[task 2018-10-05T16:10:10.061Z] 16:10:10     INFO - settings@chrome://mochitests/content/browser/browser/base/content/test/general/browser_contentSearchUI.js:621:9
[task 2018-10-05T16:10:10.061Z] 16:10:10     INFO - Async*Tester_execTest/<@chrome://mochikit/content/browser-test.js:1093:34
[task 2018-10-05T16:10:10.061Z] 16:10:10     INFO - async*Tester_execTest@chrome://mochikit/content/browser-test.js:1084:16
[task 2018-10-05T16:10:10.062Z] 16:10:10     INFO - nextTest/<@chrome://mochikit/content/browser-test.js:986:9
[task 2018-10-05T16:10:10.062Z] 16:10:10     INFO - SimpleTest.waitForFocus/waitForFocusInner/focusedOrLoaded/<@chrome://mochikit/content/tests/SimpleTest/SimpleTest.js:795:59
[task 2018-10-05T16:10:10.063Z] 16:10:10     INFO - Leaving test bound settings
[task 2018-10-05T16:10:10.063Z] 16:10:10     INFO - GECKO(1065) | MEMORY STAT | vsize 2188MB | residentFast 435MB | heapAllocated 152MB
[task 2018-10-05T16:10:10.064Z] 16:10:10     INFO - TEST-OK | browser/base/content/test/general/browser_contentSearchUI.js | took 231ms
[task 2018-10-05T16:10:10.064Z] 16:10:10     INFO - GECKO(1065) | ++DOCSHELL 0x7ff495d0f800 == 2 [pid = 1159] [id = {d0088f76-6f2b-4e90-91c1-477a5e9f5407}]
[task 2018-10-05T16:10:10.065Z] 16:10:10     INFO - GECKO(1065) | ++DOMWINDOW == 10 (0x7ff497e4fe00) [pid = 1159] [serial = 175] [outer = (nil)]
[task 2018-10-05T16:10:10.066Z] 16:10:10     INFO - GECKO(1065) | ++DOMWINDOW == 11 (0x7ff495ce0000) [pid = 1159] [serial = 176] [outer = 0x7ff497e4fe00]
[task 2018-10-05T16:10:10.067Z] 16:10:10     INFO - checking window state
[task 2018-10-05T16:10:10.067Z] 16:10:10     INFO - TEST-START | browser/base/content/test/general/browser_contextmenu_childprocess.js
[task 2018-10-05T16:10:10.068Z] 16:10:10     INFO - GECKO(1065) | ++DOCSHELL 0x7f26eea1b000 == 4 [pid = 1227] [id = {462daf50-348f-4e37-bef4-bbb71edc1673}]
[task 2018-10-05T16:10:10.069Z] 16:10:10     INFO - GECKO(1065) | ++DOMWINDOW == 11 (0x7f26ee15ae00) [pid = 1227] [serial = 171] [outer = (nil)]
[task 2018-10-05T16:10:10.069Z] 16:10:10     INFO - GECKO(1065) | ++DOMWINDOW == 12 (0x7f26f014e000) [pid = 1227] [serial = 172] [outer = 0x7f26ee15ae00]
[task 2018-10-05T16:10:10.070Z] 16:10:10     INFO - GECKO(1065) | --DOMWINDOW == 10 (0x7ff495cdbc00) [pid = 1159] [serial = 170] [outer = (nil)] [url = about:blank]
[task 2018-10-05T16:10:10.070Z] 16:10:10     INFO - GECKO(1065) | --DOMWINDOW == 9 (0x7ff495ce1000) [pid = 1159] [serial = 167] [outer = (nil)] [url = about:blank]
[task 2018-10-05T16:10:10.291Z] 16:10:10     INFO - GECKO(1065) | ++DOMWINDOW == 13 (0x7f26f0150800) [pid = 1227] [serial = 173] [outer = 0x7f26ee15ae00]
[task 2018-10-05T16:10:10.328Z] 16:10:10     INFO - GECKO(1065) | ++DOCSHELL 0x7f26f04ed800 == 5 [pid = 1227] [id = {c31b1541-8c24-421e-b8fd-ff6c0b0ff31b}]
[task 2018-10-05T16:10:10.329Z] 16:10:10     INFO - GECKO(1065) | ++DOMWINDOW == 14 (0x7f26ef629600) [pid = 1227] [serial = 174] [outer = (nil)]
[task 2018-10-05T16:10:10.330Z] 16:10:10     INFO - GECKO(1065) | ++DOCSHELL 0x7f26f01a3800 == 6 [pid = 1227] [id = {22f93bd6-1357-48a9-9cbd-7faa75bc340d}]
[task 2018-10-05T16:10:10.331Z] 16:10:10     INFO - GECKO(1065) | ++DOMWINDOW == 15 (0x7f26ef629a00) [pid = 1227] [serial = 175] [outer = (nil)]
[task 2018-10-05T16:10:10.332Z] 16:10:10     INFO - GECKO(1065) | ++DOCSHELL 0x7f26f04ee000 == 7 [pid = 1227] [id = {3784a225-c828-469e-94bf-6b9a904e5c9b}]
[task 2018-10-05T16:10:10.333Z] 16:10:10     INFO - GECKO(1065) | ++DOMWINDOW == 16 (0x7f26ef629c00) [pid = 1227] [serial = 176] [outer = (nil)]
[task 2018-10-05T16:10:10.337Z] 16:10:10     INFO - GECKO(1065) | ++DOCSHELL 0x7f26f04ee800 == 8 [pid = 1227] [id = {448136ec-fc50-43e8-b35e-919c2f20db29}]
[task 2018-10-05T16:10:10.338Z] 16:10:10     INFO - GECKO(1065) | ++DOMWINDOW == 17 (0x7f26f03e7800) [pid = 1227] [serial = 177] [outer = (nil)]
[task 2018-10-05T16:10:10.339Z] 16:10:10     INFO - GECKO(1065) | ++DOCSHELL 0x7f26f04ef000 == 9 [pid = 1227] [id = {8dcec7ef-72b7-4691-b221-23d14ce3a227}]
[task 2018-10-05T16:10:10.340Z] 16:10:10     INFO - GECKO(1065) | ++DOMWINDOW == 18 (0x7f26f03e8000) [pid = 1227] [serial = 178] [outer = (nil)]
[task 2018-10-05T16:10:10.664Z] 16:10:10     INFO - GECKO(1065) | [Child 1227, Main Thread] WARNING: Can't add a range if the end is older that the start.: file /builds/worker/workspace/build/src/dom/html/TimeRanges.cpp, line 92
[task 2018-10-05T16:10:10.680Z] 16:10:10     INFO - GECKO(1065) | [Child 1227, Main Thread] WARNING: Can't add a range if the end is older that the start.: file /builds/worker/workspace/build/src/dom/html/TimeRanges.cpp, line 92
[task 2018-10-05T16:10:10.742Z] 16:10:10     INFO - GECKO(1065) | [Child 1227, Main Thread] WARNING: HTMLEditRules::BeforeEdit() failed to handle something: 'NS_SUCCEEDED(rv)', file /builds/worker/workspace/build/src/editor/libeditor/HTMLEditor.cpp, line 3613
[task 2018-10-05T16:10:10.744Z] 16:10:10     INFO - GECKO(1065) | [Child 1227, Main Thread] WARNING: '!aSelection->RangeCount()', file /builds/worker/workspace/build/src/editor/libeditor/EditorBase.cpp, line 3912
[task 2018-10-05T16:10:10.745Z] 16:10:10     INFO - GECKO(1065) | [Child 1227, Main Thread] WARNING: '!selectionStartPoint.IsSet()', file /builds/worker/workspace/build/src/editor/libeditor/HTMLEditRules.cpp, line 10245
[task 2018-10-05T16:10:10.751Z] 16:10:10     INFO - GECKO(1065) | [Child 1227, Main Thread] WARNING: Failed to normalize Selection: 'NS_SUCCEEDED(rv)', file /builds/worker/workspace/build/src/editor/libeditor/HTMLEditRules.cpp, line 470
[task 2018-10-05T16:10:11.102Z] 16:10:11     INFO - GECKO(1065) | ++DOMWINDOW == 19 (0x7f26f3aa5800) [pid = 1227] [serial = 179] [outer = 0x7f26ef629600]
[task 2018-10-05T16:10:11.183Z] 16:10:11     INFO - GECKO(1065) | ++DOMWINDOW == 20 (0x7f26f0303000) [pid = 1227] [serial = 180] [outer = 0x7f26f03e8000]
[task 2018-10-05T16:10:11.272Z] 16:10:11     INFO - GECKO(1065) | ++DOMWINDOW == 21 (0x7f26f0303c00) [pid = 1227] [serial = 181] [outer = 0x7f26ef629a00]
[task 2018-10-05T16:10:11.434Z] 16:10:11     INFO - GECKO(1065) | ++DOMWINDOW == 22 (0x7f26ee4e8c00) [pid = 1227] [serial = 182] [outer = 0x7f26ef629c00]
[task 2018-10-05T16:10:11.450Z] 16:10:11     INFO - GECKO(1065) | ++DOMWINDOW == 23 (0x7f26ee4e9400) [pid = 1227] [serial = 183] [outer = 0x7f26f03e7800]
[task 2018-10-05T16:10:13.215Z] 16:10:13     INFO - GECKO(1065) | MEMORY STAT | vsize 2334MB | residentFast 446MB | heapAllocated 156MB
[task 2018-10-05T16:10:13.215Z] 16:10:13     INFO - TEST-OK | browser/base/content/test/general/browser_contextmenu_childprocess.js | took 3630ms

Push with failures:
https://treeherder.mozilla.org/#/jobs?repo=mozilla-inbound&group_state=expanded&revision=a858092c4df7c1db13935762fea281a5f9911a98

Backout:
https://hg.mozilla.org/integration/mozilla-inbound/rev/7c132c5ae38d40a3fdf6e5d4fa13065d6922cf4d
Flags: needinfo?(dpino)
QA Contact: adw
Not sure how the SearchTestUtils part got dropped, but adding that back gets us green:

https://treeherder.mozilla.org/#/jobs?repo=try&revision=75b606f45f33e6ffb637fdab85e793408abeb238
OK, I think we have it this time. Really.
Attachment #9015271 - Flags: review+
Attachment #9014818 - Attachment is obsolete: true
Keywords: checkin-needed
Tried to land this and received the following: 
Hunk #1 FAILED at 329
1 out of 1 hunks FAILED -- saving rejects to file browser/modules/test/browser/browser_ContentSearch.js.rej
patch failed, unable to continue (try -v)
patch failed, rejects left in working directory
errors during apply, please fix and qrefresh Bug-1481199-Drop-the-obsolete-dataType-parameter-for.patch
Flags: needinfo?(mozilla)
Keywords: checkin-needed
I will take a look at this. I feel this patch is causing a lot of trouble. Thanks Mike for putting so much effort in helping me land it.

With regard to the missing changes in SearchTestUtils, I think I borked it when I did the rebase, likely I used an out of date local branch.
Flags: needinfo?(dpino)
There was a change to browser_ContentSearch.js that landed on the 6th October, so I suspect it is bitrot from that.

I'm happy to take a look at landing this directly in a few hours (I'm not sure Mike has commit access?), rather than waiting on the checkin-needed cycle - worst case I can do a final tweak if it needs it.
Mark: That would be great. I tried to fetch the patch and apply it to my local checkout to rebase it to latest master, but I have some trouble converting the hg patch to a git patch :/
Pushed by mbanner@mozilla.com:
https://hg.mozilla.org/integration/mozilla-inbound/rev/eaa627409f75
Drop the obsolete dataType parameter for nsIBrowserSearchService.addEngine. r=mkaply
https://hg.mozilla.org/mozilla-central/rev/eaa627409f75
Status: NEW → RESOLVED
Closed: 11 months ago
Resolution: --- → FIXED
Target Milestone: --- → Firefox 64
Flags: needinfo?(mozilla)
You need to log in before you can comment on or make changes to this bug.