Closed Bug 1481537 Opened 4 years ago Closed 3 years ago

add support for bug-less commits

Categories

(Conduit :: moz-phab, enhancement, P3)

enhancement

Tracking

(Not tracked)

RESOLVED FIXED

People

(Reporter: glob, Assigned: glob)

References

Details

(Keywords: conduit-triaged)

Attachments

(2 files)

add support for bug-less commits

only via the `NO BUG` marker in the commit description [as per the commit hook](https://hg.mozilla.org/hgcustom/version-control-tools/file/tip/hghooks/mozhghooks/commit-message.py#l26)

i don't think supporting `NO BUG` as a command line switch is the right thing to do; this is an override and its usage should be on the decline

when automatic bug creation happens then we can add a switch for that
Keywords: conduit-triaged
Whiteboard: [phabricator-backlog]
a different way to handle this is to follow bug 1482216 and just display a warning.

another thing to consider is "NO BUG" is a mozilla-central specific thing; none of the other repositories that we support (NSS, VCT, all the git based repos) have this requirement and it would be weird to always add "NO BUG" to their commits.

(spongebob: some time later)

we could make the warning configurable in moz-phab (after adding support for per-repo configuration options) and update lando to add the NO BUG marker upon landing to mozilla-central, gated behind a warning.
Keywords: conduit-backlog
Whiteboard: [phabricator-backlog]
Keywords: conduit-backlog
Priority: -- → P3
Duplicate of this bug: 1551561

This is going to help WPT; let's do the simplest thing and add a --no-bug switch which just bypasses the moz-phab check.

Assignee: nobody → glob

Hoist repo.vcs into the base class, and rename the existing _vcs to
_phab_vcs to clarify its value.

Depends on D53779

You need to log in before you can comment on or make changes to this bug.