Closed Bug 1482190 Opened 2 years ago Closed 2 years ago

Custom top sites which match the search shortcut rules get incorrectly converted to search shortcuts after being added

Categories

(Firefox :: New Tab Page, defect, P2)

defect

Tracking

()

VERIFIED FIXED
Firefox 63
Iteration:
63.4 - Aug 20
Tracking Status
firefox62 --- verified
firefox63 --- verified

People

(Reporter: k88hudson, Assigned: ahillier)

References

(Blocks 1 open bug)

Details

Attachments

(1 file)

STR:

With browser.newtabpage.activity-stream.improvesearch.topSiteSearchShortcuts.havePinned turned on, do the following:

1. Click the "Add Top Site" option of the top sites section menu. 
2. Add a title of "Custom Google" and the url "https://google.com/foo".

Expected:

A new regular pinned site with the title "Custom Google" and url "https://google.com/foo" should show up.

Actual:

A search shortcut shows up
Note that this also applies to editing sites in place.
Assignee: nobody → ahillier
Commit pushed to master at https://github.com/mozilla/activity-stream

https://github.com/mozilla/activity-stream/commit/7f409d38dc66e6e692fd56358b5f74928e409b07
Fix Bug 1482190: don't convert manually pinned sites to search shortcuts (#4305)
Status: NEW → RESOLVED
Closed: 2 years ago
Resolution: --- → FIXED
Blocks: 1482205
I have verified this on Windows 10 x64, Arch Linux and Mac 10.13.3 with the latest version of "Firefox Nightly" (63.0a1 - Build ID 20180813220525) installed and I can confirm that a "Top Site" that matches a search shortcut, is not converted automatically to one after being created.
Status: RESOLVED → VERIFIED
Blocks: 1482398
Checked with 62.0b18 over Windows 10x64, macOS 10.12, Ubuntu 16.04LTS, and 62.0b19 on macOS10.12. 
The issue is not present on any OS.
Component: Activity Streams: Newtab → New Tab Page
You need to log in before you can comment on or make changes to this bug.