Cannot remove addon through "Manage Extension" item in browserAction context menu

VERIFIED FIXED in Firefox 62

Status

()

VERIFIED FIXED
6 months ago
10 days ago

People

(Reporter: philipp, Assigned: mstriemer)

Tracking

({regression})

62 Branch
mozilla63
regression
Points:
---
Bug Flags:
in-testsuite +

Firefox Tracking Flags

(firefox-esr52 unaffected, firefox-esr60 unaffected, firefox61 unaffected, firefox62+ verified, firefox63 verified)

Details

Attachments

(2 attachments)

(Reporter)

Description

6 months ago
Created attachment 8999258 [details]
screencast

bug 1457474 implemented a way to open a webextension's entry within about:addons through the context menu of its toolbar icon. it's not possible to uninstall/remove the addon that way though.

str in a new profile:
- install the privacy badger extension from https://addons.mozilla.org/en-US/firefox/addon/privacy-badger17/
- right-click the browseraction icon that's added to the toolbar
- click on "manage extension"
- click on "remove" on the addon page in about:addons that opened
- nothing is happening at that point and the extension stays installed (if you are starting the steps from a newly opened tab, the about:addons page will close and the addon isn't getting uninstalled either)
I guess maybe some assumptions at https://searchfox.org/mozilla-central/source/toolkit/mozapps/extensions/content/extensions.js#1196 aren't true anymore?

Oriol, want to take a look?
Flags: needinfo?(oriol-bugzilla)
tracking-firefox62: --- → +
In bug 1457474 I just copied the code from bug 1413574 for pageActions, which have the same problem.
I don't know the Add-ons Manager code, better find someone else.
Flags: needinfo?(oriol-bugzilla)
(Reporter)

Comment 3

6 months ago
hi, could you take a look as the author of bug 1413574?
Flags: needinfo?(adw)
This is a problem with the about:addons, not the UI that opens about:addons.  I'm not sure who's working on that these days.  I'll try to find someone to needinfo.
Flags: needinfo?(adw)
Oh David is listed as the triage owner -- David, do you know who might be a good person to investigate this bug?
Flags: needinfo?(ddurst)
Yuck, this code assumes that the only way to get to the detail view is by a click from the list view:
https://searchfox.org/mozilla-central/rev/2466b82b729765fb0a3ab62f812c1a96a7362478/toolkit/mozapps/extensions/content/extensions.js#1201-1203
(Assignee)

Comment 7

6 months ago
Created attachment 9000161 [details]
Bug 1482480 - Fix removing add-on from Manage Extension menu item r?aswan

Using the Manage Extension menu item would try to go back to the list view
to uninstall but there was no previous view so it would fail.

TODO: Check dictionaries
(Assignee)

Comment 8

6 months ago
I checked dictionaries, so feel free to ignore that comment.
Flags: needinfo?(ddurst)
David, should this be a priority to fix for 62? What do you think?
Flags: needinfo?(ddurst)
Comment on attachment 9000161 [details]
Bug 1482480 - Fix removing add-on from Manage Extension menu item r?aswan

Andrew Swan [:aswan] has approved the revision.
Attachment #9000161 - Flags: review+
(Assignee)

Updated

6 months ago
Assignee: nobody → mstriemer

Comment 11

6 months ago
Pushed by mstriemer@mozilla.com:
https://hg.mozilla.org/integration/autoland/rev/f2abc57ccd74
Fix removing add-on from Manage Extension menu item r=aswan

Comment 12

6 months ago
bugherder
https://hg.mozilla.org/mozilla-central/rev/f2abc57ccd74
Status: NEW → RESOLVED
Last Resolved: 6 months ago
status-firefox63: affected → fixed
Resolution: --- → FIXED
Target Milestone: --- → mozilla63
(Assignee)

Comment 13

6 months ago
This is also possible through the Manage Extension item in the page action context menu. I believe this code will fix that, too.
(Assignee)

Updated

6 months ago
Flags: needinfo?(ddurst)
Please nominate this for Beta approval when you get a chance.
Flags: qe-verify+
Flags: needinfo?(mstriemer)
Flags: in-testsuite+
(Assignee)

Comment 15

6 months ago
Comment on attachment 9000161 [details]
Bug 1482480 - Fix removing add-on from Manage Extension menu item r?aswan

Approval Request Comment
[Feature/Bug causing the regression]: bug 1457474
[User impact if declined]: Removing an extension doesn't work from the Manage Extensions option
[Is this code covered by automated tests?]: Yes
[Has the fix been verified in Nightly?]: No
[Needs manual test from QE? If yes, steps to reproduce]: See comment 0
[List of other uplifts needed for the feature/fix]:
[Is the change risky?]: Low
[Why is the change risky/not risky?]: Reduces dependence on previous state, has tests but is not verified on Nightly yet
[String changes made/needed]: No
Flags: needinfo?(mstriemer)
Attachment #9000161 - Flags: approval-mozilla-beta?
Comment on attachment 9000161 [details]
Bug 1482480 - Fix removing add-on from Manage Extension menu item r?aswan

Fix for regression in 62, has new tests. Let's uplift for beta 19.
Attachment #9000161 - Flags: approval-mozilla-beta? → approval-mozilla-beta+
Whoever takes this for verification, can you also check beta some time next week after beta 19 is released? Thanks!
Mozilla/5.0 (Windows NT 10.0; Win64; x64; rv:63.0) Gecko/20100101 Firefox/63.0 (20180817100105)

I was able to reproduce the mentioned behavior on a Nightly build from 20180808100114. 

The issue not reproducible on the latest Nightly build from 20180817100105 using Windows 10 x64, Windows 7 x64, Ubuntu 18.04 and OS X 10.13. When installing the Privacy Badger add-on and then navigate from the context menu to  Manage Extension (about:addons) and press the remove button, the add-on is successfully removed.
status-firefox63: fixed → verified

Comment 19

6 months ago
bugherderuplift
https://hg.mozilla.org/releases/mozilla-beta/rev/d810601eca84
status-firefox62: affected → fixed
I've reproduced this issue on Beta 62.0b18. 

The issue has been verified as fixed on Beta 62.0b19 using Windows 10, Windows 7, Ubuntu 18.04 and OS X 10.13.
Status: RESOLVED → VERIFIED
status-firefox62: fixed → verified
(Assignee)

Updated

6 months ago
See Also: → bug 1125613
(Assignee)

Updated

10 days ago
Duplicate of this bug: 1427991
You need to log in before you can comment on or make changes to this bug.