Closed Bug 1482565 Opened Last year Closed Last year

Support and show @Яндекс and @百度 searches for yandex and baidu

Categories

(Firefox :: New Tab Page, enhancement, P1)

enhancement

Tracking

()

VERIFIED FIXED
Firefox 63
Iteration:
63.4 - Aug 20
Tracking Status
firefox62 --- verified
firefox63 --- verified

People

(Reporter: Mardak, Assigned: Mardak)

References

(Blocks 1 open bug)

Details

(Whiteboard: [fxsearch])

Attachments

(4 files)

For yandex and baidu, bug 1482125 added the @keyword and bug 1481901 added the tile. Both places need to be updated to use the not-english keyword.
Severity: normal → enhancement
Attached image address bar keywords
Attached image activity stream tiles
mkaply, originally I was thinking activity stream would check Services.search.getDefaultEngines().…._internalAliases but then figured activity stream probably shouldn't load the search service too early unnecessarily, so ended up duplicating the array, but then looks like bug 1482579 is saying it's too early anyway.

Ideally we get rid of this duplication, but we also don't want to impact startup or cause things to be loaded too early unnecessarily.
See Also: → 1482579
Comment on attachment 8999318 [details]
Bug 1482565 - Support and show @Яндекс and @百度 searches for yandex and baidu

Mike Kaply [:mkaply] has approved the revision.
Attachment #8999318 - Flags: review+
Yeah, I noticed that error when this first started landing.

I don't think there's going to be anything we can do to avoid an sync load of the search service because of how early Activity stream needs the information.

We're putting information that we need from the search service on the very first tab...
Pushed by elee@mozilla.com:
https://hg.mozilla.org/integration/autoland/rev/e1631a0ca4db
Support and show @Яндекс and @百度 searches for yandex and baidu r=mkaply
https://hg.mozilla.org/mozilla-central/rev/e1631a0ca4db
Status: NEW → RESOLVED
Closed: Last year
Resolution: --- → FIXED
Target Milestone: --- → Firefox 63
Commit pushed to master at https://github.com/mozilla/activity-stream

https://github.com/mozilla/activity-stream/commit/4190e3b81c06aaa71082c5016159749f80f266d0
chore(mc): Port Bug 1482565 - Support and show @Яндекс and @百度 searches for yandex and baidu r=mkaply (#4329)
Blocks: 1482398
Whiteboard: [fxsearch]
I have verified that the issue is no longer reproducible in the latest Nightly (63.0a1, Build ID 20180816100035) and Beta (62.0b18 Build ID 20180816151750) on Windows 10, Mac 10.13 and Arch Linux x64. @Яндекс and @百度 searches are shown for Yandex and Baidu.
Status: RESOLVED → VERIFIED
Component: Activity Streams: Newtab → New Tab Page
You need to log in before you can comment on or make changes to this bug.