Copy Link and Send Tab to Device page action button tooltips say "coypURL-title" and "sendToDevice-title"

VERIFIED FIXED in Firefox 62

Status

()

defect
P3
normal
VERIFIED FIXED
9 months ago
8 months ago

People

(Reporter: dao, Assigned: adw)

Tracking

({regression})

Trunk
Firefox 63
Points:
---
Dependency tree / graph

Firefox Tracking Flags

(firefox-esr52 unaffected, firefox-esr60 unaffected, firefox61 wontfix, firefox62+ verified, firefox63 verified)

Details

Attachments

(1 attachment)

Reporter

Description

9 months ago
In my main use profile I moved Copy Link and Send Tab to Device to be permanently visible in the address bar, and for some weeks I've been getting "coypURL-title" and "sendToDevice-title" as the tooltip. Not sure what else I did to get to this state; I can't seem to reproduce this in a new profile.
Perhaps you have a pref set that's related to Fluent? (I don't know whether that exists, just the first thing that came to mind  when I saw this fly by)
Reporter

Comment 2

9 months ago
(In reply to Mike de Boer [:mikedeboer] from comment #1)
> Perhaps you have a pref set that's related to Fluent?

I don't as far as I know.
Assignee

Updated

9 months ago
Component: Address Bar → Toolbars and Customization
Assignee

Updated

9 months ago
Priority: -- → P3
Assignee

Comment 3

9 months ago
I think I broke this with bug 1221539, which added lazy initialization for actions in the panel.

The titles/tooltips of some of these built-in actions are fetched indirectly off of attributes on the panel.  copyURL-title and sendToDevice-title are two of those attribute names.

tooltiptext is set in two places.  When you choose "Add to Address Bar," here: https://hg.mozilla.org/mozilla-central/annotate/4e56a2f51ad739ca52046723448f3129a58f1666/browser/base/content/browser-pageActions.js#l469

For new windows that should have actions in the urlbar right when they open, tooltiptext gets set via takeActionTitleFromPanel (which ends up calling updateAction, which calls _updateActionTitle), which gets called by an onPlacedInPanel callback for each action, for example: https://hg.mozilla.org/mozilla-central/annotate/4e56a2f51ad739ca52046723448f3129a58f1666/browser/base/content/browser-pageActions.js#l982

This bug only happens for new windows, so the problem is the second case.  Before bug 1221539, copyURL.onPlacedInPanel would have been called right when the window opened, but now it's only called the first time the panel opens.  So if you reproduce this bug but then open the panel, the tooltiptext gets fixed.

To fix this, there's another callback called onBeforePlacedInWindow that we could maybe use, but we should be careful not to break the lazy initialization of actions in the panel that bug 1221539 added.
Blocks: 1221539

Comment 4

9 months ago
Given this is a regression and it's almost primary UI, I'm not sure P3 is best here. I know time for 63 nightly is short at this point, but IMO we should treat this as at least P2. Hopefully we can land a fix in the 64 cycle and uplift it. Drew, is this something you could look at or are you busy with other stuff?
Flags: needinfo?(adw)
Assignee

Updated

9 months ago
Assignee: nobody → adw
Status: NEW → ASSIGNED
Flags: needinfo?(adw)
Assignee

Comment 5

9 months ago
Replacing onPlacedInPanel with onBeforePlacedInWindow is the right fix.

Comment 6

9 months ago
Comment on attachment 9003317 [details]
Bug 1483167 - Copy Link and Send Tab to Device page action button tooltips say "coypURL-title" and "sendToDevice-title"

:Gijs (he/him) has approved the revision.
Attachment #9003317 - Flags: review+

Comment 7

9 months ago
Pushed by dwillcoxon@mozilla.com:
https://hg.mozilla.org/integration/autoland/rev/68654fc447f8
Copy Link and Send Tab to Device page action button tooltips say "coypURL-title" and "sendToDevice-title" r=Gijs

Comment 8

9 months ago
bugherder
https://hg.mozilla.org/mozilla-central/rev/68654fc447f8
Status: ASSIGNED → RESOLVED
Last Resolved: 9 months ago
Resolution: --- → FIXED
Target Milestone: --- → Firefox 63
Flags: qe-verify+
Assignee

Updated

9 months ago
Duplicate of this bug: 1485348
We're building Fx62 RC builds at this point, so I think it's a bit late for uplift there. OTOH, I'm setting this to fix-optional to keep it on the radar as a possible dot release ride-along.

Comment 11

9 months ago
User Agent: Mozilla/5.0 (Macintosh; Intel Mac OS X 10.13; rv:63.0) Gecko/20100101 Firefox/63.0
Build ID: 20180904100126

Verified as fixed on the latest Nightly build. 
Tested on macOS, Windows and Ubuntu. 

Note: If this issue will be fixed in Beta (62) please add back the qe-verify+ tag because I've removed it.
Status: RESOLVED → VERIFIED
Flags: qe-verify+

Comment 12

9 months ago
Comment on attachment 9003317 [details]
Bug 1483167 - Copy Link and Send Tab to Device page action button tooltips say "coypURL-title" and "sendToDevice-title"

Approval Request Comment
[Feature/Bug causing the regression]: bug 1221539
[User impact if declined]: broken tooltips for page action items put in the URL bar.
[Is this code covered by automated tests?]: generally yes, not this specific bit
[Has the fix been verified in Nightly?]: yes
[Needs manual test from QE? If yes, steps to reproduce]: see comment #0 / comment 11.
[List of other uplifts needed for the feature/fix]: n/a
[Is the change risky?]: no
[Why is the change risky/not risky?]: relatively small + straightforward patch, already verified, js-only.
[String changes made/needed]: no
Attachment #9003317 - Flags: approval-mozilla-release?
Reporter

Updated

9 months ago
Blocks: 1489834
Comment on attachment 9003317 [details]
Bug 1483167 - Copy Link and Send Tab to Device page action button tooltips say "coypURL-title" and "sendToDevice-title"

fix broken tooltips, verified in 63, approved for 62.0.2
Attachment #9003317 - Flags: approval-mozilla-release? → approval-mozilla-release+

Comment 15

8 months ago
User Agent: Mozilla/5.0 (Macintosh; Intel Mac OS X 10.13; rv:62.0) Gecko/20100101 Firefox/62.0
Build ID: 20180920131237

Verified as fixed on the Release candidate build 62.0.2
Flags: qe-verify+
You need to log in before you can comment on or make changes to this bug.