Closed Bug 1489834 Opened Last year Closed Last year

Send Tab to Device page action button tooltips says "sendToDevice-title"

Categories

(Firefox :: Toolbars and Customization, defect, P1)

defect

Tracking

()

RESOLVED FIXED
Firefox 64
Tracking Status
firefox-esr60 --- unaffected
firefox62 --- unaffected
firefox63 --- unaffected
firefox64 --- fixed

People

(Reporter: dao, Assigned: adw)

References

Details

(Keywords: regression)

Attachments

(1 file)

+++ This bug was initially created as a clone of Bug #1483167 +++

Still seeing this in the current nightly.
(In reply to Dão Gottwald [::dao] from comment #0)
> +++ This bug was initially created as a clone of Bug #1483167 +++
> 
> Still seeing this in the current nightly.

Does this also affect 63?
Flags: needinfo?(dao+bmo)
Not seeing it there.
Flags: needinfo?(dao+bmo)
(In reply to Dão Gottwald [::dao] from comment #2)
> Not seeing it there.

Odd... do we think this re-regressed since bug 1483167?
Ni for comment #3...
Flags: needinfo?(dao+bmo)
FWIW, assuming the STR are to first add the Send Tab to Device pageAction to the Address Bar in order to see the tooltip, I'm not seeing this on the latest Windows, macOS or Linux Nightlies.
I see it.  I'm not sure what the problem is yet.  I verified that the other actions are fixed.
Assignee: nobody → adw
Status: NEW → ASSIGNED
Priority: -- → P1
The value of the sendToDevice-title attribute on the panel is "", so that's probably why.
Blocks: 1470555
No longer blocks: 1221539
Flags: needinfo?(dao+bmo)
Bug 1470555 has also caused another regression (bug 1489754). Feel free to back it out unless the fix here is easy.
Drew, do we think this is an easy fix or should we just back it out?
Flags: needinfo?(adw)
Yes, this should be an easy fix, and I'm hoping to have a patch ready today.
Flags: needinfo?(adw)
FYI, phabricator decided to post the patch for this in bug 1470555.
Bug 1470555 moved the title from a dtd to a properties file, so we can and should now set the action's title directly when the action is created in PageActions.jsm.  But it's a PluralForm string, so we need to jump through that hoop.
Drew: looks like this just needs update from jaws' comment on patch?
Flags: needinfo?(adw)
Yes, I updated the patch just now.  Try run: https://treeherder.mozilla.org/#/jobs?repo=try&revision=fba73975801884ec151f81db3cef7d7a86ccf451
Flags: needinfo?(adw)
Comment on attachment 9008770 [details]
Bug 1489834 - Fix the Send Tab to Device page action title and tooltip

Jared Wein [:jaws] (please needinfo? me) has approved the revision.
Attachment #9008770 - Flags: review+
There were some weird, unrelated-looking failures on that last try push.  Here's another one with a fresh tree: https://treeherder.mozilla.org/#/jobs?repo=try&revision=c8613e6817abd0235546329a90aff0e0d0a50500
Pushed by dwillcoxon@mozilla.com:
https://hg.mozilla.org/integration/autoland/rev/2fab03252db7
Fix the Send Tab to Device page action title and tooltip r=jaws
https://hg.mozilla.org/mozilla-central/rev/2fab03252db7
Status: ASSIGNED → RESOLVED
Closed: Last year
Resolution: --- → FIXED
Target Milestone: --- → Firefox 64
You need to log in before you can comment on or make changes to this bug.