Firefox window-buttons don't follow the gnome-shell window-buttons placement configuration

RESOLVED DUPLICATE of bug 1433667

Status

()

defect
RESOLVED DUPLICATE of bug 1433667
11 months ago
10 months ago

People

(Reporter: mohos.nas, Unassigned)

Tracking

(Blocks 1 bug)

61 Branch
Points:
---
Dependency tree / graph

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment)

Reporter

Description

11 months ago
User Agent: Mozilla/5.0 (X11; Fedora; Linux x86_64; rv:61.0) Gecko/20100101 Firefox/61.0
Build ID: 20180723085942

Steps to reproduce:

I have an up-to-date Fedora 28 Linux with GNOME DE. I've set window-buttons (close, minimize, maximize) placement to Left side of  the window position in gnome-tweaks. The window-buttons placement works fine when Title bar check-box is checked in Menu> Customize (Firefox title bar is present).


Actual results:

But When I un-check the Title-bar check-box in Menu> Customize (actually it's now in the CSD view (means no title bar is present)) the window buttons position turn to right  for Firefox while the placement configuration in gnome-tweaks is set to Left side and all applications are following the gnome-tweaks configurations except Firefox!


Expected results:

The window buttons position for Firefox window should be stay in left side when firefox is showing in CSD view (meant no title bar). 
At last I'm going to attach a screen shot of this bug (Chrome behaviour VS. Firefox behaviour both in CSD view).
Hope to be fixed soon.

Updated

11 months ago
Component: Untriaged → Theme

Updated

11 months ago
Blocks: gtktitlebar
Component: Theme → Widget: Gtk
Product: Firefox → Core
Reporter

Comment 1

10 months ago
Also I'm sure that it's not related to any of various theme parts (I've already tried this matter on three devices with different distro but with the same firefox version. All the results were same as each other!)
Yes, this is a dupe of Bug 1433667. We don't support the left button placement now.
Status: UNCONFIRMED → RESOLVED
Closed: 10 months ago
Resolution: --- → DUPLICATE
Duplicate of bug: 1433667
Reporter

Comment 3

10 months ago
Ok! But it would be better to support this feature correctly on various Linux desktops since this feature is working as it should on OS X and Window 10!
You need to log in before you can comment on or make changes to this bug.