Medium.com's undo/redo is not working on FF Nightly for 2 months

RESOLVED FIXED

Status

defect
P1
normal
RESOLVED FIXED
11 months ago
5 months ago

People

(Reporter: dumindu.madunuwan, Assigned: adamopenweb)

Tracking

({regression, site-compat})

Firefox 63
Dependency tree / graph

Firefox Tracking Flags

(firefox61 unaffected, firefox62 unaffected, firefox63 disabled, firefox64 disabled, firefox65 fixed)

Details

User Agent: Mozilla/5.0 (Macintosh; Intel Mac OS X 10.13; rv:63.0) Gecko/20100101 Firefox/63.0
Build ID: 20180815100249

Steps to reproduce:

Related with https://www.reddit.com/r/firefox/comments/92j1ob/mediumcoms_undoredo_is_not_working_on_ff_nightly/ ,

* Create a new story on Medium.com using FF Nightly
* Make some changes like add inline code blocks or few words
* test undo/ redo functionality via key board shortcuts




Actual results:

Undo/ redo works only for last word change, sometimes totally not working as well.


Expected results:

undo/ redo functionality should work on nightly
This is due to Bug 1440189. Flipping the dom.keyboardevent.keypress.dispatch_non_printable_keys_only_system_group_in_content pref or adding `medium.com/p/` to the dom.keyboardevent.keypress.hack.dispatch_non_printable_keys pref works around the issue.
Blocks: 1440189
Component: Editor → DOM: Events
Flags: needinfo?(edilee) → needinfo?(masayuki)
cc'ing astevenson, in case we have some contacts at Medium and they can fix it on their side like we did with GDocs?
Flags: needinfo?(astevenson)
I don't have a contact at Medium unfortunately, but have sent a message to Medium support as well.
Flags: needinfo?(astevenson)
Was contacted back by a Medium engineer today, provided the details of this report.
Thanks Kohei, I actually shared that link with them already. :)
Hi Adam, any update from Medium folks?
Flags: needinfo?(astevenson)
Still having same issue btw
They are looking into the issue and have been active in communicating back with us. Will update when I have more info to share.
Flags: needinfo?(astevenson)
:kohei, can we close this now that Bug 1440189 is fixed? It doesn't reproduce on Nightly any longer at least.
Flags: needinfo?(kohei.yoshino)
No, it’s a regression introduced by Bug 1440189. I can still produce the issue. If it takes time for Medium to fix the issue, we have to add an exception like Etherpad and others. Otherwise, this bug should fall under Tech Evangelism.
Flags: needinfo?(kohei.yoshino)
As Kohei informed, this is still reproducible in Nightly and I faced this issue at least for 2 months in Nightly now. It's so grateful if Mozilla can fix this from browser side. Thanks
According to comment #2 and comment #13, could you take a look? Thank you so much.
Flags: needinfo?(masayuki)
Priority: -- → P3
This needs to be fixed from the Medium end. Bug 1440189 simply brings Gecko into line with the spec and other engines. We are not shipping it to release, however, until major Web compat issues such as this are resolved.
Flags: needinfo?(masayuki)
Yes, this needs to be fixed by Medium. On the other hand, we should add medium.com into the blacklist for avoiding inconvenience of Nightly testers (I thought that they'd fix the bug quickly).
Assignee: nobody → astevenson
Status: NEW → ASSIGNED
Component: DOM: Events → Desktop
Priority: P3 → --
Product: Core → Tech Evangelism
Version: 63 Branch → Firefox 63
I landed the patch for bug 1495627 to disable the new behavior only under "medium.com/p/". Therefore, staff of Medium will be not able to reproduce this bug with tomorrow's Nightly and newer. So, could you let them know that they need to remove ",medium.com/p/" from "dom.keyboardevent.keypress.hack.dispatch_non_printable_keys" in about:config.
Flags: needinfo?(astevenson)
Thanks Masayuki! Will let them know.
Flags: needinfo?(astevenson)
Thanks for everyone for checking this and adding a patch from Nightly side. undo/ redo functionalities are now working perfectly on Nightly.
Looks like that undo/redo work fine with Nightly even if medium.com is removed from the blacklist. Did you get some replay from them?
Flags: needinfo?(astevenson)
I know they were working on a patch, but hadn't heard back. Just pinged them again. Thanks for the follow up. :)
Flags: needinfo?(astevenson)
They've confirmed that they fixed this issue. Closing this report as Fixed.
Status: ASSIGNED → RESOLVED
Closed: 8 months ago
Resolution: --- → FIXED
Product: Tech Evangelism → Web Compatibility
You need to log in before you can comment on or make changes to this bug.