Add search filter, search pref and bug fixes to Activity Stream

VERIFIED FIXED in Firefox 63

Status

()

enhancement
VERIFIED FIXED
11 months ago
18 days ago

People

(Reporter: Mardak, Assigned: Mardak)

Tracking

unspecified
Firefox 63
Points:
---
Dependency tree / graph

Firefox Tracking Flags

(firefox63 fixed)

Details

(Whiteboard: [export])

User Story

https://github.com/mozilla/activity-stream/compare/ce7ded0ac20f37f5a4d1e8c68664ca134e7faa77...65eacf8eef567356aef588c63c902dc50ccbd224

Attachments

(1 attachment, 1 obsolete attachment)

No description provided.
No longer depends on: 1437671
No longer depends on: 1476055
No longer depends on: 1476450
Depends on: 1479478
No longer depends on: 1479413
MozReview-Commit-ID: ANMt3NGC8HY
Comment on attachment 8998301 [details]
Bug 1481559 - Add search filter, search pref and bug fixes to Activity Stream

Ursula Sarracini (:ursula) has approved the revision.

https://phabricator.services.mozilla.com/D2878
Attachment #8998301 - Flags: review+
Summary: Add ... and bug fixes to Activity Stream → Add search filter, search pref and bug fixes to Activity Stream
Assignee: nobody → edilee
User Story: (updated)
Attachment #8998301 - Attachment description: Bug 1481559 - Add ... and bug fixes to Activity Stream. r?k88hudson → Bug 1481559 - Add search filter, search pref and bug fixes to Activity Stream
Pushed by usarracini@mozilla.com:
https://hg.mozilla.org/integration/autoland/rev/ce04f86f84f4
Add search filter, search pref and bug fixes to Activity Stream r=ursula
https://hg.mozilla.org/mozilla-central/rev/ce04f86f84f4
Status: NEW → RESOLVED
Closed: 11 months ago
Resolution: --- → FIXED
Target Milestone: --- → Firefox 63
Backed out for browser_preferences_usage.js failures.

backout: https://hg.mozilla.org/mozilla-central/rev/ec96693b39bedee0114f444d3ce37ab0d98d6b06

push with failures: https://treeherder.mozilla.org/#/jobs?repo=mozilla-central&revision=7d78ffbf4c4a31bfc808e80ea09c6c131328c4ad&filter-resultStatus=testfailed&filter-resultStatus=busted&filter-resultStatus=exception

failure log: https://treeherder.mozilla.org/logviewer.html#?job_id=192727360&repo=mozilla-central&lineNumber=1845

00:07:44     INFO - TEST-PASS | browser/base/content/test/performance/browser_preferences_usage.js | You need to run this test on a debug build. - 
00:07:44     INFO - Leaving test bound debug_only
00:07:44     INFO - Entering test bound startup
00:07:44     INFO - TEST-PASS | browser/base/content/test/performance/browser_preferences_usage.js | startupRecorder has prefStats - 
00:07:44     INFO - Buffered messages finished
00:07:44     INFO - TEST-UNEXPECTED-FAIL | browser/base/content/test/performance/browser_preferences_usage.js | Whitelist item network.loadinfo.skip_type_assertion should be accessed at most 650 times. - 652 <= 650 - JS frame :: chrome://mochitests/content/browser/browser/base/content/test/performance/browser_preferences_usage.js :: checkPrefGetters :: line 46
00:07:44     INFO - Stack trace:
00:07:44     INFO - chrome://mochitests/content/browser/browser/base/content/test/performance/browser_preferences_usage.js:checkPrefGetters:46
00:07:44     INFO - chrome://mochitests/content/browser/browser/base/content/test/performance/browser_preferences_usage.js:startup:106
00:07:44     INFO - chrome://mochikit/content/browser-test.js:Tester_execTest/<:1103
00:07:44     INFO - chrome://mochikit/content/browser-test.js:Tester_execTest:1094
00:07:44     INFO - chrome://mochikit/content/browser-test.js:nextTest/<:996
00:07:44     INFO - chrome://mochikit/content/tests/SimpleTest/SimpleTest.js:SimpleTest.waitForFocus/waitForFocusInner/focusedOrLoaded/<:795
00:07:44     INFO - TEST-PASS | browser/base/content/test/performance/browser_preferences_usage.js | Whitelist item browser.startup.record should be accessed at least 200 times. - 200 <= 269 - 
00:07:44     INFO - TEST-PASS | browser/base/content/test/performance/browser_preferences_usage.js | Whitelist item browser.startup.record should be accessed at most 350 times. - 269 <= 350 - 
00:07:44     INFO - TEST-PASS | browser/base/content/test/performance/browser_preferences_usage.js | Whitelist item browser.search.log should be accessed at least 100 times. - 100 <= 190 - 
00:07:44     INFO - Not taking screenshot here: see the one that was previously logged
00:07:44     INFO - TEST-UNEXPECTED-FAIL | browser/base/content/test/performance/browser_preferences_usage.js | Whitelist item browser.search.log should be accessed at most 150 times. - 190 <= 150 - JS frame :: chrome://mochitests/content/browser/browser/base/content/test/performance/browser_preferences_usage.js :: checkPrefGetters :: line 46
00:07:44     INFO - Stack trace:
00:07:44     INFO - chrome://mochitests/content/browser/browser/base/content/test/performance/browser_preferences_usage.js:checkPrefGetters:46
00:07:44     INFO - chrome://mochitests/content/browser/browser/base/content/test/performance/browser_preferences_usage.js:startup:106
00:07:44     INFO - chrome://mochikit/content/browser-test.js:Tester_execTest/<:1103
00:07:44     INFO - chrome://mochikit/content/browser-test.js:Tester_execTest:1094
00:07:44     INFO - chrome://mochikit/content/browser-test.js:nextTest/<:996
00:07:44     INFO - chrome://mochikit/content/tests/SimpleTest/SimpleTest.js:SimpleTest.waitForFocus/waitForFocusInner/focusedOrLoaded/<:795
00:07:44     INFO - TEST-PASS | browser/base/content/test/performance/browser_preferences_usage.js | Whitelist item layout.css.prefixes.webkit should be accessed at least 135 times. - 135 <= 168 -
Flags: needinfo?(edilee)
Status: RESOLVED → REOPENED
Resolution: FIXED → ---
Posted file Increase limit for pref access (obsolete) —
https://bugzilla.mozilla.org/show_bug.cgi?id=1481559 Got backed out because of too many pref accesses.
browser.search.log should be accessed at most 150 times 
This is caused by our usage of `Services.search.currentEngine.searchForm` and will be fixed by https://bugzilla.mozilla.org/show_bug.cgi?id=1481447
network.loadinfo.skip_type_assertion should be accessed at most 650 times.
This is caused by adding new resources that we access `data/content/assets/glyph-pocket-save-16.svg`
Added andreio's patch with some increased numbers https://treeherder.mozilla.org/#/jobs?repo=try&revision=3238997de8e0299e566c1da9d8e8dc4431d4d921
Flags: needinfo?(edilee)
Pushed by elee@mozilla.com:
https://hg.mozilla.org/integration/autoland/rev/f99759ea7410
Add search filter, search pref and bug fixes to Activity Stream r=ursula
https://hg.mozilla.org/mozilla-central/rev/f99759ea7410
Status: REOPENED → RESOLVED
Closed: 11 months ago11 months ago
Resolution: --- → FIXED
Blocks: 1482205
Attachment #8998531 - Attachment is obsolete: true
Marking this qe-verify + until all the actionable dependencies are verified.
Flags: qe-verify+
Whiteboard: [export]
No longer depends on: 1485999
Whiteboard: [export] → [export][qa-triaged]

Marking issue as verified and clearing flag since all the manually actionable dependencies have been checked.

Status: RESOLVED → VERIFIED
Flags: qe-verify+
QA Whiteboard: [qa-triaged]
Whiteboard: [export][qa-triaged] → [export]
Component: Activity Streams: Newtab → New Tab Page
You need to log in before you can comment on or make changes to this bug.