When menu dropped down, selection in wrong place

VERIFIED DUPLICATE of bug 14841

Status

SeaMonkey
General
P3
normal
VERIFIED DUPLICATE of bug 14841
18 years ago
13 years ago

People

(Reporter: cpratt, Assigned: saari (gone))

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

18 years ago
Build ID: 1999092408
Platform: all

To reproduce:
- Launch apprunner
- Press Alt+E to drop down the Edit menu

Result: 'Wallet' receives focus/selection.

Expected result: 'Undo' should receive focus/selection - even if it's disabled.
This is standard behavior for other applications.

Updated

18 years ago
Assignee: shuang → saari
(Assignee)

Updated

18 years ago
Status: NEW → ASSIGNED
Target Milestone: M12

Comment 1

18 years ago
this is essentially the same problem as Bug 14841 no? That is to say that
disabled menuitems are being ignored by whatever system is used to order
these things. I believe this bug should be duped.
(Reporter)

Comment 2

18 years ago
They're related.
14839 - When a menu is dropped down using the keyboard, selection/focus should
be on the first item even if it is disabled
14841 - Keyboard navigation of menus skips disabled items (but it shouldn't)
I don't see them as duplicates but then again I wouldn't have filed them both if
I'd believe that. saari?

Comment 3

18 years ago
mass-moving all m12 bugs to m13
(Assignee)

Updated

18 years ago
Status: ASSIGNED → RESOLVED
Last Resolved: 18 years ago
Resolution: --- → DUPLICATE
(Assignee)

Comment 4

18 years ago
Yeah, these bugs are the same. Closing this one as a dup of 14841

Incidentally, I like the keyboard navigation skipping the disabled items. Why
waste time with them? But far be it for xptoolkit to fly in the face of
tradition. Ahem.


*** This bug has been marked as a duplicate of 14841 ***
(Reporter)

Updated

18 years ago
Status: RESOLVED → VERIFIED
(Reporter)

Comment 5

18 years ago
Marking verified. I understand and sympathize with saari on this - but honest,
it's disorienting and confusing when the menus don't behave like other apps! :)

Comment 6

18 years ago
Moving all UE/UI bugs to new component: User Interface: Design Feedback
UE/UI component will be deleted.
Component: UE/UI → User Interface: Design Feedback

Updated

15 years ago
Component: User Interface Design → Browser-General
Product: Browser → Seamonkey
You need to log in before you can comment on or make changes to this bug.