pictures in the png make trobules when i use them for background in a table

VERIFIED DUPLICATE of bug 137223

Status

Core Graveyard
GFX
VERIFIED DUPLICATE of bug 137223
16 years ago
9 years ago

People

(Reporter: kb, Assigned: dcone (gone))

Tracking

Trunk
x86
Windows 2000

Firefox Tracking Flags

(Not tracked)

Details

(URL)

(Reporter)

Description

16 years ago
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.0rc3)
Gecko/20020523
BuildID:    200220052306

i want to use a png picture for a background in a table, like a gif or jpg. one
time, i do this, it worked. At a table, over the table with the png background i
take a gif as background. no problems. 
But if i take a png for a background for a table, and take over this table
another table with a png as background, too. then theirs a bug.
i have used mozilla 0.98, and he crashed. Then i use mozilla 1.0 RC3, theirs
stripes in gray, silver, black and white. like in this screenshot: 
http://cs-lamer.com/sub_kb/htdocs/@work/mozillaproblem.jpg
when i scroll down, theirs no more backgrounds. when i press reload, then
background on the area, wheres displayed right now when i reload, but when i
scoll up, theirs problems again. 


i have used mozilla 0.98 on windows 2000. in linux theirs no problems (a friend
tested it for me)

Reproducible: Sometimes
Steps to Reproduce:
i press reload.

Actual Results:  theirs the most ok, on the area wheres displayed before i press
reload, when i scroll down, then theirs problems and problems.

Expected Results:  i think its a problem with the graphik interpreter or so, its
just this bug if one png backgrounds over an other.

i said the most in the 'discription field'

i want to use a png picture for a background in a table, like a gif or jpg. one
time, i do this, it worked. At a table, over the table with the png background i
take a gif as background. no problems. 
But if i take a png for a background for a table, and take over this table
another table with a png as background, too. then theirs a bug.
i have used mozilla 0.98, and he crashed. Then i use mozilla 1.0 RC3, theirs
stripes in gray, silver, black and white. like in this screenshot: 
http://cs-lamer.com/sub_kb/htdocs/@work/mozillaproblem.jpg
when i scroll down, theirs no more backgrounds. when i press reload, then
background on the area, wheres displayed right now when i reload, but when i
scoll up, theirs problems again. 


i have used mozilla 0.98 on windows 2000. in linux theirs no problems (a friend
tested it for me)




sorry for my bad englisch, but i do all for helping mozilla and supporting.

if their some questions, you can mail me at kb@deusexx.de (double 'x' is right so!)

Comment 1

16 years ago
Confirming it. Using 2002053106 - WinXP.

Tried in IE 6.0 (yuck !), and result was perfect :-/
Status: UNCONFIRMED → NEW
Ever confirmed: true

Comment 2

16 years ago
I'm also seeing this, with 2002053006 on Win98SE. I do not get the vertical
lines / stripes seen in the screenshot, however - for me, the BG in those two
areas just disappears when it is scrolled offscreen or covered with another
window. Highlighting the text reveals the BG, but only in the areas directly
beneath the highlghted text.
Reassigning to dcone.
Assignee: kmcclusk → dcone
(Assignee)

Comment 4

16 years ago
this has been fixed on the trunk.. trying to get this in on the branch..needs 
approval.  There are a few PNG bugs that address this.. and all those have to be 
put into the branch.  bugs 125629 and 137223 come to mind.

*** This bug has been marked as a duplicate of 137223 ***
Status: NEW → RESOLVED
Last Resolved: 16 years ago
Resolution: --- → DUPLICATE

Comment 5

16 years ago
Verified Duplicate
Status: RESOLVED → VERIFIED
Product: Core → Core Graveyard
You need to log in before you can comment on or make changes to this bug.