Closed Bug 1484230 Opened 3 years ago Closed 3 years ago

Raptor should verify the geckoview app exists on device first

Categories

(Testing :: Raptor, defect)

Version 3
defect
Not set
normal

Tracking

(Not tracked)

RESOLVED DUPLICATE of bug 1486908

People

(Reporter: rwood, Assigned: egao)

References

Details

i.e. use mozdevice.ADBAndroid.is_app_installed
Blocks: 1473078
Depends on: 1480841
Assignee: nobody → egao
Damn, I actually filed a dupe and attached a patch in bug 1486908. You can see the patch there at attachment 9004661 [details] [diff] [review] in bug 1486908.

+            # check geckoview is installed
+            if not ADBAndroid.is_app_installed(self.device, 'geckoview'):
+                self.log.info('geckoview is not installed on device')
             self.device.clear_logcat()


The test should have been 

if not self.device.is_app_installed(self.config['binary']):
    self.log.error('geckoview is not installed on device')

is_app_installed requires the full app name which in our case is passed by the self.config['binary'] and will be org.mozilla.geckoview_example.

Even with this patch, we would still hit the hang described in bug 1486908 because we don't terminate the test.

Try won't work for raptor + android until we get bitbar support working. You'll need to test locally with a device for the moment.

I hate to do it but I'm going to dupe this to bug 1486908. Let's chat when you get in today.
Status: NEW → RESOLVED
Closed: 3 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 1486908
You need to log in before you can comment on or make changes to this bug.